New version
Resolves: rhbz#1985778
This commit is contained in:
parent
9a503d16ae
commit
87cce946ef
43
postfix-3.6.2-glibc-234-build-fix.patch
Normal file
43
postfix-3.6.2-glibc-234-build-fix.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
diff --git a/src/util/sys_compat.c b/src/util/sys_compat.c
|
||||||
|
index 8bf8e58..c87f043 100644
|
||||||
|
--- a/src/util/sys_compat.c
|
||||||
|
+++ b/src/util/sys_compat.c
|
||||||
|
@@ -286,7 +286,7 @@ int dup2_pass_on_exec(int oldd, int newd)
|
||||||
|
|
||||||
|
/* closefrom() - closes all file descriptors from the given one up */
|
||||||
|
|
||||||
|
-int closefrom(int lowfd)
|
||||||
|
+void closefrom(int lowfd)
|
||||||
|
{
|
||||||
|
int fd_limit = open_limit(0);
|
||||||
|
int fd;
|
||||||
|
@@ -298,14 +298,14 @@ int closefrom(int lowfd)
|
||||||
|
*/
|
||||||
|
if (lowfd < 0) {
|
||||||
|
errno = EBADF;
|
||||||
|
- return (-1);
|
||||||
|
+ return;
|
||||||
|
}
|
||||||
|
if (fd_limit > 500)
|
||||||
|
fd_limit = 500;
|
||||||
|
for (fd = lowfd; fd < fd_limit; fd++)
|
||||||
|
(void) close(fd);
|
||||||
|
|
||||||
|
- return (0);
|
||||||
|
+ return;
|
||||||
|
}
|
||||||
|
|
||||||
|
#endif
|
||||||
|
diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h
|
||||||
|
index 99bec9b..16e27db 100644
|
||||||
|
--- a/src/util/sys_defs.h
|
||||||
|
+++ b/src/util/sys_defs.h
|
||||||
|
@@ -1509,7 +1509,7 @@ extern int setsid(void);
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef HAS_CLOSEFROM
|
||||||
|
-extern int closefrom(int);
|
||||||
|
+extern void closefrom(int);
|
||||||
|
|
||||||
|
#endif
|
||||||
|
|
12
postfix.spec
12
postfix.spec
@ -48,8 +48,8 @@
|
|||||||
|
|
||||||
Name: postfix
|
Name: postfix
|
||||||
Summary: Postfix Mail Transport Agent
|
Summary: Postfix Mail Transport Agent
|
||||||
Version: 3.6.1
|
Version: 3.6.2
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
URL: http://www.postfix.org
|
URL: http://www.postfix.org
|
||||||
License: (IBM and GPLv2+) or (EPL-2.0 and GPLv2+)
|
License: (IBM and GPLv2+) or (EPL-2.0 and GPLv2+)
|
||||||
@ -94,6 +94,9 @@ Patch9: pflogsumm-1.1.5-datecalc.patch
|
|||||||
# rhbz#1384871, sent upstream
|
# rhbz#1384871, sent upstream
|
||||||
Patch10: pflogsumm-1.1.5-ipv6-warnings-fix.patch
|
Patch10: pflogsumm-1.1.5-ipv6-warnings-fix.patch
|
||||||
Patch11: postfix-3.4.4-chroot-example-fix.patch
|
Patch11: postfix-3.4.4-chroot-example-fix.patch
|
||||||
|
# bug report sent upstream, the fedora patch is a hack,
|
||||||
|
# please do not reuse ;)
|
||||||
|
Patch12: postfix-3.6.2-glibc-234-build-fix.patch
|
||||||
|
|
||||||
# Optional patches - set the appropriate environment variables to include
|
# Optional patches - set the appropriate environment variables to include
|
||||||
# them when building the package/spec file
|
# them when building the package/spec file
|
||||||
@ -244,6 +247,7 @@ pushd pflogsumm-%{pflogsumm_ver}
|
|||||||
popd
|
popd
|
||||||
%endif
|
%endif
|
||||||
%patch11 -p1 -b .chroot-example-fix
|
%patch11 -p1 -b .chroot-example-fix
|
||||||
|
%patch12 -p1 -b .glibc-234-build-fix
|
||||||
|
|
||||||
for f in README_FILES/TLS_{LEGACY_,}README TLS_ACKNOWLEDGEMENTS; do
|
for f in README_FILES/TLS_{LEGACY_,}README TLS_ACKNOWLEDGEMENTS; do
|
||||||
iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
|
iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
|
||||||
@ -791,6 +795,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 29 2021 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.6.2-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1985778
|
||||||
|
|
||||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2:3.6.1-3
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2:3.6.1-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
|||||||
SHA512 (postfix-3.6.1.tar.gz) = 6f83a6aa55bd442fe005b35c7470483ff5ba6781121f783b07ef454580354fc5c85d0d5106936810d6bef0f5592937f0863eec3b82e138caac7694e2a3bb7bc3
|
SHA512 (postfix-3.6.2.tar.gz) = 464ce9ec77e637ede91123472a0383b2bfda52102f9e9852c7191016d4fda2e14f302f2db9793887c182688c2a14dde6eeda728523196a627a8028f99555a4d9
|
||||||
SHA512 (pflogsumm-1.1.5.tar.gz) = 994d660692dfea38a1dd9866d15f15035657e85131c1f5a2cd82baa5bd4ad987a00939cb5233f316d2090014c52ae68ef20db0c893f8634969484e0e74678f4d
|
|
||||||
|
Loading…
Reference in New Issue
Block a user