New version
Resolves: rhbz#1006005 - Defuzzified patches
This commit is contained in:
parent
6d7ac2de90
commit
7ae72294aa
@ -1,7 +1,8 @@
|
||||
diff -up postfix-2.6.1/conf/postfix-files.files postfix-2.6.1/conf/postfix-files
|
||||
--- postfix-2.6.1/conf/postfix-files.files 2009-02-14 03:08:16.000000000 +0100
|
||||
+++ postfix-2.6.1/conf/postfix-files 2009-05-26 11:29:57.000000000 +0200
|
||||
@@ -111,20 +111,14 @@ $command_directory/postqueue:f:root:$set
|
||||
diff --git a/conf/postfix-files b/conf/postfix-files
|
||||
index 90ef957..6bced7f 100644
|
||||
--- a/conf/postfix-files
|
||||
+++ b/conf/postfix-files
|
||||
@@ -114,20 +114,14 @@ $command_directory/postqueue:f:root:$setgid_group:2755:u
|
||||
$sendmail_path:f:root:-:755
|
||||
$newaliases_path:l:$sendmail_path
|
||||
$mailq_path:l:$sendmail_path
|
||||
@ -22,7 +23,7 @@ diff -up postfix-2.6.1/conf/postfix-files.files postfix-2.6.1/conf/postfix-files
|
||||
$config_directory/master.cf:f:root:-:644:p
|
||||
$config_directory/pcre_table:f:root:-:644:o
|
||||
$config_directory/postfix-files:f:root:-:644:o
|
||||
@@ -137,8 +131,8 @@ $config_directory/postfix-script:f:root:
|
||||
@@ -140,8 +134,8 @@ $config_directory/postfix-script:f:root:-:755:o
|
||||
$config_directory/postfix-script-sgid:f:root:-:755:o
|
||||
$config_directory/postfix-script-nosgid:f:root:-:755:o
|
||||
$config_directory/post-install:f:root:-:755:o
|
||||
@ -33,7 +34,7 @@ diff -up postfix-2.6.1/conf/postfix-files.files postfix-2.6.1/conf/postfix-files
|
||||
$manpage_directory/man1/postalias.1:f:root:-:644
|
||||
$manpage_directory/man1/postcat.1:f:root:-:644
|
||||
$manpage_directory/man1/postconf.1:f:root:-:644
|
||||
@@ -151,9 +145,9 @@ $manpage_directory/man1/postmap.1:f:root
|
||||
@@ -154,9 +148,9 @@ $manpage_directory/man1/postmap.1:f:root:-:644
|
||||
$manpage_directory/man1/postmulti.1:f:root:-:644
|
||||
$manpage_directory/man1/postqueue.1:f:root:-:644
|
||||
$manpage_directory/man1/postsuper.1:f:root:-:644
|
@ -1,9 +1,11 @@
|
||||
Changing the postfix-files config file won't work right on upgrades because
|
||||
it's a noreplace configuration (the new version with the right paths in it is
|
||||
installed as postfix-files.rpmnew), so we just munge the post-install script.
|
||||
--- postfix-1.1.3/conf/post-install Thu Feb 28 16:15:08 2002
|
||||
+++ postfix-1.1.3/conf/post-install Thu Feb 28 16:14:54 2002
|
||||
@@ -429,6 +429,16 @@
|
||||
diff --git a/conf/post-install b/conf/post-install
|
||||
index 91ff4a6..f78d820 100644
|
||||
--- a/conf/post-install
|
||||
+++ b/conf/post-install
|
||||
@@ -480,6 +480,16 @@ test -n "$create" && {
|
||||
case $path in
|
||||
no|no/*) continue;;
|
||||
esac
|
||||
|
@ -1,21 +1,8 @@
|
||||
diff -up postfix-2.5.5/src/util/sys_defs.h.large-fs postfix-2.5.5/src/util/sys_defs.h
|
||||
--- postfix-2.5.5/src/util/sys_defs.h.large-fs 2008-01-15 01:51:44.000000000 +0100
|
||||
+++ postfix-2.5.5/src/util/sys_defs.h 2008-10-21 17:55:29.000000000 +0200
|
||||
@@ -709,8 +709,8 @@ extern int initgroups(const char *, int)
|
||||
#define GETTIMEOFDAY(t) gettimeofday(t,(struct timezone *) 0)
|
||||
#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin"
|
||||
#define FIONREAD_IN_TERMIOS_H
|
||||
-#define USE_STATFS
|
||||
-#define STATFS_IN_SYS_VFS_H
|
||||
+#define USE_STATVFS
|
||||
+#define STATVFS_IN_SYS_STATVFS_H
|
||||
#define PREPEND_PLUS_TO_OPTSTRING
|
||||
#define HAS_POSIX_REGEXP
|
||||
#define NATIVE_SENDMAIL_PATH "/usr/sbin/sendmail"
|
||||
diff -up postfix-2.5.5/src/util/fsspace.c.large-fs postfix-2.5.5/src/util/fsspace.c
|
||||
--- postfix-2.5.5/src/util/fsspace.c.large-fs 2006-06-15 20:07:16.000000000 +0200
|
||||
+++ postfix-2.5.5/src/util/fsspace.c 2008-10-21 17:56:29.000000000 +0200
|
||||
@@ -91,8 +91,15 @@ void fsspace(const char *path, struct
|
||||
diff --git a/src/util/fsspace.c b/src/util/fsspace.c
|
||||
index 50a4aa7..beef3db 100644
|
||||
--- a/src/util/fsspace.c
|
||||
+++ b/src/util/fsspace.c
|
||||
@@ -91,8 +91,15 @@ void fsspace(const char *path, struct fsspace * sp)
|
||||
|
||||
if (statvfs(path, &fsbuf) < 0)
|
||||
msg_fatal("statvfs %s: %m", path);
|
||||
@ -33,3 +20,18 @@ diff -up postfix-2.5.5/src/util/fsspace.c.large-fs postfix-2.5.5/src/util/fsspac
|
||||
#endif
|
||||
if (msg_verbose)
|
||||
msg_info("%s: %s: block size %lu, blocks free %lu",
|
||||
diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h
|
||||
index 00cbdc2..361eac1 100644
|
||||
--- a/src/util/sys_defs.h
|
||||
+++ b/src/util/sys_defs.h
|
||||
@@ -761,8 +761,8 @@ extern int initgroups(const char *, int);
|
||||
#define GETTIMEOFDAY(t) gettimeofday(t,(struct timezone *) 0)
|
||||
#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin"
|
||||
#define FIONREAD_IN_TERMIOS_H
|
||||
-#define USE_STATFS
|
||||
-#define STATFS_IN_SYS_VFS_H
|
||||
+#define USE_STATVFS
|
||||
+#define STATVFS_IN_SYS_STATVFS_H
|
||||
#define PREPEND_PLUS_TO_OPTSTRING
|
||||
#define HAS_POSIX_REGEXP
|
||||
#define NATIVE_SENDMAIL_PATH "/usr/sbin/sendmail"
|
||||
|
11
postfix.spec
11
postfix.spec
@ -37,8 +37,8 @@
|
||||
|
||||
Name: postfix
|
||||
Summary: Postfix Mail Transport Agent
|
||||
Version: 2.10.1
|
||||
Release: 7%{?dist}
|
||||
Version: 2.10.2
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.postfix.org
|
||||
@ -78,7 +78,7 @@ Source101: postfix-pam.conf
|
||||
# Patches
|
||||
|
||||
Patch1: postfix-2.10.0-config.patch
|
||||
Patch2: postfix-2.6.1-files.patch
|
||||
Patch2: postfix-2.10.2-files.patch
|
||||
Patch3: postfix-alternatives.patch
|
||||
Patch8: postfix-large-fs.patch
|
||||
Patch9: pflogsumm-1.1.3-datecalc.patch
|
||||
@ -526,6 +526,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Sep 16 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2:2.10.2-1
|
||||
- New version
|
||||
Resolves: rhbz#1006005
|
||||
- Defuzzified patches
|
||||
|
||||
* Mon Aug 12 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2:2.10.1-7
|
||||
- Minor changes to macros regarding hardened build
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user