New version
Resolves: rhbz#1270577 - Dropped reset-errno-before-readdir patch (upstreamed)
This commit is contained in:
parent
6a7fc222d1
commit
636b014d44
@ -1,22 +0,0 @@
|
|||||||
This patch comes from Mika Ilmaranta who attched it to the bug
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=1204139.
|
|
||||||
|
|
||||||
--- postfix-3.0.1/src/util/scan_dir.c 2015-04-21 20:44:19.985338673 +0300
|
|
||||||
+++ postfix-3.0.1/src/util/scan_dir.c.reset-errno-before-readdir 2015-04-21 20:47:32.791855824 +0300
|
|
||||||
@@ -78,6 +78,7 @@
|
|
||||||
#endif
|
|
||||||
#endif
|
|
||||||
#include <string.h>
|
|
||||||
+#include <errno.h>
|
|
||||||
|
|
||||||
/* Utility library. */
|
|
||||||
|
|
||||||
@@ -177,6 +178,8 @@ char *scan_dir_next(SCAN_DIR *scan)
|
|
||||||
#define STREQ(x,y) (strcmp((x),(y)) == 0)
|
|
||||||
|
|
||||||
if (info) {
|
|
||||||
+ /* Some implementations report spurious errors. */
|
|
||||||
+ errno = 0;
|
|
||||||
while ((dp = readdir(info->dir)) != 0) {
|
|
||||||
if (STREQ(dp->d_name, ".") || STREQ(dp->d_name, "..")) {
|
|
||||||
if (msg_verbose > 1)
|
|
13
postfix.spec
13
postfix.spec
@ -41,8 +41,8 @@
|
|||||||
|
|
||||||
Name: postfix
|
Name: postfix
|
||||||
Summary: Postfix Mail Transport Agent
|
Summary: Postfix Mail Transport Agent
|
||||||
Version: 3.0.2
|
Version: 3.0.3
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.postfix.org
|
URL: http://www.postfix.org
|
||||||
@ -85,9 +85,6 @@ Patch1: postfix-3.0.0-config.patch
|
|||||||
Patch2: postfix-3.0.0-files.patch
|
Patch2: postfix-3.0.0-files.patch
|
||||||
Patch3: postfix-3.0.2-alternatives.patch
|
Patch3: postfix-3.0.2-alternatives.patch
|
||||||
Patch4: postfix-3.0.0-large-fs.patch
|
Patch4: postfix-3.0.0-large-fs.patch
|
||||||
# The patch below resets the global errno variable to 0 before calling
|
|
||||||
# readdir(). This seems to fix bug rhbz#1204139
|
|
||||||
Patch5: postfix-3.0.1-reset-errno-before-readdir.patch
|
|
||||||
Patch9: pflogsumm-1.1.3-datecalc.patch
|
Patch9: pflogsumm-1.1.3-datecalc.patch
|
||||||
|
|
||||||
# Optional patches - set the appropriate environment variables to include
|
# Optional patches - set the appropriate environment variables to include
|
||||||
@ -212,7 +209,6 @@ maps with Postfix, you need this.
|
|||||||
%patch2 -p1 -b .files
|
%patch2 -p1 -b .files
|
||||||
%patch3 -p1 -b .alternatives
|
%patch3 -p1 -b .alternatives
|
||||||
%patch4 -p1 -b .large-fs
|
%patch4 -p1 -b .large-fs
|
||||||
%patch5 -p1 -b .reset-errno-before-readdir
|
|
||||||
|
|
||||||
# Change DEF_SHLIB_DIR according to build host
|
# Change DEF_SHLIB_DIR according to build host
|
||||||
sed -i \
|
sed -i \
|
||||||
@ -732,6 +728,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 12 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.0.3-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1270577
|
||||||
|
- Dropped reset-errno-before-readdir patch (upstreamed)
|
||||||
|
|
||||||
* Mon Sep 14 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.0.2-2
|
* Mon Sep 14 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.0.2-2
|
||||||
- Fixed sysvinit conditionals
|
- Fixed sysvinit conditionals
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user