New version
Resolves: rhbz#1427860 De-fuzzified patches Dropped timestamps patch (upstreamed)
This commit is contained in:
parent
d1b10b3364
commit
55babbc505
@ -1,84 +0,0 @@
|
|||||||
diff --git a/postfix-install b/postfix-install
|
|
||||||
index 922402b..9cc52d5 100644
|
|
||||||
--- a/postfix-install
|
|
||||||
+++ b/postfix-install
|
|
||||||
@@ -40,6 +40,10 @@
|
|
||||||
# is installed from a pre-built package or from source code.
|
|
||||||
#
|
|
||||||
# Arguments
|
|
||||||
+# .IP -keep-new-mtime
|
|
||||||
+# When installing files preserve new file's mtime timestamps.
|
|
||||||
+# Otherwise, mtimes will be set to the time that postfix-install
|
|
||||||
+# is run.
|
|
||||||
# .IP -non-interactive
|
|
||||||
# Do not ask the user for parameter settings. Installation parameters
|
|
||||||
# are specified via one of the non-interactive methods described
|
|
||||||
@@ -210,6 +214,7 @@ if [ -n "$SHLIB_ENV_VAR" ]; then
|
|
||||||
fi
|
|
||||||
|
|
||||||
USAGE="Usage: $0 [name=value] [option]
|
|
||||||
+ -keep-new-mtime Preserve new file's mtime timestamps.
|
|
||||||
-non-interactive Do not ask for installation parameters.
|
|
||||||
-package Build a ready-to-install package.
|
|
||||||
name=value Specify an installation parameter".
|
|
||||||
@@ -225,6 +230,8 @@ do
|
|
||||||
*=*) IFS= eval $arg; IFS="$BACKUP_IFS";;
|
|
||||||
-non-int*) non_interactive=1;;
|
|
||||||
-package) need_install_root=install_root;;
|
|
||||||
+-keep-new-mtime)
|
|
||||||
+ keep_new_mtime=1;;
|
|
||||||
*) echo "$0: Error: $USAGE" 1>&2; exit 1;;
|
|
||||||
esac
|
|
||||||
shift
|
|
||||||
@@ -305,6 +312,7 @@ compare_or_replace() {
|
|
||||||
echo Updating $dst...
|
|
||||||
rm -f $tempdir/junk || exit 1
|
|
||||||
cp $src $tempdir/junk || exit 1
|
|
||||||
+ test -z "$keep_new_mtime" || touch -r $src $tempdir/junk || exit 1
|
|
||||||
mv -f $tempdir/junk $dst || exit 1
|
|
||||||
test -z "$owner" || chown $owner $dst || exit 1
|
|
||||||
test -z "$group" || chgrp $group $dst || exit 1
|
|
||||||
diff --git a/Makefile.in b/Makefile.in
|
|
||||||
index 6d9d9b4..ae61297 100644
|
|
||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -122,23 +122,24 @@ printfck: update
|
|
||||||
install: update
|
|
||||||
SHLIB_ENV_VAR= SHLIB_ENV_VAL= \
|
|
||||||
$(SHLIB_ENV) shlib_directory=$(SHLIB_DIR_OVERRIDE) $(SHELL) \
|
|
||||||
- postfix-install
|
|
||||||
+ postfix-install $(POSTFIX_INSTALL_OPTS)
|
|
||||||
|
|
||||||
package: update
|
|
||||||
SHLIB_ENV_VAR= SHLIB_ENV_VAL= \
|
|
||||||
$(SHLIB_ENV) shlib_directory=$(SHLIB_DIR_OVERRIDE) $(SHELL) \
|
|
||||||
- postfix-install -package
|
|
||||||
+ postfix-install -package $(POSTFIX_INSTALL_OPTS)
|
|
||||||
|
|
||||||
upgrade: update
|
|
||||||
SHLIB_ENV_VAR= SHLIB_ENV_VAL= \
|
|
||||||
$(SHLIB_ENV) shlib_directory=$(SHLIB_DIR_OVERRIDE) $(SHELL) \
|
|
||||||
- postfix-install -non-interactive
|
|
||||||
+ postfix-install -non-interactive $(POSTFIX_INSTALL_OPTS)
|
|
||||||
|
|
||||||
|
|
||||||
non-interactive-package: update
|
|
||||||
SHLIB_ENV_VAR= SHLIB_ENV_VAL= \
|
|
||||||
$(SHLIB_ENV) shlib_directory=$(SHLIB_DIR_OVERRIDE) $(SHELL) \
|
|
||||||
- postfix-install -non-interactive -package
|
|
||||||
+ postfix-install -non-interactive -package \
|
|
||||||
+ $(POSTFIX_INSTALL_OPTS)
|
|
||||||
|
|
||||||
depend clean:
|
|
||||||
set -e; for i in $(DIRS); do \
|
|
||||||
diff --git a/makedefs b/makedefs
|
|
||||||
index 8f78601..eb11838 100644
|
|
||||||
--- a/makedefs
|
|
||||||
+++ b/makedefs
|
|
||||||
@@ -1196,5 +1196,6 @@ PLUGIN_MAP_OBJ_UPDATE = $PLUGIN_MAP_OBJ_UPDATE
|
|
||||||
PLUGIN_MAP_SO_MAKE = $PLUGIN_MAP_SO_MAKE
|
|
||||||
PLUGIN_MAP_SO_UPDATE = $PLUGIN_MAP_SO_UPDATE
|
|
||||||
PLUGIN_LD = $PLUGIN_LD
|
|
||||||
+POSTFIX_INSTALL_OPTS = $POSTFIX_INSTALL_OPTS
|
|
||||||
# Application-specific rules.
|
|
||||||
EOF
|
|
@ -1,5 +1,5 @@
|
|||||||
diff --git a/conf/main.cf b/conf/main.cf
|
diff --git a/conf/main.cf b/conf/main.cf
|
||||||
index 1fc886b..c654dbd 100644
|
index 7af8bde..fbe5c62 100644
|
||||||
--- a/conf/main.cf
|
--- a/conf/main.cf
|
||||||
+++ b/conf/main.cf
|
+++ b/conf/main.cf
|
||||||
@@ -132,6 +132,10 @@ mail_owner = postfix
|
@@ -132,6 +132,10 @@ mail_owner = postfix
|
||||||
@ -85,10 +85,10 @@ index 1fc886b..c654dbd 100644
|
|||||||
readme_directory =
|
readme_directory =
|
||||||
-inet_protocols = ipv4
|
-inet_protocols = ipv4
|
||||||
diff --git a/conf/master.cf b/conf/master.cf
|
diff --git a/conf/master.cf b/conf/master.cf
|
||||||
index 1eda7b5..10ee56e 100644
|
index b67ed59..a9633ba 100644
|
||||||
--- a/conf/master.cf
|
--- a/conf/master.cf
|
||||||
+++ b/conf/master.cf
|
+++ b/conf/master.cf
|
||||||
@@ -95,14 +95,14 @@ scache unix - - n - 1 scache
|
@@ -96,14 +96,14 @@ scache unix - - n - 1 scache
|
||||||
# Also specify in main.cf: cyrus_destination_recipient_limit=1
|
# Also specify in main.cf: cyrus_destination_recipient_limit=1
|
||||||
#
|
#
|
||||||
#cyrus unix - n n - - pipe
|
#cyrus unix - n n - - pipe
|
@ -21,10 +21,10 @@ index 50a4aa7..beef3db 100644
|
|||||||
if (msg_verbose)
|
if (msg_verbose)
|
||||||
msg_info("%s: %s: block size %lu, blocks free %lu",
|
msg_info("%s: %s: block size %lu, blocks free %lu",
|
||||||
diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h
|
diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h
|
||||||
index a33fa94..c5249da 100644
|
index 3f570c4..611d9cd 100644
|
||||||
--- a/src/util/sys_defs.h
|
--- a/src/util/sys_defs.h
|
||||||
+++ b/src/util/sys_defs.h
|
+++ b/src/util/sys_defs.h
|
||||||
@@ -778,8 +778,8 @@ extern int initgroups(const char *, int);
|
@@ -768,8 +768,8 @@ extern int initgroups(const char *, int);
|
||||||
#define GETTIMEOFDAY(t) gettimeofday(t,(struct timezone *) 0)
|
#define GETTIMEOFDAY(t) gettimeofday(t,(struct timezone *) 0)
|
||||||
#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin"
|
#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin"
|
||||||
#define FIONREAD_IN_TERMIOS_H
|
#define FIONREAD_IN_TERMIOS_H
|
19
postfix.spec
19
postfix.spec
@ -41,8 +41,8 @@
|
|||||||
|
|
||||||
Name: postfix
|
Name: postfix
|
||||||
Summary: Postfix Mail Transport Agent
|
Summary: Postfix Mail Transport Agent
|
||||||
Version: 3.1.4
|
Version: 3.2.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.postfix.org
|
URL: http://www.postfix.org
|
||||||
@ -81,13 +81,11 @@ Source101: postfix-pam.conf
|
|||||||
|
|
||||||
# Patches
|
# Patches
|
||||||
|
|
||||||
Patch1: postfix-3.0.0-config.patch
|
Patch1: postfix-3.2.0-config.patch
|
||||||
Patch2: postfix-3.1.0-files.patch
|
Patch2: postfix-3.1.0-files.patch
|
||||||
Patch3: postfix-3.1.0-alternatives.patch
|
Patch3: postfix-3.1.0-alternatives.patch
|
||||||
Patch4: postfix-3.1.0-large-fs.patch
|
Patch4: postfix-3.2.0-large-fs.patch
|
||||||
Patch9: pflogsumm-1.1.3-datecalc.patch
|
Patch9: pflogsumm-1.1.3-datecalc.patch
|
||||||
# Upstream patch
|
|
||||||
Patch10: postfix-3.1.3-timestamps.patch
|
|
||||||
|
|
||||||
# Optional patches - set the appropriate environment variables to include
|
# Optional patches - set the appropriate environment variables to include
|
||||||
# them when building the package/spec file
|
# them when building the package/spec file
|
||||||
@ -223,7 +221,6 @@ pushd pflogsumm-%{pflogsumm_ver}
|
|||||||
%patch9 -p1 -b .datecalc
|
%patch9 -p1 -b .datecalc
|
||||||
popd
|
popd
|
||||||
%endif
|
%endif
|
||||||
%patch10 -p1 -b timestamps
|
|
||||||
|
|
||||||
for f in README_FILES/TLS_{LEGACY_,}README TLS_ACKNOWLEDGEMENTS; do
|
for f in README_FILES/TLS_{LEGACY_,}README TLS_ACKNOWLEDGEMENTS; do
|
||||||
iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
|
iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
|
||||||
@ -297,7 +294,7 @@ make -f Makefile.init makefiles shared=yes dynamicmaps=yes \
|
|||||||
AUXLIBS_SQLITE="${AUXLIBS_SQLITE}" AUXLIBS_CDB="${AUXLIBS_CDB}"\
|
AUXLIBS_SQLITE="${AUXLIBS_SQLITE}" AUXLIBS_CDB="${AUXLIBS_CDB}"\
|
||||||
DEBUG="" SHLIB_RPATH="-Wl,-rpath,%{postfix_shlib_dir} $LDFLAGS" \
|
DEBUG="" SHLIB_RPATH="-Wl,-rpath,%{postfix_shlib_dir} $LDFLAGS" \
|
||||||
OPT="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-comment" \
|
OPT="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-comment" \
|
||||||
POSTFIX_INSTALL_OPTS=-keep-new-mtime
|
POSTFIX_INSTALL_OPTS=-keep-build-mtime
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -736,6 +733,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 2 2017 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.2.0-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1427860
|
||||||
|
- De-fuzzified patches
|
||||||
|
- Dropped timestamps patch (upstreamed)
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2:3.1.4-2
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2:3.1.4-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (pflogsumm-1.1.3.tar.gz) = c378bbc4ec3fe6be3bca52df579ca0c92a98a53e8b3017e8b308f3359ce1216a23c754cb9775c5aaf6578a77189aae89cc39df189a39f32ff8c8997ee542a7ce
|
SHA512 (pflogsumm-1.1.3.tar.gz) = c378bbc4ec3fe6be3bca52df579ca0c92a98a53e8b3017e8b308f3359ce1216a23c754cb9775c5aaf6578a77189aae89cc39df189a39f32ff8c8997ee542a7ce
|
||||||
SHA512 (postfix-3.1.4.tar.gz) = 4cf8aa8d0cf6d99defa32c2907705370d6f8d047d7e938c84a20a62c68ae07a2bec304f28c178d1072b9610f2969420f83fe2066821ad34c0f95e62bbb5b8c05
|
SHA512 (postfix-3.2.0.tar.gz) = bfaa4b2125758833997b399bb2f095475924c1e51fba752e631ad73494d8764458548541d175ef8a1ed6566e9dac569f963e0651e1500aa19595f9062b8e86ce
|
||||||
|
Loading…
Reference in New Issue
Block a user