New version
Resolves: rhbz#1054116 - Updated / de-fuzzified patches - Compiled with USE_LDAP_SASL if both "ldap" and "sasl" options are enabled. Resolves: rhbz#1052958
This commit is contained in:
parent
25f5011e85
commit
2b1e9a1e33
@ -1,5 +1,5 @@
|
|||||||
diff --git a/conf/main.cf b/conf/main.cf
|
diff --git a/conf/main.cf b/conf/main.cf
|
||||||
index 8d301aa..57e865f 100644
|
index dc58a1d..e0fcc91 100644
|
||||||
--- a/conf/main.cf
|
--- a/conf/main.cf
|
||||||
+++ b/conf/main.cf
|
+++ b/conf/main.cf
|
||||||
@@ -113,6 +113,10 @@ mail_owner = postfix
|
@@ -113,6 +113,10 @@ mail_owner = postfix
|
||||||
@ -65,7 +65,7 @@ index 8d301aa..57e865f 100644
|
|||||||
+# can be used to take advantage of the single instance message store
|
+# can be used to take advantage of the single instance message store
|
||||||
+# capability of Cyrus. The concurrency limit can be used to control
|
+# capability of Cyrus. The concurrency limit can be used to control
|
||||||
+# how many simultaneous LMTP sessions will be permitted to the Cyrus
|
+# how many simultaneous LMTP sessions will be permitted to the Cyrus
|
||||||
+# message store.
|
+# message store.
|
||||||
#
|
#
|
||||||
# Cyrus IMAP via command line. Uncomment the "cyrus...pipe" and
|
# Cyrus IMAP via command line. Uncomment the "cyrus...pipe" and
|
||||||
# subsequent line in master.cf.
|
# subsequent line in master.cf.
|
||||||
@ -85,10 +85,10 @@ index 8d301aa..57e865f 100644
|
|||||||
readme_directory =
|
readme_directory =
|
||||||
-inet_protocols = ipv4
|
-inet_protocols = ipv4
|
||||||
diff --git a/conf/master.cf b/conf/master.cf
|
diff --git a/conf/master.cf b/conf/master.cf
|
||||||
index acc67d7..bc15d38 100644
|
index 51a3398..721b61c 100644
|
||||||
--- a/conf/master.cf
|
--- a/conf/master.cf
|
||||||
+++ b/conf/master.cf
|
+++ b/conf/master.cf
|
||||||
@@ -92,14 +92,14 @@ scache unix - - n - 1 scache
|
@@ -95,14 +95,14 @@ scache unix - - n - 1 scache
|
||||||
# Also specify in main.cf: cyrus_destination_recipient_limit=1
|
# Also specify in main.cf: cyrus_destination_recipient_limit=1
|
||||||
#
|
#
|
||||||
#cyrus unix - n n - - pipe
|
#cyrus unix - n n - - pipe
|
@ -1,16 +1,13 @@
|
|||||||
Changing the postfix-files config file won't work right on upgrades because
|
|
||||||
it's a noreplace configuration (the new version with the right paths in it is
|
|
||||||
installed as postfix-files.rpmnew), so we just munge the post-install script.
|
|
||||||
diff --git a/conf/post-install b/conf/post-install
|
diff --git a/conf/post-install b/conf/post-install
|
||||||
index 91ff4a6..f78d820 100644
|
index 7e79c92..081b015 100644
|
||||||
--- a/conf/post-install
|
--- a/conf/post-install
|
||||||
+++ b/conf/post-install
|
+++ b/conf/post-install
|
||||||
@@ -480,6 +480,16 @@ test -n "$create" && {
|
@@ -491,6 +491,16 @@ test -n "$create" && {
|
||||||
case $path in
|
case $path in
|
||||||
no|no/*) continue;;
|
no|no/*) continue;;
|
||||||
esac
|
esac
|
||||||
+ # Munge paths for alternatives.
|
+ # Munge paths for alternatives.
|
||||||
+ case $path in
|
+ case $path in
|
||||||
+ /usr/bin/mailq) path=$path.postfix ;;
|
+ /usr/bin/mailq) path=$path.postfix ;;
|
||||||
+ /usr/bin/newaliases) path=$path.postfix ;;
|
+ /usr/bin/newaliases) path=$path.postfix ;;
|
||||||
+ /usr/bin/rmail) path=$path.postfix ;;
|
+ /usr/bin/rmail) path=$path.postfix ;;
|
||||||
@ -18,7 +15,7 @@ index 91ff4a6..f78d820 100644
|
|||||||
+ /usr/share/man/man1/mailq.1.gz) path=/usr/share/man/man1/mailq.postfix.1.gz ;;
|
+ /usr/share/man/man1/mailq.1.gz) path=/usr/share/man/man1/mailq.postfix.1.gz ;;
|
||||||
+ /usr/share/man/man1/newaliases.1.gz) path=/usr/share/man/man1/newaliases.postfix.1.gz ;;
|
+ /usr/share/man/man1/newaliases.1.gz) path=/usr/share/man/man1/newaliases.postfix.1.gz ;;
|
||||||
+ /usr/share/man/man5/aliases.5.gz) path=/usr/share/man/man5/aliases.postfix.5.gz ;;
|
+ /usr/share/man/man5/aliases.5.gz) path=/usr/share/man/man5/aliases.postfix.5.gz ;;
|
||||||
+ esac
|
+ esac
|
||||||
# Pick up the flags.
|
# Pick up the flags.
|
||||||
case $flags in *u*) upgrade_flag=1;; *) upgrade_flag=;; esac
|
case $flags in *u*) upgrade_flag=1;; *) upgrade_flag=;; esac
|
||||||
case $flags in *c*) create_flag=1;; *) create_flag=;; esac
|
case $flags in *c*) create_flag=1;; *) create_flag=;; esac
|
||||||
|
@ -21,10 +21,10 @@ index 50a4aa7..beef3db 100644
|
|||||||
if (msg_verbose)
|
if (msg_verbose)
|
||||||
msg_info("%s: %s: block size %lu, blocks free %lu",
|
msg_info("%s: %s: block size %lu, blocks free %lu",
|
||||||
diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h
|
diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h
|
||||||
index 00cbdc2..361eac1 100644
|
index 6edde1e..b30871e 100644
|
||||||
--- a/src/util/sys_defs.h
|
--- a/src/util/sys_defs.h
|
||||||
+++ b/src/util/sys_defs.h
|
+++ b/src/util/sys_defs.h
|
||||||
@@ -761,8 +761,8 @@ extern int initgroups(const char *, int);
|
@@ -776,8 +776,8 @@ extern int initgroups(const char *, int);
|
||||||
#define GETTIMEOFDAY(t) gettimeofday(t,(struct timezone *) 0)
|
#define GETTIMEOFDAY(t) gettimeofday(t,(struct timezone *) 0)
|
||||||
#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin"
|
#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin"
|
||||||
#define FIONREAD_IN_TERMIOS_H
|
#define FIONREAD_IN_TERMIOS_H
|
||||||
|
15
postfix.spec
15
postfix.spec
@ -37,8 +37,8 @@
|
|||||||
|
|
||||||
Name: postfix
|
Name: postfix
|
||||||
Summary: Postfix Mail Transport Agent
|
Summary: Postfix Mail Transport Agent
|
||||||
Version: 2.10.2
|
Version: 2.11.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.postfix.org
|
URL: http://www.postfix.org
|
||||||
@ -77,7 +77,7 @@ Source101: postfix-pam.conf
|
|||||||
|
|
||||||
# Patches
|
# Patches
|
||||||
|
|
||||||
Patch1: postfix-2.10.0-config.patch
|
Patch1: postfix-2.11.0-config.patch
|
||||||
Patch2: postfix-2.10.2-files.patch
|
Patch2: postfix-2.10.2-files.patch
|
||||||
Patch3: postfix-alternatives.patch
|
Patch3: postfix-alternatives.patch
|
||||||
Patch8: postfix-large-fs.patch
|
Patch8: postfix-large-fs.patch
|
||||||
@ -164,7 +164,7 @@ CCARGS="${CCARGS} -fsigned-char"
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with ldap}
|
%if %{with ldap}
|
||||||
CCARGS="${CCARGS} -DHAS_LDAP -DLDAP_DEPRECATED=1"
|
CCARGS="${CCARGS} -DHAS_LDAP -DLDAP_DEPRECATED=1 %{?with_sasl:-DUSE_LDAP_SASL}"
|
||||||
AUXLIBS="${AUXLIBS} -lldap -llber"
|
AUXLIBS="${AUXLIBS} -lldap -llber"
|
||||||
%endif
|
%endif
|
||||||
%if %{with pcre}
|
%if %{with pcre}
|
||||||
@ -526,6 +526,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 12 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2:2.11.0-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1054116
|
||||||
|
- Updated / de-fuzzified patches
|
||||||
|
- Compiled with USE_LDAP_SASL if both "ldap" and "sasl" options are enabled.
|
||||||
|
Resolves: rhbz#1052958
|
||||||
|
|
||||||
* Thu Jan 2 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2:2.10.2-3
|
* Thu Jan 2 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2:2.10.2-3
|
||||||
- Rebuilt regarding ECDHE
|
- Rebuilt regarding ECDHE
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user