[tw]
- new version 2.4.5 - fixed compile proplem with glibc-2.6.90+
This commit is contained in:
parent
788c27d3c1
commit
236d5ac1d5
@ -7,3 +7,4 @@ postfix-2.3.3.tar.gz
|
||||
postfix-2.3.4.tar.gz
|
||||
postfix-2.3.6.tar.gz
|
||||
postfix-2.4.3.tar.gz
|
||||
postfix-2.4.5.tar.gz
|
||||
|
71
postfix-2.4.5-open_define.patch
Normal file
71
postfix-2.4.5-open_define.patch
Normal file
@ -0,0 +1,71 @@
|
||||
diff -up postfix-2.4.5/src/util/dict_open.c.open_define postfix-2.4.5/src/util/dict_open.c
|
||||
--- postfix-2.4.5/src/util/dict_open.c.open_define 2006-06-26 14:59:19.000000000 +0200
|
||||
+++ postfix-2.4.5/src/util/dict_open.c 2007-08-13 18:46:18.000000000 +0200
|
||||
@@ -302,7 +302,7 @@ DICT *dict_open3(const char *dict_type
|
||||
dict_open_init();
|
||||
if ((dp = (DICT_OPEN_INFO *) htable_find(dict_open_hash, dict_type)) == 0)
|
||||
msg_fatal("unsupported dictionary type: %s", dict_type);
|
||||
- if ((dict = dp->open(dict_name, open_flags, dict_flags)) == 0)
|
||||
+ if ((dict = (dp->open)(dict_name, open_flags, dict_flags)) == 0)
|
||||
msg_fatal("opening %s:%s %m", dict_type, dict_name);
|
||||
if (msg_verbose)
|
||||
msg_info("%s: %s:%s", myname, dict_type, dict_name);
|
||||
@@ -323,7 +323,7 @@ void dict_open_register(const char *t
|
||||
msg_panic("%s: dictionary type exists: %s", myname, type);
|
||||
dp = (DICT_OPEN_INFO *) mymalloc(sizeof(*dp));
|
||||
dp->type = mystrdup(type);
|
||||
- dp->open = open;
|
||||
+ (dp->open) = open;
|
||||
htable_enter(dict_open_hash, dp->type, (char *) dp);
|
||||
}
|
||||
|
||||
diff -up postfix-2.4.5/src/util/dict_db.c.open_define postfix-2.4.5/src/util/dict_db.c
|
||||
--- postfix-2.4.5/src/util/dict_db.c.open_define 2007-01-04 15:06:07.000000000 +0100
|
||||
+++ postfix-2.4.5/src/util/dict_db.c 2007-08-13 18:46:18.000000000 +0200
|
||||
@@ -665,10 +665,10 @@ static DICT *dict_db_open(const char *cl
|
||||
if (type == DB_HASH && db->set_h_nelem(db, DICT_DB_NELM) != 0)
|
||||
msg_fatal("set DB hash element count %d: %m", DICT_DB_NELM);
|
||||
#if (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR > 0)
|
||||
- if ((errno = db->open(db, 0, db_path, 0, type, db_flags, 0644)) != 0)
|
||||
+ if ((errno = (db->open)(db, 0, db_path, 0, type, db_flags, 0644)) != 0)
|
||||
msg_fatal("open database %s: %m", db_path);
|
||||
#elif (DB_VERSION_MAJOR == 3 || DB_VERSION_MAJOR == 4)
|
||||
- if ((errno = db->open(db, db_path, 0, type, db_flags, 0644)) != 0)
|
||||
+ if ((errno = (db->open)(db, db_path, 0, type, db_flags, 0644)) != 0)
|
||||
msg_fatal("open database %s: %m", db_path);
|
||||
#else
|
||||
#error "Unsupported Berkeley DB version"
|
||||
diff -up postfix-2.4.5/src/global/mkmap_open.c.open_define postfix-2.4.5/src/global/mkmap_open.c
|
||||
--- postfix-2.4.5/src/global/mkmap_open.c.open_define 2004-12-15 01:24:22.000000000 +0100
|
||||
+++ postfix-2.4.5/src/global/mkmap_open.c 2007-08-13 18:46:18.000000000 +0200
|
||||
@@ -177,7 +177,7 @@ MKMAP *mkmap_open(const char *type, con
|
||||
* Truncate the database upon open, and update it. Read-write mode is
|
||||
* needed because the underlying routines read as well as write.
|
||||
*/
|
||||
- mkmap->dict = mkmap->open(path, open_flags, dict_flags);
|
||||
+ mkmap->dict = (mkmap->open)(path, open_flags, dict_flags);
|
||||
mkmap->dict->lock_fd = -1; /* XXX just in case */
|
||||
mkmap->dict->stat_fd = -1; /* XXX just in case */
|
||||
mkmap->dict->flags |= DICT_FLAG_DUP_WARN;
|
||||
diff -up postfix-2.4.5/src/global/mkmap_cdb.c.open_define postfix-2.4.5/src/global/mkmap_cdb.c
|
||||
--- postfix-2.4.5/src/global/mkmap_cdb.c.open_define 2004-12-09 00:58:05.000000000 +0100
|
||||
+++ postfix-2.4.5/src/global/mkmap_cdb.c 2007-08-13 18:46:18.000000000 +0200
|
||||
@@ -56,7 +56,7 @@
|
||||
MKMAP *mkmap_cdb_open(const char *unused_path)
|
||||
{
|
||||
MKMAP *mkmap = (MKMAP *) mymalloc(sizeof(*mkmap));
|
||||
- mkmap->open = dict_cdb_open;
|
||||
+ (mkmap->open) = dict_cdb_open;
|
||||
mkmap->after_open = 0;
|
||||
mkmap->after_close = 0;
|
||||
return (mkmap);
|
||||
diff -up postfix-2.4.5/src/global/mail_dict.c.open_define postfix-2.4.5/src/global/mail_dict.c
|
||||
--- postfix-2.4.5/src/global/mail_dict.c.open_define 2004-01-04 19:53:27.000000000 +0100
|
||||
+++ postfix-2.4.5/src/global/mail_dict.c 2007-08-13 18:46:18.000000000 +0200
|
||||
@@ -64,5 +64,5 @@ void mail_dict_init(void)
|
||||
DICT_OPEN_INFO *dp;
|
||||
|
||||
for (dp = dict_open_info; dp->type; dp++)
|
||||
- dict_open_register(dp->type, dp->open);
|
||||
+ dict_open_register(dp->type, (dp->open));
|
||||
}
|
10
postfix.spec
10
postfix.spec
@ -38,8 +38,8 @@
|
||||
|
||||
Name: postfix
|
||||
Summary: Postfix Mail Transport Agent
|
||||
Version: 2.4.3
|
||||
Release: 3%{?dist}
|
||||
Version: 2.4.5
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.postfix.org
|
||||
@ -79,6 +79,7 @@ Patch6: postfix-2.1.1-obsolete.patch
|
||||
Patch7: postfix-2.1.5-aliases.patch
|
||||
Patch8: postfix-large-fs.patch
|
||||
Patch9: postfix-2.4.0-cyrus.patch
|
||||
Patch10: postfix-2.4.5-open_define.patch
|
||||
|
||||
# Optional patches - set the appropriate environment variables to include
|
||||
# them when building the package/spec file
|
||||
@ -136,6 +137,7 @@ TLS
|
||||
%patch7 -p1 -b .aliases
|
||||
%patch8 -p1 -b .large-fs
|
||||
%patch9 -p1 -b .cyrus
|
||||
%patch10 -p1 -b .open_define
|
||||
|
||||
%if %{PFLOGSUMM}
|
||||
gzip -dc %{SOURCE53} | tar xf -
|
||||
@ -464,6 +466,10 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 13 2007 Thomas Woerner <twoerner@redhat.com> 2:2.4.5-1
|
||||
- new version 2.4.5
|
||||
- fixed compile proplem with glibc-2.6.90+
|
||||
|
||||
* Fri Jun 15 2007 Thomas Woerner <twoerner@redhat.com> 2:2.4.3-3
|
||||
- added missing epoch in requirement of pflogsumm sub package
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user