parent
cde7dcbbea
commit
e69944d799
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/poppler-test-2009-05-13_0d2bfd4af4c76a3bac27ccaff793d9129df7b57a.tar.xz
|
||||
/poppler-0.61.1.tar.xz
|
||||
/poppler-0.62.0.tar.xz
|
||||
/poppler-0.63.0.tar.xz
|
||||
|
@ -3804,7 +3804,7 @@ new file mode 100644
|
||||
index 00000000..f2fa6f17
|
||||
--- /dev/null
|
||||
+++ b/qt4/src/ArthurOutputDev.cc
|
||||
@@ -0,0 +1,812 @@
|
||||
@@ -0,0 +1,817 @@
|
||||
+//========================================================================
|
||||
+//
|
||||
+// ArthurOutputDev.cc
|
||||
@ -4370,8 +4370,10 @@ index 00000000..f2fa6f17
|
||||
+#ifdef HAVE_SPLASH
|
||||
+ double x1, y1;
|
||||
+ double x2, y2;
|
||||
+ double px, py;
|
||||
+// SplashPath *path;
|
||||
+ int render;
|
||||
+ Guchar f;
|
||||
+
|
||||
+ if (m_needFontUpdate) {
|
||||
+ updateFont(state);
|
||||
@ -4396,18 +4398,20 @@ index 00000000..f2fa6f17
|
||||
+ if (fontPath) {
|
||||
+ QPainterPath qPath;
|
||||
+ qPath.setFillRule(Qt::WindingFill);
|
||||
+ for (int i = 0; i < fontPath->length; ++i) {
|
||||
+ for (int i = 0; i < fontPath->getLength(); ++i) {
|
||||
+ // SplashPath.flags: bitwise or allowed
|
||||
+ if (fontPath->flags[i] & splashPathLast || fontPath->flags[i] & splashPathClosed) {
|
||||
+ fontPath->getPoint(i, &px, &py, &f);
|
||||
+ if (f & splashPathLast || f & splashPathClosed) {
|
||||
+ qPath.closeSubpath();
|
||||
+ }
|
||||
+ if (fontPath->flags[i] & splashPathFirst) {
|
||||
+ state->transform(fontPath->pts[i].x+x, -fontPath->pts[i].y+y, &x1, &y1);
|
||||
+ if (f & splashPathFirst) {
|
||||
+ state->transform(px+x, -py+y, &x1, &y1);
|
||||
+ qPath.moveTo(x1,y1);
|
||||
+ }
|
||||
+ if (fontPath->flags[i] & splashPathCurve) {
|
||||
+ state->transform(fontPath->pts[i].x+x, -fontPath->pts[i].y+y, &x1, &y1);
|
||||
+ state->transform(fontPath->pts[i+1].x+x, -fontPath->pts[i+1].y+y, &x2, &y2);
|
||||
+ if (f & splashPathCurve) {
|
||||
+ state->transform(px+x, -py+y, &x1, &y1);
|
||||
+ fontPath->getPoint(i+1, &px, &py, &f);
|
||||
+ state->transform(px+x, -py+y, &x2, &y2);
|
||||
+ qPath.quadTo(x1,y1,x2,y2);
|
||||
+ ++i;
|
||||
+ }
|
||||
@ -4416,7 +4420,8 @@ index 00000000..f2fa6f17
|
||||
+ // qDebug() << "Need to implement arc";
|
||||
+ // }
|
||||
+ else {
|
||||
+ state->transform(fontPath->pts[i].x+x, -fontPath->pts[i].y+y, &x1, &y1);
|
||||
+ fontPath->getPoint(i, &px, &py, &f);
|
||||
+ state->transform(px+x, -py+y, &x1, &y1);
|
||||
+ qPath.lineTo(x1,y1);
|
||||
+ }
|
||||
+ }
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 1f48bf3f1fdc488158ce57f3aa595c4b127e93e4 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Wed, 7 Feb 2018 16:57:59 +0100
|
||||
Subject: [PATCH] fix build with gtk-doc 1.27
|
||||
|
||||
---
|
||||
gtkdoc.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gtkdoc.py b/gtkdoc.py
|
||||
index 48f862a3..2abfd8e2 100644
|
||||
--- a/gtkdoc.py
|
||||
+++ b/gtkdoc.py
|
||||
@@ -319,9 +319,9 @@ class GTKDoc(object):
|
||||
ldflags = ' "-L%s" %s ' % (self.library_path, additional_ldflags) + ldflags
|
||||
current_ld_library_path = env.get('LD_LIBRARY_PATH')
|
||||
if current_ld_library_path:
|
||||
- env['RUN'] = 'LD_LIBRARY_PATH="%s:%s" ' % (self.library_path, current_ld_library_path)
|
||||
+ env['LD_LIBRARY_PATH'] = '%s:%s' % (self.library_path, current_ld_library_path)
|
||||
else:
|
||||
- env['RUN'] = 'LD_LIBRARY_PATH="%s" ' % self.library_path
|
||||
+ env['LD_LIBRARY_PATH'] = '%s' % self.library_path
|
||||
|
||||
if ldflags:
|
||||
env['LDFLAGS'] = '%s %s' % (ldflags, env.get('LDFLAGS', ''))
|
||||
--
|
||||
2.14.3
|
||||
|
@ -188,10 +188,10 @@ index 7c2ca78..e93908c 100644
|
||||
+ s2 = selection->y2;
|
||||
+ }
|
||||
|
||||
begin = NULL;
|
||||
end = NULL;
|
||||
current = NULL;
|
||||
for (p = words; p != NULL; p = p->next) {
|
||||
begin = nullptr;
|
||||
end = nullptr;
|
||||
current = nullptr;
|
||||
for (p = words; p != nullptr; p = p->next) {
|
||||
+ if (rot == 0 || rot == 2) {
|
||||
+ p_min = p->xMin;
|
||||
+ p_max = p->xMax;
|
||||
@ -203,28 +203,28 @@ index 7c2ca78..e93908c 100644
|
||||
if (blk->page->primaryLR) {
|
||||
- if ((selection->x1 < p->xMax) ||
|
||||
- (selection->x2 < p->xMax))
|
||||
- if (begin == NULL)
|
||||
- if (begin == nullptr)
|
||||
- begin = p;
|
||||
+ if (((s1 < p_max) || (s2 < p_max)) && begin == NULL)
|
||||
+ if (((s1 < p_max) || (s2 < p_max)) && begin == nullptr)
|
||||
+ begin = p;
|
||||
|
||||
- if (((selection->x1 > p->xMin) ||
|
||||
- (selection->x2 > p->xMin)) && (begin != NULL)) {
|
||||
+ if (((s1 > p_min) || (s2 > p_min)) && begin != NULL) {
|
||||
- (selection->x2 > p->xMin)) && (begin != nullptr)) {
|
||||
+ if (((s1 > p_min) || (s2 > p_min)) && begin != nullptr) {
|
||||
end = p->next;
|
||||
current = p;
|
||||
}
|
||||
} else {
|
||||
- if ((selection->x1 > p->xMin) ||
|
||||
- (selection->x2 > p->xMin))
|
||||
- if (begin == NULL)
|
||||
- if (begin == nullptr)
|
||||
- begin = p;
|
||||
+ if (((s1 > p_min) || (s2 > p_min)) && begin == NULL)
|
||||
+ if (((s1 > p_min) || (s2 > p_min)) && begin == nullptr)
|
||||
+ begin = p;
|
||||
|
||||
- if (((selection->x1 < p->xMax) ||
|
||||
- (selection->x2 < p->xMax)) && (begin != NULL)) {
|
||||
+ if (((s1 < p_max) || (s2 < p_max)) && begin != NULL) {
|
||||
- (selection->x2 < p->xMax)) && (begin != nullptr)) {
|
||||
+ if (((s1 < p_max) || (s2 < p_max)) && begin != nullptr) {
|
||||
end = p->next;
|
||||
current = p;
|
||||
}
|
||||
|
13
poppler.spec
13
poppler.spec
@ -3,8 +3,8 @@
|
||||
|
||||
Summary: PDF rendering library
|
||||
Name: poppler
|
||||
Version: 0.62.0
|
||||
Release: 2%{?dist}
|
||||
Version: 0.63.0
|
||||
Release: 1%{?dist}
|
||||
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
||||
URL: http://poppler.freedesktop.org/
|
||||
Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.xz
|
||||
@ -13,8 +13,7 @@ Source1: %{name}-test-%{test_date}_%{test_sha}.tar.xz
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1185007
|
||||
Patch0: poppler-0.30.0-rotated-words-selection.patch
|
||||
Patch1: 0001-fix-build-with-gtk-doc-1.27.patch
|
||||
Patch2: 0001-Revert-Remove-the-Qt4-frontend.patch
|
||||
Patch1: 0001-Revert-Remove-the-Qt4-frontend.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
@ -189,7 +188,7 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
||||
%files
|
||||
%doc README
|
||||
%license COPYING
|
||||
%{_libdir}/libpoppler.so.73*
|
||||
%{_libdir}/libpoppler.so.74*
|
||||
|
||||
%files devel
|
||||
%{_libdir}/pkgconfig/poppler.pc
|
||||
@ -246,6 +245,10 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 23 2018 Marek Kasik <mkasik@redhat.com> - 0.63.0-1
|
||||
- Update to 0.63.0
|
||||
- Resolves: #1558001
|
||||
|
||||
* Wed Mar 07 2018 Rex Dieter <rdieter@fedoraproject.org> - 0.62.0-2
|
||||
- BR: gcc-c++, use %%ldconfig_scriptlets %%make_build %%make_install
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (poppler-0.62.0.tar.xz) = 91f7eae7b05965ae97a34e658bed2a676be8a6e4d34f82148ece6eb58932632dcf9a34d50c66412f93f560ce575abf5c608ed6b1e5184604b96024801886c706
|
||||
SHA512 (poppler-0.63.0.tar.xz) = a151d08480e9940a02191355ef5e7499d6494cff05f22f49de2bb8223512f5e5c9bb9b33651943ded30b4cd7096a2423fb7a01fa62228fbcd1d3a221b885cfe9
|
||||
SHA512 (poppler-test-2009-05-13_0d2bfd4af4c76a3bac27ccaff793d9129df7b57a.tar.xz) = f8ce114357043a893100de2d52ada8bd850148d19f0e8c889988ea97e9a92313f0545c0b88ef32a1ce7f0e9e58edc1a8c9066278c20b7718ca619913fd4bfb3c
|
||||
|
Loading…
Reference in New Issue
Block a user