0.6.4
This commit is contained in:
parent
d89086f109
commit
b971c16ba0
@ -1,2 +1,2 @@
|
|||||||
poppler-0.6.2.tar.gz
|
poppler-0.6.4.tar.gz
|
||||||
poppler-data-0.1.tar.gz
|
poppler-data-0.2.0.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -up poppler-0.5.91/poppler-0.5.91/poppler/GlobalParams.cc.debug-spew poppler-0.5.91/poppler-0.5.91/poppler/GlobalParams.cc
|
|
||||||
--- poppler-0.5.91/poppler-0.5.91/poppler/GlobalParams.cc.debug-spew 2007-08-15 20:03:42.000000000 -0400
|
|
||||||
+++ poppler-0.5.91/poppler-0.5.91/poppler/GlobalParams.cc 2007-08-15 20:03:54.000000000 -0400
|
|
||||||
@@ -685,7 +685,6 @@ void GlobalParams::scanEncodingDirs() {
|
|
||||||
}
|
|
||||||
|
|
||||||
void GlobalParams::parseNameToUnicode(GooString *name) {
|
|
||||||
-printf("PARSING %s\n", name->getCString());
|
|
||||||
char *tok1, *tok2;
|
|
||||||
FILE *f;
|
|
||||||
char buf[256];
|
|
45
poppler.spec
45
poppler.spec
@ -1,9 +1,9 @@
|
|||||||
%define dataversion 0.1
|
%define dataversion 0.2
|
||||||
|
|
||||||
Summary: PDF rendering library
|
Summary: PDF rendering library
|
||||||
Name: poppler
|
Name: poppler
|
||||||
Version: 0.6.2
|
Version: 0.6.4
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2 and Redistributable, no modification permitted
|
License: GPLv2 and Redistributable, no modification permitted
|
||||||
# the code is GPLv2
|
# the code is GPLv2
|
||||||
# the charmap data in /usr/share/poppler is redistributable
|
# the charmap data in /usr/share/poppler is redistributable
|
||||||
@ -30,7 +30,6 @@ Summary: Libraries and headers for poppler
|
|||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: pkgconfig
|
Requires: pkgconfig
|
||||||
Requires: gtk-doc
|
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
Poppler, a PDF rendering library, it's a fork of the xpdf PDF
|
Poppler, a PDF rendering library, it's a fork of the xpdf PDF
|
||||||
@ -39,6 +38,25 @@ viewer developed by Derek Noonburg of Glyph and Cog, LLC.
|
|||||||
You should install the poppler-devel package if you would like to
|
You should install the poppler-devel package if you would like to
|
||||||
compile applications based on poppler.
|
compile applications based on poppler.
|
||||||
|
|
||||||
|
%package glib
|
||||||
|
Summary: Glib wrapper for poppler
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description glib
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package glib-devel
|
||||||
|
Summary: Development files for glib wrapper
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
Requires: gtk-doc
|
||||||
|
|
||||||
|
%description glib-devel
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
|
||||||
%package qt
|
%package qt
|
||||||
Summary: Qt wrapper for poppler
|
Summary: Qt wrapper for poppler
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -130,22 +148,29 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc %{name}-%{version}/COPYING
|
%doc %{name}-%{version}/COPYING
|
||||||
%doc poppler-data-%{dataversion}/README-poppler-data
|
%doc poppler-data-%{dataversion}/README-poppler-data
|
||||||
%doc poppler-data-%{dataversion}/COPYING-poppler-data
|
%doc poppler-data-%{dataversion}/COPYING-poppler-data
|
||||||
%{_libdir}/libpoppler-glib.so.*
|
|
||||||
%{_libdir}/libpoppler.so.*
|
%{_libdir}/libpoppler.so.*
|
||||||
%{_datadir}/poppler/
|
%{_datadir}/poppler/
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%exclude %{_libdir}/pkgconfig/poppler-qt.pc
|
%exclude %{_libdir}/pkgconfig/poppler-qt.pc
|
||||||
%{_libdir}/pkgconfig/poppler-cairo.pc
|
|
||||||
%{_libdir}/pkgconfig/poppler-glib.pc
|
|
||||||
%{_libdir}/pkgconfig/poppler.pc
|
%{_libdir}/pkgconfig/poppler.pc
|
||||||
%{_libdir}/pkgconfig/poppler-splash.pc
|
%{_libdir}/pkgconfig/poppler-splash.pc
|
||||||
%{_libdir}/libpoppler-glib.so
|
|
||||||
%{_libdir}/libpoppler.so
|
%{_libdir}/libpoppler.so
|
||||||
%{_includedir}/poppler/
|
%{_includedir}/poppler/
|
||||||
%{_datadir}/gtk-doc/html/poppler
|
%{_datadir}/gtk-doc/html/poppler
|
||||||
|
|
||||||
|
%files glib
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_libdir}/libpoppler-glib.so.*
|
||||||
|
|
||||||
|
%files glib-devel
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_libdir}/pkgconfig/poppler-glib.pc
|
||||||
|
%{_libdir}/pkgconfig/poppler-cairo.pc
|
||||||
|
%{_libdir}/libpoppler-glib.so
|
||||||
|
%{_datadir}/gtk-doc/html/poppler
|
||||||
|
|
||||||
%files qt
|
%files qt
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libpoppler-qt.so.*
|
%{_libdir}/libpoppler-qt.so.*
|
||||||
@ -172,6 +197,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 29 2008 Matthias Clasen <mclasen@redhat.com> - 0.6.4-1
|
||||||
|
- Update to 0.6.4
|
||||||
|
- Split off poppler-glib
|
||||||
|
|
||||||
* Sun Dec 2 2007 Matthias Clasen <mclasen@redhat.com> - 0.6.2-3
|
* Sun Dec 2 2007 Matthias Clasen <mclasen@redhat.com> - 0.6.2-3
|
||||||
- Fix the qt3 checks some more
|
- Fix the qt3 checks some more
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user