0.8.3
This commit is contained in:
parent
425cb86ffb
commit
a88bb7fb0f
@ -1 +1 @@
|
|||||||
poppler-0.8.1.tar.gz
|
poppler-0.8.3.tar.gz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up poppler-0.8.1/poppler-0.8.1/qt4/Makefile.in.fix-qt4-build poppler-0.8.1/poppler-0.8.1/qt4/Makefile.in
|
diff -up poppler-0.8.3/poppler-0.8.3/qt4/Makefile.in.fix-qt4-build poppler-0.8.3/poppler-0.8.3/qt4/Makefile.in
|
||||||
--- poppler-0.8.1/poppler-0.8.1/qt4/Makefile.in.fix-qt4-build 20.8.12-21 10:29:14.000000000 -0500
|
--- poppler-0.8.3/poppler-0.8.3/qt4/Makefile.in.fix-qt4-build 20.8.32-21 10:29:14.000000000 -0500
|
||||||
+++ poppler-0.8.1/poppler-0.8.1/qt4/Makefile.in 20.8.12-21 10:29:22.000000000 -0500
|
+++ poppler-0.8.3/poppler-0.8.3/qt4/Makefile.in 20.8.32-21 10:29:22.000000000 -0500
|
||||||
@@ -223,7 +223,7 @@ sharedstatedir = @sharedstatedir@
|
@@ -223,7 +223,7 @@ sharedstatedir = @sharedstatedir@
|
||||||
sysconfdir = @sysconfdir@
|
sysconfdir = @sysconfdir@
|
||||||
target_alias = @target_alias@
|
target_alias = @target_alias@
|
||||||
@ -10,9 +10,9 @@ diff -up poppler-0.8.1/poppler-0.8.1/qt4/Makefile.in.fix-qt4-build poppler-0.8.1
|
|||||||
all: all-recursive
|
all: all-recursive
|
||||||
|
|
||||||
.SUFFIXES:
|
.SUFFIXES:
|
||||||
diff -up poppler-0.8.1/poppler-0.8.1/qt4/src/Makefile.in.qt4 poppler-0.8.1/poppler-0.8.1/qt4/src/Makefile.in
|
diff -up poppler-0.8.3/poppler-0.8.3/qt4/src/Makefile.in.qt4 poppler-0.8.3/poppler-0.8.3/qt4/src/Makefile.in
|
||||||
--- poppler-0.8.1/poppler-0.8.1/qt4/src/Makefile.in.qt4 20.8.12-28 23:28:27.000000000 -0500
|
--- poppler-0.8.3/poppler-0.8.3/qt4/src/Makefile.in.qt4 20.8.32-28 23:28:27.000000000 -0500
|
||||||
+++ poppler-0.8.1/poppler-0.8.1/qt4/src/Makefile.in 20.8.12-28 23:28:46.000000000 -0500
|
+++ poppler-0.8.3/poppler-0.8.3/qt4/src/Makefile.in 20.8.32-28 23:28:46.000000000 -0500
|
||||||
@@ -635,7 +635,7 @@ SUFFIXES: .moc
|
@@ -635,7 +635,7 @@ SUFFIXES: .moc
|
||||||
|
|
||||||
# This rule lets GNU make create any *.moc from the equivalent *.h
|
# This rule lets GNU make create any *.moc from the equivalent *.h
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up poppler-0.8.1/poppler-0.8.1/poppler/OptionalContent.cc.jx poppler-0.8.1/poppler-0.8.1/poppler/OptionalContent.cc
|
diff -up poppler-0.8.3/poppler-0.8.3/poppler/OptionalContent.cc.jx poppler-0.8.3/poppler-0.8.3/poppler/OptionalContent.cc
|
||||||
--- poppler-0.8.1/poppler-0.8.1/poppler/OptionalContent.cc.jx 20.8.13-14 20:24:54.000000000 -0400
|
--- poppler-0.8.3/poppler-0.8.3/poppler/OptionalContent.cc.jx 20.8.33-14 20:24:54.000000000 -0400
|
||||||
+++ poppler-0.8.1/poppler-0.8.1/poppler/OptionalContent.cc 20.8.14-06 18:56:06.000000000 -0400
|
+++ poppler-0.8.3/poppler-0.8.3/poppler/OptionalContent.cc 20.8.34-06 18:56:06.000000000 -0400
|
||||||
@@ -162,6 +162,8 @@ OptionalContentGroup* OCGs::findOcgByRef
|
@@ -162,6 +162,8 @@ OptionalContentGroup* OCGs::findOcgByRef
|
||||||
{
|
{
|
||||||
//TODO: make this more efficient
|
//TODO: make this more efficient
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up poppler-0.8.1/poppler-0.8.1/poppler/XRef.h.objstream poppler-0.8.1/poppler-0.8.1/poppler/XRef.h
|
diff -up poppler-0.8.3/poppler-0.8.3/poppler/XRef.h.objstream poppler-0.8.3/poppler-0.8.3/poppler/XRef.h
|
||||||
--- poppler-0.8.1/poppler-0.8.1/poppler/XRef.h.objstream 20.8.11-21 21:00:59.000000000 +0100
|
--- poppler-0.8.3/poppler-0.8.3/poppler/XRef.h.objstream 20.8.31-21 21:00:59.000000000 +0100
|
||||||
+++ poppler-0.8.1/poppler-0.8.1/poppler/XRef.h 20.8.12-18 17:18:47.000000000 +0100
|
+++ poppler-0.8.3/poppler-0.8.3/poppler/XRef.h 20.8.32-18 17:18:47.000000000 +0100
|
||||||
@@ -19,7 +19,36 @@
|
@@ -19,7 +19,36 @@
|
||||||
class Dict;
|
class Dict;
|
||||||
class Stream;
|
class Stream;
|
||||||
@ -47,9 +47,9 @@ diff -up poppler-0.8.1/poppler-0.8.1/poppler/XRef.h.objstream poppler-0.8.1/popp
|
|||||||
|
|
||||||
// Write access
|
// Write access
|
||||||
void setModifiedObject(Object* o, Ref r);
|
void setModifiedObject(Object* o, Ref r);
|
||||||
diff -up poppler-0.8.1/poppler-0.8.1/poppler/XRef.cc.objstream poppler-0.8.1/poppler-0.8.1/poppler/XRef.cc
|
diff -up poppler-0.8.3/poppler-0.8.3/poppler/XRef.cc.objstream poppler-0.8.3/poppler-0.8.3/poppler/XRef.cc
|
||||||
--- poppler-0.8.1/poppler-0.8.1/poppler/XRef.cc.objstream 20.8.11-21 21:00:59.000000000 +0100
|
--- poppler-0.8.3/poppler-0.8.3/poppler/XRef.cc.objstream 20.8.31-21 21:00:59.000000000 +0100
|
||||||
+++ poppler-0.8.1/poppler-0.8.1/poppler/XRef.cc 20.8.12-18 17:18:47.000000000 +0100
|
+++ poppler-0.8.3/poppler-0.8.3/poppler/XRef.cc 20.8.32-18 17:18:47.000000000 +0100
|
||||||
@@ -50,34 +50,9 @@
|
@@ -50,34 +50,9 @@
|
||||||
// ObjectStream
|
// ObjectStream
|
||||||
//------------------------------------------------------------------------
|
//------------------------------------------------------------------------
|
||||||
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Summary: PDF rendering library
|
Summary: PDF rendering library
|
||||||
Name: poppler
|
Name: poppler
|
||||||
Version: 0.8.1
|
Version: 0.8.3
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2 and Redistributable, no modification permitted
|
License: GPLv2 and Redistributable, no modification permitted
|
||||||
# the code is GPLv2
|
# the code is GPLv2
|
||||||
@ -13,7 +13,6 @@ Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.gz
|
|||||||
Source1: http://poppler.freedesktop.org/poppler-data-%{dataversion}.tar.gz
|
Source1: http://poppler.freedesktop.org/poppler-data-%{dataversion}.tar.gz
|
||||||
Patch0: poppler-ObjStream.patch
|
Patch0: poppler-ObjStream.patch
|
||||||
Patch1: fix-qt4-build.patch
|
Patch1: fix-qt4-build.patch
|
||||||
Patch2: poppler-0.8.0-ocg-crash.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
|
|
||||||
BuildRequires: gtk2-devel
|
BuildRequires: gtk2-devel
|
||||||
@ -114,7 +113,6 @@ converting PDF files to a number of other formats.
|
|||||||
%setup -c -q -a1
|
%setup -c -q -a1
|
||||||
%patch0 -p1 -b .objstream
|
%patch0 -p1 -b .objstream
|
||||||
%patch1 -p1 -b .fix-qt4-build
|
%patch1 -p1 -b .fix-qt4-build
|
||||||
%patch2 -p1 -b .ocg
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
pushd %{name}-%{version}
|
pushd %{name}-%{version}
|
||||||
@ -201,6 +199,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 4 2008 Matthias Clasen <mclasen@redhat.com> - 0.8.3-1
|
||||||
|
- Update to 0.8.3
|
||||||
|
|
||||||
* Mon Apr 28 2008 Matthias Clasen <mclasen@redhat.com> - 0.8.1-1
|
* Mon Apr 28 2008 Matthias Clasen <mclasen@redhat.com> - 0.8.1-1
|
||||||
- Update to 0.8.1
|
- Update to 0.8.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user