new upstream release 0.50.0
This commit is contained in:
parent
75eb8cfc1b
commit
a4db50cbf3
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@
|
|||||||
/poppler-0.45.0.tar.xz
|
/poppler-0.45.0.tar.xz
|
||||||
/poppler-0.48.0.tar.xz
|
/poppler-0.48.0.tar.xz
|
||||||
/poppler-0.49.0.tar.xz
|
/poppler-0.49.0.tar.xz
|
||||||
|
/poppler-0.50.0.tar.xz
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
From 6d5a35324d49856569788bc4e471cc245f5a0774 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marek Kasik <mkasik@redhat.com>
|
|
||||||
Date: Wed, 21 Sep 2016 12:28:16 +0200
|
|
||||||
Subject: [PATCH] Don't crash when calling cmsGetColorSpace()
|
|
||||||
|
|
||||||
Initialize RGBProfile and displayProfile before their use
|
|
||||||
if they were not initialized in GfxState's constructor.
|
|
||||||
|
|
||||||
https://bugs.freedesktop.org/show_bug.cgi?id=97870
|
|
||||||
---
|
|
||||||
poppler/GfxState.cc | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/poppler/GfxState.cc b/poppler/GfxState.cc
|
|
||||||
index 368ee27..b617012 100644
|
|
||||||
--- a/poppler/GfxState.cc
|
|
||||||
+++ b/poppler/GfxState.cc
|
|
||||||
@@ -2049,6 +2049,7 @@ GfxColorSpace *GfxICCBasedColorSpace::parse(Array *arr, OutputDev *out, GfxState
|
|
||||||
if (hp == 0) {
|
|
||||||
error(errSyntaxWarning, -1, "read ICCBased color space profile error");
|
|
||||||
} else {
|
|
||||||
+ GfxColorSpace::setupColorProfiles();
|
|
||||||
cmsHPROFILE dhp = (state != NULL && state->getDisplayProfile() != NULL) ? state->getDisplayProfile() : displayProfile;
|
|
||||||
if (dhp == NULL) dhp = RGBProfile;
|
|
||||||
unsigned int cst = getCMSColorSpaceType(cmsGetColorSpace(hp));
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
10
poppler.spec
10
poppler.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: PDF rendering library
|
Summary: PDF rendering library
|
||||||
Name: poppler
|
Name: poppler
|
||||||
Version: 0.49.0
|
Version: 0.50.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
||||||
URL: http://poppler.freedesktop.org/
|
URL: http://poppler.freedesktop.org/
|
||||||
@ -9,9 +9,6 @@ Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.xz
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1185007
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1185007
|
||||||
Patch0: poppler-0.30.0-rotated-words-selection.patch
|
Patch0: poppler-0.30.0-rotated-words-selection.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1363669
|
|
||||||
Patch1: poppler-0.45.0-cmsGetColorSpace.patch
|
|
||||||
|
|
||||||
Requires: poppler-data
|
Requires: poppler-data
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
@ -175,7 +172,7 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
|||||||
%files
|
%files
|
||||||
%doc README
|
%doc README
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%{_libdir}/libpoppler.so.65*
|
%{_libdir}/libpoppler.so.66*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/pkgconfig/poppler.pc
|
%{_libdir}/pkgconfig/poppler.pc
|
||||||
@ -232,6 +229,9 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
|||||||
%{_bindir}/poppler-glib-demo
|
%{_bindir}/poppler-glib-demo
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 16 2016 David Tardon <dtardon@redhat.com> - 0.50.0-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
* Tue Nov 22 2016 David Tardon <dtardon@redhat.com> - 0.49.0-1
|
* Tue Nov 22 2016 David Tardon <dtardon@redhat.com> - 0.49.0-1
|
||||||
- new upstream release
|
- new upstream release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user