Update to 0.15.1
Remove CVE-2010-3702, 3703 and 3704 patches (they are already in 0.15.1)
This commit is contained in:
parent
b99c78bb0f
commit
935a0ca382
@ -1,18 +0,0 @@
|
||||
--- poppler-0.15.0/poppler/Gfx.cc 2010-09-12 23:44:11.000000000 +0200
|
||||
+++ poppler-0.15.0/poppler/Gfx.cc 2010-10-07 12:44:51.000000000 +0200
|
||||
@@ -536,6 +536,7 @@ Gfx::Gfx(XRef *xrefA, OutputDev *outA, i
|
||||
drawText = gFalse;
|
||||
maskHaveCSPattern = gFalse;
|
||||
mcStack = NULL;
|
||||
+ parser = NULL;
|
||||
|
||||
// start the resource stack
|
||||
res = new GfxResources(xref, resDict, NULL);
|
||||
@@ -590,6 +591,7 @@ Gfx::Gfx(XRef *xrefA, OutputDev *outA, D
|
||||
drawText = gFalse;
|
||||
maskHaveCSPattern = gFalse;
|
||||
mcStack = NULL;
|
||||
+ parser = NULL;
|
||||
|
||||
// start the resource stack
|
||||
res = new GfxResources(xref, resDict, NULL);
|
@ -1,10 +0,0 @@
|
||||
--- poppler-0.15.0/poppler/Function.cc 2010-07-24 01:18:28.000000000 +0200
|
||||
+++ poppler-0.15.0/poppler/Function.cc 2010-10-07 12:44:51.000000000 +0200
|
||||
@@ -1108,6 +1108,7 @@ PostScriptFunction::PostScriptFunction(O
|
||||
code = NULL;
|
||||
codeString = NULL;
|
||||
codeSize = 0;
|
||||
+ stack = NULL;
|
||||
ok = gFalse;
|
||||
cache = new PopplerCache(5);
|
||||
|
@ -1,28 +0,0 @@
|
||||
--- poppler-0.15.0/fofi/FoFiType1.cc 2010-07-24 01:18:27.000000000 +0200
|
||||
+++ poppler-0.15.0/fofi/FoFiType1.cc 2010-10-07 12:44:51.000000000 +0200
|
||||
@@ -13,7 +13,7 @@
|
||||
// All changes made under the Poppler project to this file are licensed
|
||||
// under GPL version 2 or later
|
||||
//
|
||||
-// Copyright (C) 2005, 2008 Albert Astals Cid <aacid@kde.org>
|
||||
+// Copyright (C) 2005, 2008, 2010 Albert Astals Cid <aacid@kde.org>
|
||||
// Copyright (C) 2005 Kristian Høgsberg <krh@redhat.com>
|
||||
// Copyright (C) 2010 Jakub Wilk <ubanus@users.sf.net>
|
||||
//
|
||||
@@ -31,6 +31,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include "goo/gmem.h"
|
||||
+#include "goo/GooLikely.h"
|
||||
#include "FoFiEncodings.h"
|
||||
#include "FoFiType1.h"
|
||||
#include "poppler/Error.h"
|
||||
@@ -243,7 +244,7 @@ void FoFiType1::parse() {
|
||||
code = code * 8 + (*p2 - '0');
|
||||
}
|
||||
}
|
||||
- if (code < 256) {
|
||||
+ if (likely(code < 256 && code >= 0)) {
|
||||
for (p = p2; *p == ' ' || *p == '\t'; ++p) ;
|
||||
if (*p == '/') {
|
||||
++p;
|
21
poppler.spec
21
poppler.spec
@ -1,8 +1,8 @@
|
||||
|
||||
Summary: PDF rendering library
|
||||
Name: poppler
|
||||
Version: 0.15.0
|
||||
Release: 5%{?dist}
|
||||
Version: 0.15.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: Development/Libraries
|
||||
URL: http://poppler.freedesktop.org/
|
||||
@ -13,14 +13,6 @@ Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.gz
|
||||
Patch1: poppler-0.12.4-annot-appearance.patch
|
||||
|
||||
## upstream patches
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=595245
|
||||
Patch100: poppler-0.15.0-CVE-2010-3702.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=639356
|
||||
Patch101: poppler-0.15.0-CVE-2010-3703.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=638960
|
||||
Patch102: poppler-0.15.0-CVE-2010-3704.patch
|
||||
|
||||
|
||||
Requires: poppler-data >= 0.4.0
|
||||
@ -145,9 +137,6 @@ converting PDF files to a number of other formats.
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .annot
|
||||
%patch100 -p1 -b .CVE-2010-3702
|
||||
%patch101 -p1 -b .CVE-2010-3703
|
||||
%patch102 -p1 -b .CVE-2010-3704
|
||||
|
||||
chmod -x goo/GooTimer.h
|
||||
|
||||
@ -203,7 +192,7 @@ rm -fv $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README
|
||||
%{_libdir}/libpoppler.so.8*
|
||||
%{_libdir}/libpoppler.so.9*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -261,6 +250,10 @@ rm -fv $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 1 2010 Marek Kasik <mkasik@redhat.com> - 0.15.1-1
|
||||
- Update to 0.15.1
|
||||
- Remove CVE-2010-3702, 3703 and 3704 patches (they are already in 0.15.1)
|
||||
|
||||
* Thu Oct 7 2010 Marek Kasik <mkasik@redhat.com> - 0.15.0-5
|
||||
- Add poppler-0.15.0-CVE-2010-3702.patch
|
||||
(Properly initialize parser)
|
||||
|
Loading…
Reference in New Issue
Block a user