new upstream release 0.49.0
This commit is contained in:
parent
c2806e5559
commit
6d07b1a451
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@
|
||||
/poppler-0.43.0.tar.xz
|
||||
/poppler-0.45.0.tar.xz
|
||||
/poppler-0.48.0.tar.xz
|
||||
/poppler-0.49.0.tar.xz
|
||||
|
@ -1,27 +0,0 @@
|
||||
diff -up poppler-0.24.2/configure.ac.mocversiongrep poppler-0.24.2/configure.ac
|
||||
--- poppler-0.24.2/configure.ac.mocversiongrep 2013-10-18 09:51:24.223114884 -0500
|
||||
+++ poppler-0.24.2/configure.ac 2013-10-18 09:54:33.408681067 -0500
|
||||
@@ -646,20 +646,20 @@ if test x$enable_poppler_qt5 = xyes; the
|
||||
AC_CHECK_TOOL(MOCQT5, moc)
|
||||
AC_MSG_CHECKING([for Qt5 moc])
|
||||
mocversion=`$MOCQT5 -v 2>&1`
|
||||
- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc 5"`
|
||||
+ mocversiongrep=`echo $mocversion | grep -E " 5."`
|
||||
if test x"$mocversiongrep" != x"$mocversion"; then
|
||||
AC_MSG_RESULT([no])
|
||||
# moc was not the qt5 one, try with moc-qt5
|
||||
AC_CHECK_TOOL(MOCQT52, moc-qt5)
|
||||
AC_MSG_CHECKING([for Qt5 moc-qt5])
|
||||
mocversion=`$MOCQT52 -v 2>&1`
|
||||
- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc-qt5 5|moc 5"`
|
||||
+ mocversiongrep=`echo $mocversion | grep -E " 5."`
|
||||
if test x"$mocversiongrep" != x"$mocversion"; then
|
||||
AC_CHECK_TOOL(QTCHOOSER, qtchooser)
|
||||
AC_MSG_CHECKING([for qtchooser])
|
||||
qt5tooldir=`QT_SELECT=qt5 qtchooser -print-env | grep QTTOOLDIR | cut -d '=' -f 2 | cut -d \" -f 2`
|
||||
mocversion=`$qt5tooldir/moc -v 2>&1`
|
||||
- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc 5"`
|
||||
+ mocversiongrep=`echo $mocversion | grep -E " 5."`
|
||||
if test x"$mocversiongrep" != x"$mocversion"; then
|
||||
# no valid moc found
|
||||
enable_poppler_qt5=no;
|
25
poppler.spec
25
poppler.spec
@ -1,6 +1,6 @@
|
||||
Summary: PDF rendering library
|
||||
Name: poppler
|
||||
Version: 0.48.0
|
||||
Version: 0.49.0
|
||||
Release: 1%{?dist}
|
||||
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
||||
Group: Development/Libraries
|
||||
@ -13,12 +13,7 @@ Patch0: poppler-0.30.0-rotated-words-selection.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1363669
|
||||
Patch1: poppler-0.45.0-cmsGetColorSpace.patch
|
||||
|
||||
## upstreamable patches
|
||||
# fix configure checks for moc versions
|
||||
Patch50: poppler-0.24.2-mocversiongrep.patch
|
||||
|
||||
Requires: poppler-data >= 0.4.0
|
||||
BuildRequires: automake libtool
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: openjpeg2-devel
|
||||
@ -153,12 +148,6 @@ Requires: %{name}-glib%{?_isa} = %{version}-%{release}
|
||||
%patch0 -p1 -b .rotated-words-selection
|
||||
%patch1 -p1 -b .cmsGetColorSpace
|
||||
|
||||
%patch50 -p1 -b .mocversiongrep
|
||||
|
||||
# hammer to nuke rpaths, recheck on new releases
|
||||
autoreconf -i -f
|
||||
|
||||
|
||||
%build
|
||||
|
||||
%configure \
|
||||
@ -173,6 +162,13 @@ autoreconf -i -f
|
||||
--disable-zlib \
|
||||
--enable-introspection=yes
|
||||
|
||||
sed -i \
|
||||
-e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
|
||||
-e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
|
||||
libtool
|
||||
|
||||
# needed for gobject introspection build, because we killed RPATH
|
||||
export LD_LIBRARY_PATH=`pwd`/poppler/.libs:`pwd`/glib/.libs:${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
@ -218,7 +214,7 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README
|
||||
%{_libdir}/libpoppler.so.64*
|
||||
%{_libdir}/libpoppler.so.65*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -287,6 +283,9 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Nov 22 2016 David Tardon <dtardon@redhat.com> - 0.49.0-1
|
||||
- new upstream release
|
||||
|
||||
* Fri Oct 21 2016 Marek Kasik <mkasik@redhat.com> - 0.48.0-1
|
||||
- Update to 0.48.0
|
||||
- Resolves: #1359555
|
||||
|
Loading…
Reference in New Issue
Block a user