parent
0b34bc3624
commit
55b63a4da1
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
|||||||
/poppler-0.40.0.tar.xz
|
/poppler-0.40.0.tar.xz
|
||||||
/poppler-0.41.0.tar.xz
|
/poppler-0.41.0.tar.xz
|
||||||
/poppler-0.43.0.tar.xz
|
/poppler-0.43.0.tar.xz
|
||||||
|
/poppler-0.45.0.tar.xz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From 182abe4ed5c0773073c6751a26a7c4e40e99e02e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Thomas Freitag <Thomas.Freitag@alfa.de>
|
|
||||||
Date: Fri, 13 May 2016 00:07:24 +0200
|
|
||||||
Subject: [PATCH] Splash: type 3 chars. restore the current position also in
|
|
||||||
output device
|
|
||||||
|
|
||||||
Bug #95344
|
|
||||||
---
|
|
||||||
poppler/Gfx.cc | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
|
|
||||||
index cc6b66d..7d748b9 100644
|
|
||||||
--- a/poppler/Gfx.cc
|
|
||||||
+++ b/poppler/Gfx.cc
|
|
||||||
@@ -4046,6 +4046,7 @@ void Gfx::doShowText(GooString *s) {
|
|
||||||
curX += tdx;
|
|
||||||
curY += tdy;
|
|
||||||
state->moveTo(curX, curY);
|
|
||||||
+ out->updateCTM(state, 0, 0, 0, 0, 0, 0);
|
|
||||||
p += n;
|
|
||||||
len -= n;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
14
poppler.spec
14
poppler.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: PDF rendering library
|
Summary: PDF rendering library
|
||||||
Name: poppler
|
Name: poppler
|
||||||
Version: 0.43.0
|
Version: 0.45.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://poppler.freedesktop.org/
|
URL: http://poppler.freedesktop.org/
|
||||||
@ -10,9 +10,6 @@ Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.xz
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1185007
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1185007
|
||||||
Patch0: poppler-0.30.0-rotated-words-selection.patch
|
Patch0: poppler-0.30.0-rotated-words-selection.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1352717
|
|
||||||
Patch1: poppler-0.43.0-type3-chars-position.patch
|
|
||||||
|
|
||||||
## upstreamable patches
|
## upstreamable patches
|
||||||
# fix configure checks for moc versions
|
# fix configure checks for moc versions
|
||||||
Patch50: poppler-0.24.2-mocversiongrep.patch
|
Patch50: poppler-0.24.2-mocversiongrep.patch
|
||||||
@ -151,7 +148,6 @@ Requires: %{name}-glib%{?_isa} = %{version}-%{release}
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .rotated-words-selection
|
%patch0 -p1 -b .rotated-words-selection
|
||||||
%patch1 -p1 -b .type3-chars-position
|
|
||||||
|
|
||||||
%patch50 -p1 -b .mocversiongrep
|
%patch50 -p1 -b .mocversiongrep
|
||||||
|
|
||||||
@ -218,7 +214,7 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING README
|
%doc COPYING README
|
||||||
%{_libdir}/libpoppler.so.60*
|
%{_libdir}/libpoppler.so.62*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -287,6 +283,10 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 18 2016 Marek Kasik <mkasik@redhat.com> - 0.45.0-1
|
||||||
|
- Update to 0.45.0
|
||||||
|
- Resolves: #1338421
|
||||||
|
|
||||||
* Mon Jul 11 2016 Marek Kasik <mkasik@redhat.com> - 0.43.0-2
|
* Mon Jul 11 2016 Marek Kasik <mkasik@redhat.com> - 0.43.0-2
|
||||||
- Restore the current position of char also in output device
|
- Restore the current position of char also in output device
|
||||||
- Related: #1352717
|
- Related: #1352717
|
||||||
|
Loading…
Reference in New Issue
Block a user