parent
ed22faac0c
commit
34f97a4a32
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
||||
/poppler-21.07.0.tar.xz
|
||||
/poppler-21.08.0.tar.xz
|
||||
/poppler-22.01.0.tar.xz
|
||||
/poppler-22.08.0.tar.xz
|
||||
|
@ -1,9 +1,9 @@
|
||||
--- poppler-0.90.0/CMakeLists.txt
|
||||
+++ poppler-0.90.0/CMakeLists.txt
|
||||
@@ -17,6 +17,9 @@ else()
|
||||
set(THREADS_PREFER_PTHREAD_FLAG TRUE)
|
||||
find_package(Threads)
|
||||
endif()
|
||||
|
||||
include(MacroOptionalFindPackage)
|
||||
find_package(PkgConfig)
|
||||
+
|
||||
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
|
||||
+
|
||||
|
@ -6,6 +6,6 @@
|
||||
set(INTROSPECTION_GIRS)
|
||||
- set(INTROSPECTION_SCANNER_ARGS "--add-include-path=${CMAKE_CURRENT_SOURCE_DIR}" "--warn-all")
|
||||
+ set(INTROSPECTION_SCANNER_ARGS "--add-include-path=${CMAKE_CURRENT_SOURCE_DIR}" "--warn-all" "--sources-top-dirs=${CMAKE_SOURCE_DIR}" "--sources-top-dirs=${CMAKE_BINARY_DIR}")
|
||||
set(INTROSPECTION_COMPILER_ARGS "--includedir=${CMAKE_CURRENT_SOURCE_DIR}")
|
||||
set(INTROSPECTION_COMPILER_ARGS ${INTROSPECTION_COMPILER_ARGS} "--includedir=${CMAKE_CURRENT_SOURCE_DIR}")
|
||||
|
||||
# Poppler: Assign package to gir & export keys
|
||||
|
@ -1,58 +0,0 @@
|
||||
From 81044c64b9ed9a10ae82a28bac753060bdfdac74 Mon Sep 17 00:00:00 2001
|
||||
From: Albert Astals Cid <aacid@kde.org>
|
||||
Date: Tue, 15 Mar 2022 15:14:32 +0100
|
||||
Subject: Hints::readTables: bail out if we run out of file when reading
|
||||
|
||||
Fixes #1230
|
||||
|
||||
diff --git a/poppler/Hints.cc b/poppler/Hints.cc
|
||||
index 79f04088..4707e1c6 100644
|
||||
--- a/poppler/Hints.cc
|
||||
+++ b/poppler/Hints.cc
|
||||
@@ -5,7 +5,7 @@
|
||||
// This file is licensed under the GPLv2 or later
|
||||
//
|
||||
// Copyright 2010, 2012, 2013 Hib Eris <hib@hiberis.nl>
|
||||
-// Copyright 2010, 2011, 2013, 2014, 2016-2019, 2021 Albert Astals Cid <aacid@kde.org>
|
||||
+// Copyright 2010, 2011, 2013, 2014, 2016-2019, 2021, 2022 Albert Astals Cid <aacid@kde.org>
|
||||
// Copyright 2010, 2013 Pino Toscano <pino@kde.org>
|
||||
// Copyright 2013 Adrian Johnson <ajohnson@redneon.com>
|
||||
// Copyright 2014 Fabio D'Urso <fabiodurso@hotmail.it>
|
||||
@@ -189,21 +189,31 @@ void Hints::readTables(BaseStream *str, Linearization *linearization, XRef *xref
|
||||
char *p = &buf[0];
|
||||
|
||||
if (hintsOffset && hintsLength) {
|
||||
- Stream *s = str->makeSubStream(hintsOffset, false, hintsLength, Object(objNull));
|
||||
+ std::unique_ptr<Stream> s(str->makeSubStream(hintsOffset, false, hintsLength, Object(objNull)));
|
||||
s->reset();
|
||||
for (unsigned int i = 0; i < hintsLength; i++) {
|
||||
- *p++ = s->getChar();
|
||||
+ const int c = s->getChar();
|
||||
+ if (unlikely(c == EOF)) {
|
||||
+ error(errSyntaxWarning, -1, "Found EOF while reading hints");
|
||||
+ ok = false;
|
||||
+ return;
|
||||
+ }
|
||||
+ *p++ = c;
|
||||
}
|
||||
- delete s;
|
||||
}
|
||||
|
||||
if (hintsOffset2 && hintsLength2) {
|
||||
- Stream *s = str->makeSubStream(hintsOffset2, false, hintsLength2, Object(objNull));
|
||||
+ std::unique_ptr<Stream> s(str->makeSubStream(hintsOffset2, false, hintsLength2, Object(objNull)));
|
||||
s->reset();
|
||||
for (unsigned int i = 0; i < hintsLength2; i++) {
|
||||
- *p++ = s->getChar();
|
||||
+ const int c = s->getChar();
|
||||
+ if (unlikely(c == EOF)) {
|
||||
+ error(errSyntaxWarning, -1, "Found EOF while reading hints2");
|
||||
+ ok = false;
|
||||
+ return;
|
||||
+ }
|
||||
+ *p++ = c;
|
||||
}
|
||||
- delete s;
|
||||
}
|
||||
|
||||
MemStream *memStream = new MemStream(&buf[0], 0, bufLength, Object(objNull));
|
12
poppler.spec
12
poppler.spec
@ -10,8 +10,8 @@
|
||||
|
||||
Summary: PDF rendering library
|
||||
Name: poppler
|
||||
Version: 22.01.0
|
||||
Release: 6%{?dist}
|
||||
Version: 22.08.0
|
||||
Release: 1%{?dist}
|
||||
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
||||
URL: http://poppler.freedesktop.org/
|
||||
Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.xz
|
||||
@ -22,8 +22,6 @@ Patch1: poppler-0.90.0-position-independent-code.patch
|
||||
|
||||
Patch3: poppler-21.01.0-glib-introspection.patch
|
||||
|
||||
Patch4: poppler-22.01.0-hints.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
@ -201,7 +199,7 @@ test "$(pkg-config --modversion poppler-qt6)" = "%{version}"
|
||||
%files
|
||||
%doc README.md
|
||||
%license COPYING
|
||||
%{_libdir}/libpoppler.so.117*
|
||||
%{_libdir}/libpoppler.so.123*
|
||||
|
||||
%files devel
|
||||
%{_libdir}/pkgconfig/poppler.pc
|
||||
@ -258,6 +256,10 @@ test "$(pkg-config --modversion poppler-qt6)" = "%{version}"
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 2 2022 Marek Kasik <mkasik@redhat.com> - 22.08.0-1
|
||||
- Update to 22.08.0
|
||||
- Resolves: #2049336
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 22.01.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (poppler-test-2021-01-11-03a4b9eb854a06a83c465e82de601796c458bbe9.tar.xz) = 257133b261b07076d3207456e3edad324e29911a45a960d4953eb84813ac175bc65be713a10454b52b96711870fcbeee533fd0fd7de8550a87390e833b1af8c5
|
||||
SHA512 (poppler-22.01.0.tar.xz) = c6ea908a9188483ca588ac81d3e92dd15a405f90d36cc7059e618c8a7e3e9faeda82717aba5df34adb4a0a94e2fbecd472acec44972272349cc8d5a57b7405d1
|
||||
SHA512 (poppler-22.08.0.tar.xz) = bbff6d51eaafe58891357069c83e43ea25b4077755fa715a17b38660cd3cd546fa21d2e17a272d9b375f7e440e6e3661e84a20f18d445e0f28d06971abc04666
|
||||
|
Loading…
Reference in New Issue
Block a user