new upstream release 0.60.0

This commit is contained in:
David Tardon 2017-10-04 10:10:00 +02:00
parent f245d365d7
commit 181d22d777
5 changed files with 56 additions and 74 deletions

2
.gitignore vendored
View File

@ -5,3 +5,5 @@
/poppler-0.56.0.tar.xz
/poppler-0.57.0.tar.xz
/poppler-0.59.0.tar.xz
/poppler-0.60.0.tar.xz
/poppler-0.60.1.tar.xz

View File

@ -0,0 +1,24 @@
From d8aa752574169b6c9e936e4478bee7fa4b781034 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Fri, 6 Oct 2017 08:07:35 +0200
Subject: [PATCH] do not install Function.cc, as it's not a header
---
CMakeLists.txt | 1 -
1 file changed, 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7485b2ad..fe5911c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -572,7 +572,6 @@ if(ENABLE_XPDF_HEADERS)
poppler/FontEncodingTables.h
poppler/FontInfo.h
poppler/Form.h
- poppler/Function.cc
poppler/Function.h
poppler/Gfx.h
poppler/GfxFont.h
--
2.14.1

View File

@ -1,24 +0,0 @@
From 504b3590182175390f474657a372e78fb1508262 Mon Sep 17 00:00:00 2001
From: Albert Astals Cid <aacid@kde.org>
Date: Thu, 14 Sep 2017 19:14:23 +0200
Subject: Splash::scaleImage: Do not try to scale if srcHeight or srcWidth are
< 1
Bug #102719
diff --git a/splash/Splash.cc b/splash/Splash.cc
index 39fc7d6..aba7814 100644
--- a/splash/Splash.cc
+++ b/splash/Splash.cc
@@ -4152,7 +4152,7 @@ SplashBitmap *Splash::scaleImage(SplashImageSource src, void *srcData,
SplashBitmap *dest;
dest = new SplashBitmap(scaledWidth, scaledHeight, 1, srcMode, srcAlpha, gTrue, bitmap->getSeparationList());
- if (dest->getDataPtr() != NULL) {
+ if (dest->getDataPtr() != NULL && srcHeight > 0 && srcWidth > 0) {
if (scaledHeight < srcHeight) {
if (scaledWidth < srcWidth) {
scaleImageYdXd(src, srcData, srcMode, nComps, srcAlpha,
--
cgit v0.10.2

View File

@ -3,8 +3,8 @@
Summary: PDF rendering library
Name: poppler
Version: 0.59.0
Release: 2%{?dist}
Version: 0.60.1
Release: 1%{?dist}
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
URL: http://poppler.freedesktop.org/
Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.xz
@ -15,9 +15,9 @@ Source1: %{name}-test-%{test_date}_%{test_sha}.tar.xz
Patch0: poppler-0.30.0-rotated-words-selection.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1113172
Patch1: 0001-workaround-a-bug-in-nss-header.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1494583
Patch2: CVE-2017-14520.patch
Patch2: 0001-do-not-install-Function.cc-as-it-s-not-a-header.patch
BuildRequires: cmake
BuildRequires: gettext-devel
BuildRequires: pkgconfig(cairo)
BuildRequires: pkgconfig(cairo-ft)
@ -51,6 +51,8 @@ BuildRequires: pkgconfig(QtXml)
Requires: poppler-data
Obsoletes: poppler-glib-demos < 0.60.1-1
%description
%{name} is a PDF rendering library.
@ -141,57 +143,35 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
Command line tools for manipulating PDF files and converting them to
other formats.
%package demos
Summary: Demos for poppler
Requires: %{name}-glib%{?_isa} = %{version}-%{release}
%description demos
%{summary}.
%prep
%autosetup -p1 -b 1
sed -i \
-e '/@\s*check_search\$(EXEEXT)/d' \
-e '/@\s*check_password\$(EXEEXT)/d' \
qt4/tests/Makefile.in \
qt5/tests/Makefile.in
# sed -i \
# -e '/@\s*check_search\$(EXEEXT)/d' \
# -e '/@\s*check_password\$(EXEEXT)/d' \
# qt4/tests/Makefile.in \
# qt5/tests/Makefile.in
%build
%configure \
--disable-silent-rules \
--disable-static \
\
--enable-cairo-output \
--enable-cms=lcms2 \
--enable-gtk-doc \
--enable-gtk-test \
--enable-introspection=yes \
--enable-dctdecoder=libjpeg \
--enable-libopenjpeg=openjpeg2 \
--enable-libpng \
--enable-poppler-glib \
--enable-poppler-qt4 \
--enable-poppler-qt5 \
--enable-xpdf-headers \
--disable-zlib
sed -i \
-e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
-e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
libtool
# needed for gobject introspection build, because we killed RPATH
export LD_LIBRARY_PATH=`pwd`/poppler/.libs:`pwd`/glib/.libs:${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
mkdir build
cd build
export CC="gcc -fPIC" # hack to make the cmake call pass
%cmake \
-DENABLE_CMS=lcms2 \
-DENABLE_DCTDECODER=libjpeg \
-DENABLE_GTK_DOC=ON \
-DENABLE_LIBOPENJPEG=openjpeg2 \
-DENABLE_XPDF_HEADERS=ON \
-DENABLE_ZLIB=OFF \
..
unset CC
make %{?_smp_mflags}
%install
cd build
make install DESTDIR=$RPM_BUILD_ROOT
rm -fv $RPM_BUILD_ROOT%{_libdir}/lib*.la
%check
export LD_LIBRARY_PATH=`pwd`/poppler/.libs:`pwd`/qt4/src/.libs:`pwd`/qt5/src/.libs:${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
make %{?_smp_mflags} check
make %{?_smp_mflags} test
# verify pkg-config sanity/version
export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
@ -221,7 +201,7 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
%files
%doc README
%license COPYING
%{_libdir}/libpoppler.so.70*
%{_libdir}/libpoppler.so.71*
%files devel
%{_libdir}/pkgconfig/poppler.pc
@ -277,10 +257,10 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
%{_bindir}/pdf*
%{_mandir}/man1/*
%files demos
%{_bindir}/poppler-glib-demo
%changelog
* Wed Oct 04 2017 David Tardon <dtardon@redhat.com> - 0.60.0-1
- new upstream release
* Mon Sep 25 2017 Caolán McNamara <caolanm@redhat.com> - 0.59.0-2
- Resolves: rhbz#1494583 CVE-2017-14520

View File

@ -1,2 +1,2 @@
SHA512 (poppler-0.59.0.tar.xz) = 23777922dc95feee2a4459281081b37e124a39fc25cd00c2c3fc206f5484c13eb9ac5317f674fbbcb51e384f9a53e38b4cacbf1426c68d2bae21a7cefbc48a0e
SHA512 (poppler-0.60.1.tar.xz) = db73524b7413dddee38d5a049f3926338ee123b8fc4893d80ee9cf5aaae47c8c7b75b112293b156cd375894e548ec68e5fbf4af305e77b43bc3868ad1c966cdc
SHA512 (poppler-test-2009-05-13_0d2bfd4af4c76a3bac27ccaff793d9129df7b57a.tar.xz) = f8ce114357043a893100de2d52ada8bd850148d19f0e8c889988ea97e9a92313f0545c0b88ef32a1ce7f0e9e58edc1a8c9066278c20b7718ca619913fd4bfb3c