Update to 0.26.0
This commit is contained in:
parent
bd63cda573
commit
15f207a36f
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/poppler-0.24.1.tar.xz
|
||||
/poppler-0.24.2.tar.xz
|
||||
/poppler-0.24.3.tar.xz
|
||||
/poppler-0.26.0.tar.xz
|
||||
|
@ -1,11 +1,11 @@
|
||||
diff -up poppler-0.24.2/configure.ac.mocversiongrep poppler-0.24.2/configure.ac
|
||||
--- poppler-0.24.2/configure.ac.mocversiongrep 2013-10-18 09:51:24.223114884 -0500
|
||||
+++ poppler-0.24.2/configure.ac 2013-10-18 09:54:33.408681067 -0500
|
||||
@@ -661,20 +661,20 @@ if test x$enable_poppler_qt5 = xyes; the
|
||||
@@ -646,20 +646,20 @@ if test x$enable_poppler_qt5 = xyes; the
|
||||
AC_CHECK_TOOL(MOCQT5, moc)
|
||||
AC_MSG_CHECKING([for Qt5 moc])
|
||||
mocversion=`$MOCQT5 -v 2>&1`
|
||||
- mocversiongrep=`echo $mocversion | grep "Qt 5"`
|
||||
- mocversiongrep=`echo $mocversion | grep "Qt 5\|moc 5"`
|
||||
+ mocversiongrep=`echo $mocversion | grep " 5\."`
|
||||
if test x"$mocversiongrep" != x"$mocversion"; then
|
||||
AC_MSG_RESULT([no])
|
||||
@ -13,14 +13,14 @@ diff -up poppler-0.24.2/configure.ac.mocversiongrep poppler-0.24.2/configure.ac
|
||||
AC_CHECK_TOOL(MOCQT52, moc-qt5)
|
||||
AC_MSG_CHECKING([for Qt5 moc-qt5])
|
||||
mocversion=`$MOCQT52 -v 2>&1`
|
||||
- mocversiongrep=`echo $mocversion | grep "Qt 5"`
|
||||
- mocversiongrep=`echo $mocversion | grep "Qt 5\|moc 5"`
|
||||
+ mocversiongrep=`echo $mocversion | grep " 5\."`
|
||||
if test x"$mocversiongrep" != x"$mocversion"; then
|
||||
AC_CHECK_TOOL(QTCHOOSER, qtchooser)
|
||||
AC_MSG_CHECKING([for qtchooser])
|
||||
qt5tooldir=`QT_SELECT=qt5 qtchooser -print-env | grep QTTOOLDIR | cut -d '=' -f 2 | cut -d \" -f 2`
|
||||
mocversion=`$qt5tooldir/moc -v 2>&1`
|
||||
- mocversiongrep=`echo $mocversion | grep "Qt 5"`
|
||||
- mocversiongrep=`echo $mocversion | grep "Qt 5\|moc 5"`
|
||||
+ mocversiongrep=`echo $mocversion | grep " 5\."`
|
||||
if test x"$mocversiongrep" != x"$mocversion"; then
|
||||
# no valid moc found
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 58e04a08afee39370283c494ee2e4e392fd3b684 Mon Sep 17 00:00:00 2001
|
||||
From: Fabio D'Urso <fabiodurso@hotmail.it>
|
||||
Date: Sat, 7 Dec 2013 16:33:09 +0000
|
||||
Subject: [PATCH] segExtraBytes is a goffset not an int so use lld
|
||||
|
||||
Fixes KDE bug #328511
|
||||
---
|
||||
poppler/JBIG2Stream.cc | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/poppler/JBIG2Stream.cc b/poppler/JBIG2Stream.cc
|
||||
index 12de50e..dbc7bdc 100644
|
||||
--- a/poppler/JBIG2Stream.cc
|
||||
+++ b/poppler/JBIG2Stream.cc
|
||||
@@ -1495,7 +1495,7 @@ void JBIG2Stream::readSegments() {
|
||||
// arithmetic-coded symbol dictionary segments when numNewSyms
|
||||
// == 0. Segments like this often occur for blank pages.
|
||||
|
||||
- error(errSyntaxError, curStr->getPos(), "{0:d} extraneous byte{1:s} after segment",
|
||||
+ error(errSyntaxError, curStr->getPos(), "{0:lld} extraneous byte{1:s} after segment",
|
||||
segExtraBytes, (segExtraBytes > 1) ? "s" : "");
|
||||
|
||||
// Burn through the remaining bytes -- inefficient, but
|
||||
--
|
||||
1.8.4.2
|
||||
|
27
poppler-0.26.0-multiple-defs.patch
Normal file
27
poppler-0.26.0-multiple-defs.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From c859d2b891a115c79d04db14463791dfb1c46a20 Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
||||
Date: Wed, 30 Apr 2014 09:25:31 +0200
|
||||
Subject: [PATCH] glib: Fix multiple definition of PopplerTextSpan
|
||||
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=78103
|
||||
---
|
||||
glib/poppler-structure-element.h | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/glib/poppler-structure-element.h b/glib/poppler-structure-element.h
|
||||
index 4596a41..3848c21 100644
|
||||
--- a/glib/poppler-structure-element.h
|
||||
+++ b/glib/poppler-structure-element.h
|
||||
@@ -250,9 +250,6 @@ typedef enum {
|
||||
} PopplerStructureTableScope;
|
||||
|
||||
|
||||
-typedef struct _PopplerTextSpan PopplerTextSpan;
|
||||
-
|
||||
-
|
||||
GType poppler_structure_element_get_type (void) G_GNUC_CONST;
|
||||
PopplerStructureElementKind poppler_structure_element_get_kind (PopplerStructureElement *poppler_structure_element);
|
||||
gint poppler_structure_element_get_page (PopplerStructureElement *poppler_structure_element);
|
||||
--
|
||||
1.9.0
|
||||
|
13
poppler.spec
13
poppler.spec
@ -1,14 +1,14 @@
|
||||
|
||||
Summary: PDF rendering library
|
||||
Name: poppler
|
||||
Version: 0.24.3
|
||||
Release: 3%{?dist}
|
||||
Version: 0.26.0
|
||||
Release: 1%{?dist}
|
||||
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
||||
Group: Development/Libraries
|
||||
URL: http://poppler.freedesktop.org/
|
||||
Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.xz
|
||||
|
||||
Patch0: poppler-0.24.3-segExtraBytes.patch
|
||||
Patch0: poppler-0.26.0-multiple-defs.patch
|
||||
|
||||
## upstreamable patches
|
||||
# fix configure checks for moc versions
|
||||
@ -146,8 +146,8 @@ Requires: %{name}-glib%{?_isa} = %{version}-%{release}
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .multiple-defs
|
||||
|
||||
%patch0 -p1 -b .segExtraBytes
|
||||
%patch50 -p1 -b .mocversiongrep
|
||||
|
||||
# hammer to nuke rpaths, recheck on new releases
|
||||
@ -213,7 +213,7 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README
|
||||
%{_libdir}/libpoppler.so.43*
|
||||
%{_libdir}/libpoppler.so.46*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -282,6 +282,9 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue May 13 2014 Marek Kasik <mkasik@redhat.com> - 0.26.0-1
|
||||
- Update to 0.26.0
|
||||
|
||||
* Fri Jan 3 2014 Marek Kasik <mkasik@redhat.com> - 0.24.3-3
|
||||
- Use correct format string
|
||||
- Resolves: #1048202
|
||||
|
Loading…
Reference in New Issue
Block a user