Update to 0.24.0
This commit is contained in:
parent
f94c2f44f3
commit
0718d24ec9
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
|||||||
/poppler-0.22.0.tar.gz
|
/poppler-0.22.0.tar.gz
|
||||||
/poppler-0.22.1.tar.gz
|
/poppler-0.22.1.tar.gz
|
||||||
/poppler-0.22.5.tar.gz
|
/poppler-0.22.5.tar.gz
|
||||||
|
/poppler-0.24.0.tar.xz
|
||||||
|
@ -0,0 +1,26 @@
|
|||||||
|
From ef9d861486d54fb3dcf7b8bca01bd44c3b3361a9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
||||||
|
Date: Tue, 30 Jul 2013 09:36:44 +0200
|
||||||
|
Subject: [PATCH] glib-demo: Remove GTK_DISABLE_DEPRECATED compilation flag
|
||||||
|
|
||||||
|
Deprecations are now compile warnings, there's no reason to make them
|
||||||
|
fatal.
|
||||||
|
---
|
||||||
|
glib/demo/Makefile.am | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/glib/demo/Makefile.am b/glib/demo/Makefile.am
|
||||||
|
index 28fc22d..8120bc9 100644
|
||||||
|
--- a/glib/demo/Makefile.am
|
||||||
|
+++ b/glib/demo/Makefile.am
|
||||||
|
@@ -3,7 +3,6 @@ INCLUDES = \
|
||||||
|
-I$(top_builddir)/glib \
|
||||||
|
$(GTK_TEST_CFLAGS) \
|
||||||
|
$(POPPLER_GLIB_DISABLE_DEPRECATED) \
|
||||||
|
- -DGTK_DISABLE_DEPRECATED \
|
||||||
|
$(POPPLER_GLIB_DISABLE_SINGLE_INCLUDES)
|
||||||
|
|
||||||
|
AM_LDFLAGS = @auto_import_flags@
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
53
poppler.spec
53
poppler.spec
@ -1,11 +1,13 @@
|
|||||||
Summary: PDF rendering library
|
Summary: PDF rendering library
|
||||||
Name: poppler
|
Name: poppler
|
||||||
Version: 0.22.5
|
Version: 0.24.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
License: (GPLv2 or GPLv3) and GPLv2+ and LGPLv2+ and MIT
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://poppler.freedesktop.org/
|
URL: http://poppler.freedesktop.org/
|
||||||
Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.gz
|
Source0: http://poppler.freedesktop.org/poppler-%{version}.tar.xz
|
||||||
|
|
||||||
|
Patch0: 0001-glib-demo-Remove-GTK_DISABLE_DEPRECATED-compilation-.patch
|
||||||
|
|
||||||
Requires: poppler-data >= 0.4.0
|
Requires: poppler-data >= 0.4.0
|
||||||
BuildRequires: automake libtool
|
BuildRequires: automake libtool
|
||||||
@ -17,6 +19,7 @@ BuildRequires: pkgconfig(gobject-introspection-1.0)
|
|||||||
BuildRequires: pkgconfig(gtk+-3.0)
|
BuildRequires: pkgconfig(gtk+-3.0)
|
||||||
BuildRequires: pkgconfig(lcms2)
|
BuildRequires: pkgconfig(lcms2)
|
||||||
BuildRequires: pkgconfig(QtGui) pkgconfig(QtXml)
|
BuildRequires: pkgconfig(QtGui) pkgconfig(QtXml)
|
||||||
|
BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Xml)
|
||||||
BuildRequires: pkgconfig(libtiff-4)
|
BuildRequires: pkgconfig(libtiff-4)
|
||||||
|
|
||||||
|
|
||||||
@ -73,6 +76,24 @@ Requires: qt4-devel
|
|||||||
%{summary}.
|
%{summary}.
|
||||||
|
|
||||||
|
|
||||||
|
%package qt5
|
||||||
|
Summary: Qt5 wrapper for poppler
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
%{?_qt5:Requires: qt5%{?_isa} >= %{_qt5_version}}
|
||||||
|
%description qt5
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package qt5-devel
|
||||||
|
Summary: Development files for Qt5 wrapper
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name}-qt5%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: qt5-devel
|
||||||
|
%description qt5-devel
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
|
||||||
%package cpp
|
%package cpp
|
||||||
Summary: Pure C++ wrapper for poppler
|
Summary: Pure C++ wrapper for poppler
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -122,6 +143,8 @@ Requires: %{name}-glib%{?_isa} = %{version}-%{release}
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch0 -p1 -b .gtk-deprecated
|
||||||
|
|
||||||
iconv -f iso-8859-1 -t utf-8 < "utils/pdftohtml.1" > "utils/pdftohtml.1.utf8"
|
iconv -f iso-8859-1 -t utf-8 < "utils/pdftohtml.1" > "utils/pdftohtml.1.utf8"
|
||||||
mv "utils/pdftohtml.1.utf8" "utils/pdftohtml.1"
|
mv "utils/pdftohtml.1.utf8" "utils/pdftohtml.1"
|
||||||
|
|
||||||
@ -131,15 +154,13 @@ autoreconf -i -f
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
# Hack around borkage, http://cgit.freedesktop.org/poppler/poppler/commit/configure.ac?id=9250449aaa279840d789b3a7cef75d06a0fd88e7
|
|
||||||
PATH=%{_qt4_bindir}:$PATH; export PATH
|
|
||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--enable-cairo-output \
|
--enable-cairo-output \
|
||||||
--enable-libjpeg \
|
--enable-libjpeg \
|
||||||
--enable-libopenjpeg \
|
--enable-libopenjpeg \
|
||||||
--enable-poppler-qt4 \
|
--enable-poppler-qt4 \
|
||||||
|
--enable-poppler-qt5 \
|
||||||
--enable-xpdf-headers \
|
--enable-xpdf-headers \
|
||||||
--disable-zlib \
|
--disable-zlib \
|
||||||
--enable-introspection=yes
|
--enable-introspection=yes
|
||||||
@ -161,6 +182,7 @@ test "$(pkg-config --modversion poppler-cairo)" = "%{version}"
|
|||||||
test "$(pkg-config --modversion poppler-cpp)" = "%{version}"
|
test "$(pkg-config --modversion poppler-cpp)" = "%{version}"
|
||||||
test "$(pkg-config --modversion poppler-glib)" = "%{version}"
|
test "$(pkg-config --modversion poppler-glib)" = "%{version}"
|
||||||
test "$(pkg-config --modversion poppler-qt4)" = "%{version}"
|
test "$(pkg-config --modversion poppler-qt4)" = "%{version}"
|
||||||
|
test "$(pkg-config --modversion poppler-qt5)" = "%{version}"
|
||||||
test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
||||||
|
|
||||||
|
|
||||||
@ -176,6 +198,10 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
|||||||
|
|
||||||
%postun qt -p /sbin/ldconfig
|
%postun qt -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%post qt5 -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun qt5 -p /sbin/ldconfig
|
||||||
|
|
||||||
%post cpp -p /sbin/ldconfig
|
%post cpp -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun cpp -p /sbin/ldconfig
|
%postun cpp -p /sbin/ldconfig
|
||||||
@ -184,7 +210,7 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING README
|
%doc COPYING README
|
||||||
%{_libdir}/libpoppler.so.37*
|
%{_libdir}/libpoppler.so.43*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -222,6 +248,16 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
|||||||
%{_libdir}/pkgconfig/poppler-qt4.pc
|
%{_libdir}/pkgconfig/poppler-qt4.pc
|
||||||
%{_includedir}/poppler/qt4/
|
%{_includedir}/poppler/qt4/
|
||||||
|
|
||||||
|
%files qt5
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_libdir}/libpoppler-qt5.so.1*
|
||||||
|
|
||||||
|
%files qt5-devel
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_libdir}/libpoppler-qt5.so
|
||||||
|
%{_libdir}/pkgconfig/poppler-qt5.pc
|
||||||
|
%{_includedir}/poppler/qt5/
|
||||||
|
|
||||||
%files cpp
|
%files cpp
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libpoppler-cpp.so.0*
|
%{_libdir}/libpoppler-cpp.so.0*
|
||||||
@ -243,6 +279,9 @@ test "$(pkg-config --modversion poppler-splash)" = "%{version}"
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 19 2013 Marek Kasik <mkasik@redhat.com> - 0.24.0-1
|
||||||
|
- Update to 0.24.0
|
||||||
|
|
||||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22.5-2
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22.5-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user