reduce waking session monitor on uninteresting session changes
make polkit-pkla-compat uninstallable (for cases when no .pkla on system) Resolves: RHEL-34029
This commit is contained in:
parent
3b50e6fc37
commit
f3bcf821f8
13
polkit-0.115-session-monitor-watch-sessions-only.patch
Normal file
13
polkit-0.115-session-monitor-watch-sessions-only.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/src/polkitbackend/polkitbackendsessionmonitor-systemd.c b/src/polkitbackend/polkitbackendsessionmonitor-systemd.c
|
||||
index 1a6107a..3abd7c5 100644
|
||||
--- a/src/polkitbackend/polkitbackendsessionmonitor-systemd.c
|
||||
+++ b/src/polkitbackend/polkitbackendsessionmonitor-systemd.c
|
||||
@@ -106,7 +106,7 @@ sd_source_new (void)
|
||||
source = g_source_new (&sd_source_funcs, sizeof (SdSource));
|
||||
sd_source = (SdSource *)source;
|
||||
|
||||
- if ((ret = sd_login_monitor_new (NULL, &sd_source->monitor)) < 0)
|
||||
+ if ((ret = sd_login_monitor_new ("session", &sd_source->monitor)) < 0)
|
||||
{
|
||||
g_printerr ("Error getting login monitor: %d", ret);
|
||||
}
|
11
polkit.spec
11
polkit.spec
@ -6,7 +6,7 @@
|
||||
Summary: An authorization framework
|
||||
Name: polkit
|
||||
Version: 0.115
|
||||
Release: 15%{?dist}
|
||||
Release: 15%{?dist}.1
|
||||
License: LGPLv2+
|
||||
URL: http://www.freedesktop.org/wiki/Software/polkit
|
||||
Source0: http://www.freedesktop.org/software/polkit/releases/%{name}-%{version}.tar.gz
|
||||
@ -29,6 +29,7 @@ Patch12: polkit-0.115-CVE-2021-3560.patch
|
||||
Patch13: polkit-0.115-CVE-2021-4034.patch
|
||||
Patch14: polkit-0.115-CVE-2021-4115.patch
|
||||
Patch15: polkit-0.115-tty-flags-restore-if-changed.patch
|
||||
Patch16: polkit-0.115-session-monitor-watch-sessions-only.patch
|
||||
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
@ -48,7 +49,8 @@ BuildRequires: automake
|
||||
BuildRequires: libtool
|
||||
%endif
|
||||
|
||||
Requires: dbus, polkit-pkla-compat
|
||||
Requires: dbus
|
||||
Recommends: polkit-pkla-compat
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
Requires(pre): shadow-utils
|
||||
@ -194,6 +196,11 @@ exit 0
|
||||
%{_libdir}/girepository-1.0/*.typelib
|
||||
|
||||
%changelog
|
||||
* Mon Apr 22 2024 Jan Rybar <jrybar@redhat.com> - 0.115-15.1
|
||||
- reduce waking session monitor on uninteresting session changes
|
||||
- make polkit-pkla-compat uninstallable (for cases when no .pkla on system)
|
||||
- Resolves: RHEL-34029
|
||||
|
||||
* Tue Nov 08 2022 Jan Rybar <jrybar@redhat.com> - 0.115-15
|
||||
- pkttyagent gets stopped if killed in the background
|
||||
- Resolves: rhbz#2128989
|
||||
|
Loading…
Reference in New Issue
Block a user