Drop unused patches
This commit is contained in:
parent
d3f9a6d2ec
commit
cea6506a91
@ -1,89 +0,0 @@
|
||||
commit 7ecf29a9db86f7161e2ff48e7bb8ea46a90f954f
|
||||
Author: Miloslav Trmač <mitr@redhat.com>
|
||||
Date: Wed Feb 8 22:57:21 2017 +0100
|
||||
|
||||
Fix a memory leak in server_handle_authentication_agent_response{,2}
|
||||
|
||||
Signed-off-by: Miloslav Trmač <mitr@redhat.com>
|
||||
|
||||
diff --git a/src/polkitbackend/polkitbackendauthority.c b/src/polkitbackend/polkitbackendauthority.c
|
||||
index 2bcad62..cad3f74 100644
|
||||
--- a/src/polkitbackend/polkitbackendauthority.c
|
||||
+++ b/src/polkitbackend/polkitbackendauthority.c
|
||||
@@ -1054,6 +1054,7 @@ server_handle_authentication_agent_response (Server *server,
|
||||
g_dbus_method_invocation_return_value (invocation, g_variant_new ("()"));
|
||||
|
||||
out:
|
||||
+ g_variant_unref (identity_gvariant);
|
||||
if (identity != NULL)
|
||||
g_object_unref (identity);
|
||||
}
|
||||
@@ -1104,6 +1105,7 @@ server_handle_authentication_agent_response2 (Server *server,
|
||||
g_dbus_method_invocation_return_value (invocation, g_variant_new ("()"));
|
||||
|
||||
out:
|
||||
+ g_variant_unref (identity_gvariant);
|
||||
if (identity != NULL)
|
||||
g_object_unref (identity);
|
||||
}
|
||||
|
||||
commit d9efd2673d73214e7990e3e67cdddfa77c6a8226
|
||||
Author: Miloslav Trmač <mitr@redhat.com>
|
||||
Date: Wed Feb 8 22:55:10 2017 +0100
|
||||
|
||||
Fix a memory leak in server_handle_unregister_authentication_agent
|
||||
|
||||
Signed-off-by: Miloslav Trmač <mitr@redhat.com>
|
||||
|
||||
diff --git a/src/polkitbackend/polkitbackendauthority.c b/src/polkitbackend/polkitbackendauthority.c
|
||||
index 7e08e57..2bcad62 100644
|
||||
--- a/src/polkitbackend/polkitbackendauthority.c
|
||||
+++ b/src/polkitbackend/polkitbackendauthority.c
|
||||
@@ -1003,6 +1003,7 @@ server_handle_unregister_authentication_agent (Server *server,
|
||||
g_dbus_method_invocation_return_value (invocation, g_variant_new ("()"));
|
||||
|
||||
out:
|
||||
+ g_variant_unref (subject_gvariant);
|
||||
if (subject != NULL)
|
||||
g_object_unref (subject);
|
||||
}
|
||||
|
||||
commit af4566e1a7e9031b9a05f49c7d27bf379d822016
|
||||
Author: Miloslav Trmač <mitr@redhat.com>
|
||||
Date: Thu Feb 9 19:53:54 2017 +0100
|
||||
|
||||
Fix a memory leak per agent authentication
|
||||
|
||||
Signed-off-by: Miloslav Trmač <mitr@redhat.com>
|
||||
|
||||
diff --git a/src/polkitbackend/polkitbackendinteractiveauthority.c b/src/polkitbackend/polkitbackendinteractiveauthority.c
|
||||
index bf0ee48..b8096b3 100644
|
||||
--- a/src/polkitbackend/polkitbackendinteractiveauthority.c
|
||||
+++ b/src/polkitbackend/polkitbackendinteractiveauthority.c
|
||||
@@ -1906,15 +1906,15 @@ authentication_agent_begin_cb (GDBusProxy *proxy,
|
||||
AuthenticationSession *session = user_data;
|
||||
gboolean gained_authorization;
|
||||
gboolean was_dismissed;
|
||||
+ GVariant *result;
|
||||
GError *error;
|
||||
|
||||
was_dismissed = FALSE;
|
||||
gained_authorization = FALSE;
|
||||
|
||||
error = NULL;
|
||||
- if (!g_dbus_proxy_call_finish (proxy,
|
||||
- res,
|
||||
- &error))
|
||||
+ result = g_dbus_proxy_call_finish (proxy, res, &error);
|
||||
+ if (result == NULL)
|
||||
{
|
||||
g_printerr ("Error performing authentication: %s (%s %d)\n",
|
||||
error->message,
|
||||
@@ -1926,6 +1926,7 @@ authentication_agent_begin_cb (GDBusProxy *proxy,
|
||||
}
|
||||
else
|
||||
{
|
||||
+ g_variant_unref (result);
|
||||
gained_authorization = session->is_authenticated;
|
||||
g_debug ("Authentication complete, is_authenticated = %d", session->is_authenticated);
|
||||
}
|
@ -1,42 +0,0 @@
|
||||
diff --git a/data/Makefile.am b/data/Makefile.am
|
||||
index fe0f1d5..18693fe 100644
|
||||
--- a/data/Makefile.am
|
||||
+++ b/data/Makefile.am
|
||||
@@ -36,6 +36,11 @@ pkgconfig_DATA = polkit-gobject-1.pc polkit-agent-1.pc
|
||||
|
||||
# ----------------------------------------------------------------------------------------------------
|
||||
|
||||
+itsdir = $(datadir)/gettext/its
|
||||
+its_DATA = polkit.loc polkit.its
|
||||
+
|
||||
+# ----------------------------------------------------------------------------------------------------
|
||||
+
|
||||
systemdservice_in_files = polkit.service.in
|
||||
|
||||
if HAVE_SYSTEMD
|
||||
diff --git a/data/polkit.its b/data/polkit.its
|
||||
new file mode 100644
|
||||
index 0000000..1c37e6b
|
||||
--- /dev/null
|
||||
+++ b/data/polkit.its
|
||||
@@ -0,0 +1,8 @@
|
||||
+<?xml version="1.0"?>
|
||||
+<its:rules xmlns:its="http://www.w3.org/2005/11/its"
|
||||
+ version="2.0">
|
||||
+ <its:translateRule selector="//*" translate="no"/>
|
||||
+ <its:translateRule selector="//action/description |
|
||||
+ //action/message"
|
||||
+ translate="yes"/>
|
||||
+</its:rules>
|
||||
diff --git a/data/polkit.loc b/data/polkit.loc
|
||||
new file mode 100644
|
||||
index 0000000..c7427ec
|
||||
--- /dev/null
|
||||
+++ b/data/polkit.loc
|
||||
@@ -0,0 +1,6 @@
|
||||
+<?xml version="1.0"?>
|
||||
+<locatingRules>
|
||||
+ <locatingRule name="polkit policy" pattern="*.policy">
|
||||
+ <documentRule localName="policyconfig" target="polkit.its"/>
|
||||
+ </locatingRule>
|
||||
+</locatingRules>
|
@ -1,27 +0,0 @@
|
||||
From dfd2c165447029c32510842350e924ef5ac3f679 Mon Sep 17 00:00:00 2001
|
||||
From: Rui Matos <tiagomatos@gmail.com>
|
||||
Date: Thu, 2 Mar 2017 14:50:31 +0100
|
||||
Subject: [PATCH] polkitpermission: Fix a memory leak on authority changes
|
||||
|
||||
Signed-off-by: Rui Matos <tiagomatos@gmail.com>
|
||||
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=99741
|
||||
---
|
||||
src/polkit/polkitpermission.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/polkit/polkitpermission.c b/src/polkit/polkitpermission.c
|
||||
index f8a666e..f264094 100644
|
||||
--- a/src/polkit/polkitpermission.c
|
||||
+++ b/src/polkit/polkitpermission.c
|
||||
@@ -454,6 +454,7 @@ changed_check_cb (GObject *source_object,
|
||||
if (result != NULL)
|
||||
{
|
||||
process_result (permission, result);
|
||||
+ g_object_unref (result);
|
||||
}
|
||||
else
|
||||
{
|
||||
--
|
||||
2.9.3
|
||||
|
Loading…
Reference in New Issue
Block a user