c65daa990e
- Build with libsepol.so.1 and libsemanage.so.2 - Set X-GNOME-HiddenUnderSystemd=true in restorecond.desktop file - fixfiles: correctly restore context of mountpoints - sepolgen: print extended permissions in hexadecimal
33 lines
1.4 KiB
Diff
33 lines
1.4 KiB
Diff
From 8bc865e1fe8f6f734b7306441ccbeec3b7c37f97 Mon Sep 17 00:00:00 2001
|
|
From: Dominick Grift <dominick.grift@defensec.nl>
|
|
Date: Tue, 1 Sep 2020 18:16:41 +0200
|
|
Subject: [PATCH] newrole: support cross-compilation with PAM and audit
|
|
|
|
Compilation of newrole with PAM and audit support currently requires that you have the respective headers installed on the host. Instead make the header location customizable to accomodate cross-compilation.
|
|
|
|
Signed-off-by: Dominick Grift <dominick.grift@defensec.nl>
|
|
Acked-by: Stephen Smalley <stephen.smalley.work@gmail.com>
|
|
---
|
|
policycoreutils/newrole/Makefile | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/policycoreutils/newrole/Makefile b/policycoreutils/newrole/Makefile
|
|
index 73ebd413da85..0e7ebce3dd56 100644
|
|
--- a/policycoreutils/newrole/Makefile
|
|
+++ b/policycoreutils/newrole/Makefile
|
|
@@ -5,8 +5,9 @@ BINDIR ?= $(PREFIX)/bin
|
|
MANDIR ?= $(PREFIX)/share/man
|
|
ETCDIR ?= /etc
|
|
LOCALEDIR = $(DESTDIR)$(PREFIX)/share/locale
|
|
-PAMH ?= $(shell test -f /usr/include/security/pam_appl.h && echo y)
|
|
-AUDITH ?= $(shell test -f /usr/include/libaudit.h && echo y)
|
|
+INCLUDEDIR ?= $(PREFIX)/include
|
|
+PAMH ?= $(shell test -f $(INCLUDEDIR)/security/pam_appl.h && echo y)
|
|
+AUDITH ?= $(shell test -f $(INCLUDEDIR)/libaudit.h && echo y)
|
|
# Enable capabilities to permit newrole to generate audit records.
|
|
# This will make newrole a setuid root program.
|
|
# The capabilities used are: CAP_AUDIT_WRITE.
|
|
--
|
|
2.29.0
|
|
|