ea40a6c901
- restorecond: Install DBUS service file with 644 permissions
26 lines
1.1 KiB
Diff
26 lines
1.1 KiB
Diff
diff --git restorecond-2.8/Makefile restorecond-2.8/Makefile
|
|
index 25be18d..26eb411 100644
|
|
--- restorecond-2.8/Makefile
|
|
+++ restorecond-2.8/Makefile
|
|
@@ -50,7 +50,7 @@ install: all
|
|
-mkdir -p $(DESTDIR)$(AUTOSTARTDIR)
|
|
install -m 644 restorecond.desktop $(DESTDIR)$(AUTOSTARTDIR)/restorecond.desktop
|
|
-mkdir -p $(DESTDIR)$(DBUSSERVICEDIR)
|
|
- install -m 600 org.selinux.Restorecond.service $(DESTDIR)$(DBUSSERVICEDIR)/org.selinux.Restorecond.service
|
|
+ install -m 644 org.selinux.Restorecond.service $(DESTDIR)$(DBUSSERVICEDIR)/org.selinux.Restorecond.service
|
|
-mkdir -p $(DESTDIR)$(SYSTEMDDIR)/system
|
|
install -m 644 restorecond.service $(DESTDIR)$(SYSTEMDDIR)/system/
|
|
relabel: install
|
|
diff --git restorecond-2.8/restorecond.c restorecond-2.8/restorecond.c
|
|
index 6fbbd35..e1d26cb 100644
|
|
--- restorecond-2.8/restorecond.c
|
|
+++ restorecond-2.8/restorecond.c
|
|
@@ -105,6 +105,7 @@ static int write_pid_file(void)
|
|
}
|
|
if (write(pidfd, val, (unsigned int)len) != len) {
|
|
syslog(LOG_ERR, "Unable to write to pidfile (%s)", strerror(errno));
|
|
+ close(pidfd);
|
|
return 1;
|
|
}
|
|
close(pidfd);
|