38ab1da754
- sepolicy: Fix translated strings with parameters - sepolicy: Support non-MLS policy - sepolicy: Initialize policy.ports as a dict in generate.py - gui/polgengui.py: Use stop_emission_by_name instead of emit_stop_by_name - Minor update for bash completion - semodule_package: fix semodule_unpackage man page - gui/semanagePage: Close "edit" and "add" dialogues when successfull - gui/fcontextPage: Set default object class in addDialog\ - sepolgen: fix typo in PolicyGenerator - build: follow standard semantics for DESTDIR and PREFIX
65 lines
2.5 KiB
Diff
65 lines
2.5 KiB
Diff
diff --git selinux-dbus-2.7/Makefile selinux-dbus-2.7/Makefile
|
|
index 9a6cc90..53143af 100644
|
|
--- selinux-dbus-2.7/Makefile
|
|
+++ selinux-dbus-2.7/Makefile
|
|
@@ -1,3 +1,5 @@
|
|
+PREFIX ?= /usr
|
|
+
|
|
all:
|
|
|
|
clean:
|
|
@@ -5,12 +7,12 @@ clean:
|
|
install:
|
|
-mkdir -p $(DESTDIR)/etc/dbus-1/system.d/
|
|
install -m 644 org.selinux.conf $(DESTDIR)/etc/dbus-1/system.d/
|
|
- -mkdir -p $(DESTDIR)/usr/share/dbus-1/system-services
|
|
- install -m 644 org.selinux.service $(DESTDIR)/usr/share/dbus-1/system-services
|
|
- -mkdir -p $(DESTDIR)/usr/share/polkit-1/actions/
|
|
- install -m 644 org.selinux.policy $(DESTDIR)/usr/share/polkit-1/actions/
|
|
- -mkdir -p $(DESTDIR)/usr/share/system-config-selinux
|
|
- install -m 755 selinux_server.py $(DESTDIR)/usr/share/system-config-selinux
|
|
+ -mkdir -p $(DESTDIR)$(PREFIX)/share/dbus-1/system-services
|
|
+ install -m 644 org.selinux.service $(DESTDIR)$(PREFIX)/share/dbus-1/system-services
|
|
+ -mkdir -p $(DESTDIR)$(PREFIX)/share/polkit-1/actions/
|
|
+ install -m 644 org.selinux.policy $(DESTDIR)$(PREFIX)/share/polkit-1/actions/
|
|
+ -mkdir -p $(DESTDIR)$(PREFIX)/share/system-config-selinux
|
|
+ install -m 755 selinux_server.py $(DESTDIR)$(PREFIX)/share/system-config-selinux
|
|
|
|
relabel:
|
|
|
|
diff --git selinux-dbus-2.7/org.selinux.conf selinux-dbus-2.7/org.selinux.conf
|
|
index a350978..1ae079d 100644
|
|
--- selinux-dbus-2.7/org.selinux.conf
|
|
+++ selinux-dbus-2.7/org.selinux.conf
|
|
@@ -12,12 +12,8 @@
|
|
|
|
<!-- Allow anyone to invoke methods on the interfaces,
|
|
authorization is performed by PolicyKit -->
|
|
- <policy at_console="true">
|
|
- <allow send_destination="org.selinux"/>
|
|
- </policy>
|
|
<policy context="default">
|
|
- <allow send_destination="org.selinux"
|
|
- send_interface="org.freedesktop.DBus.Introspectable"/>
|
|
+ <allow send_destination="org.selinux"/>
|
|
</policy>
|
|
|
|
</busconfig>
|
|
diff --git selinux-dbus-2.7/org.selinux.policy selinux-dbus-2.7/org.selinux.policy
|
|
index 0126610..9772127 100644
|
|
--- selinux-dbus-2.7/org.selinux.policy
|
|
+++ selinux-dbus-2.7/org.selinux.policy
|
|
@@ -70,9 +70,9 @@
|
|
<allow_active>auth_admin_keep</allow_active>
|
|
</defaults>
|
|
</action>
|
|
- <action id="org.selinux.change_policy_type">
|
|
- <description>SELinux write access</description>
|
|
- <message>System policy prevents change_policy_type access to SELinux</message>
|
|
+ <action id="org.selinux.change_default_mode">
|
|
+ <description>Change SELinux default enforcing mode</description>
|
|
+ <message>System policy prevents change_default_policy access to SELinux</message>
|
|
<defaults>
|
|
<allow_any>no</allow_any>
|
|
<allow_inactive>no</allow_inactive>
|