187 lines
5.8 KiB
Diff
187 lines
5.8 KiB
Diff
diff --git selinux-sandbox-2.9-rc2/Makefile selinux-sandbox-2.9-rc2/Makefile
|
|
index 9da5e58..b817824 100644
|
|
--- selinux-sandbox-2.9-rc2/Makefile
|
|
+++ selinux-sandbox-2.9-rc2/Makefile
|
|
@@ -13,6 +13,7 @@ override LDLIBS += -lselinux -lcap-ng
|
|
SEUNSHARE_OBJS = seunshare.o
|
|
|
|
all: sandbox seunshare sandboxX.sh start
|
|
+ (cd po && $(MAKE) $@)
|
|
|
|
seunshare: $(SEUNSHARE_OBJS)
|
|
|
|
@@ -39,6 +40,7 @@ install: all
|
|
install -m 755 start $(DESTDIR)$(SHAREDIR)
|
|
-mkdir -p $(DESTDIR)$(SYSCONFDIR)
|
|
install -m 644 sandbox.conf $(DESTDIR)$(SYSCONFDIR)/sandbox
|
|
+ (cd po && $(MAKE) $@)
|
|
|
|
test:
|
|
@$(PYTHON) test_sandbox.py -v
|
|
diff --git selinux-sandbox-2.9-rc2/po/Makefile selinux-sandbox-2.9-rc2/po/Makefile
|
|
new file mode 100644
|
|
index 0000000..0556bbe
|
|
--- /dev/null
|
|
+++ selinux-sandbox-2.9-rc2/po/Makefile
|
|
@@ -0,0 +1,82 @@
|
|
+#
|
|
+# Makefile for the PO files (translation) catalog
|
|
+#
|
|
+
|
|
+PREFIX ?= /usr
|
|
+
|
|
+# What is this package?
|
|
+NLSPACKAGE = sandbox
|
|
+POTFILE = $(NLSPACKAGE).pot
|
|
+INSTALL = /usr/bin/install -c -p
|
|
+INSTALL_DATA = $(INSTALL) -m 644
|
|
+INSTALL_DIR = /usr/bin/install -d
|
|
+
|
|
+# destination directory
|
|
+INSTALL_NLS_DIR = $(PREFIX)/share/locale
|
|
+
|
|
+# PO catalog handling
|
|
+MSGMERGE = msgmerge
|
|
+MSGMERGE_FLAGS = -q
|
|
+XGETTEXT = xgettext -L Python --default-domain=$(NLSPACKAGE)
|
|
+MSGFMT = msgfmt
|
|
+
|
|
+# All possible linguas
|
|
+PO_LINGUAS := $(sort $(patsubst %.po,%,$(wildcard *.po)))
|
|
+
|
|
+# Only the files matching what the user has set in LINGUAS
|
|
+USER_LINGUAS := $(filter $(patsubst %,%%,$(LINGUAS)),$(PO_LINGUAS))
|
|
+
|
|
+# if no valid LINGUAS, build all languages
|
|
+USE_LINGUAS := $(if $(USER_LINGUAS),$(USER_LINGUAS),$(PO_LINGUAS))
|
|
+
|
|
+POFILES = $(patsubst %,%.po,$(USE_LINGUAS))
|
|
+MOFILES = $(patsubst %.po,%.mo,$(POFILES))
|
|
+POTFILES = $(shell cat POTFILES)
|
|
+
|
|
+#default:: clean
|
|
+
|
|
+all:: $(POTFILE) $(MOFILES)
|
|
+
|
|
+$(POTFILE): $(POTFILES)
|
|
+ $(XGETTEXT) --keyword=_ --keyword=N_ $(POTFILES)
|
|
+ @if cmp -s $(NLSPACKAGE).po $(POTFILE); then \
|
|
+ rm -f $(NLSPACKAGE).po; \
|
|
+ else \
|
|
+ mv -f $(NLSPACKAGE).po $(POTFILE); \
|
|
+ fi; \
|
|
+
|
|
+
|
|
+refresh-po: Makefile
|
|
+ for cat in $(POFILES); do \
|
|
+ lang=`basename $$cat .po`; \
|
|
+ if $(MSGMERGE) $(MSGMERGE_FLAGS) $$lang.po $(POTFILE) > $$lang.pot ; then \
|
|
+ mv -f $$lang.pot $$lang.po ; \
|
|
+ echo "$(MSGMERGE) of $$lang succeeded" ; \
|
|
+ else \
|
|
+ echo "$(MSGMERGE) of $$lang failed" ; \
|
|
+ rm -f $$lang.pot ; \
|
|
+ fi \
|
|
+ done
|
|
+
|
|
+clean:
|
|
+ @rm -fv *mo *~ .depend
|
|
+ @rm -rf tmp
|
|
+
|
|
+install: $(MOFILES)
|
|
+ @for n in $(MOFILES); do \
|
|
+ l=`basename $$n .mo`; \
|
|
+ $(INSTALL_DIR) $(DESTDIR)$(INSTALL_NLS_DIR)/$$l/LC_MESSAGES; \
|
|
+ $(INSTALL_DATA) --verbose $$n $(DESTDIR)$(INSTALL_NLS_DIR)/$$l/LC_MESSAGES/selinux-$(NLSPACKAGE).mo; \
|
|
+ done
|
|
+
|
|
+%.mo: %.po
|
|
+ $(MSGFMT) -o $@ $<
|
|
+report:
|
|
+ @for cat in $(wildcard *.po); do \
|
|
+ echo -n "$$cat: "; \
|
|
+ msgfmt -v --statistics -o /dev/null $$cat; \
|
|
+ done
|
|
+
|
|
+.PHONY: missing depend
|
|
+
|
|
+relabel:
|
|
diff --git selinux-sandbox-2.9-rc2/po/POTFILES selinux-sandbox-2.9-rc2/po/POTFILES
|
|
new file mode 100644
|
|
index 0000000..deff3f2
|
|
--- /dev/null
|
|
+++ selinux-sandbox-2.9-rc2/po/POTFILES
|
|
@@ -0,0 +1 @@
|
|
+../sandbox
|
|
diff --git selinux-sandbox-2.9-rc2/sandbox selinux-sandbox-2.9-rc2/sandbox
|
|
index 1dec07a..707959a 100644
|
|
--- selinux-sandbox-2.9-rc2/sandbox
|
|
+++ selinux-sandbox-2.9-rc2/sandbox
|
|
@@ -37,7 +37,7 @@ import sepolicy
|
|
|
|
SEUNSHARE = "/usr/sbin/seunshare"
|
|
SANDBOXSH = "/usr/share/sandbox/sandboxX.sh"
|
|
-PROGNAME = "policycoreutils"
|
|
+PROGNAME = "selinux-sandbox"
|
|
try:
|
|
import gettext
|
|
kwargs = {}
|
|
@@ -268,7 +268,7 @@ class Sandbox:
|
|
copyfile(f, "/tmp", self.__tmpdir)
|
|
copyfile(f, "/var/tmp", self.__tmpdir)
|
|
|
|
- def __setup_sandboxrc(self, wm="/usr/bin/openbox"):
|
|
+ def __setup_sandboxrc(self, wm="/usr/bin/matchbox-window-manager"):
|
|
execfile = self.__homedir + "/.sandboxrc"
|
|
fd = open(execfile, "w+")
|
|
if self.__options.session:
|
|
@@ -362,7 +362,7 @@ sandbox [-h] [-l level ] [-[X|M] [-H homedir] [-T tempdir]] [-I includefile ] [-
|
|
|
|
parser.add_option("-W", "--windowmanager", dest="wm",
|
|
type="string",
|
|
- default="/usr/bin/openbox",
|
|
+ default="/usr/bin/matchbox-window-manager",
|
|
help=_("alternate window manager"))
|
|
|
|
parser.add_option("-l", "--level", dest="level",
|
|
diff --git selinux-sandbox-2.9-rc2/sandbox.8 selinux-sandbox-2.9-rc2/sandbox.8
|
|
index d83fee7..90ef495 100644
|
|
--- selinux-sandbox-2.9-rc2/sandbox.8
|
|
+++ selinux-sandbox-2.9-rc2/sandbox.8
|
|
@@ -77,7 +77,7 @@ Specifies the windowsize when creating an X based Sandbox. The default windowsiz
|
|
\fB\-W\fR \fB\-\-windowmanager\fR
|
|
Select alternative window manager to run within
|
|
.B sandbox \-X.
|
|
-Default to /usr/bin/openbox.
|
|
+Default to /usr/bin/matchbox-window-manager.
|
|
.TP
|
|
\fB\-X\fR
|
|
Create an X based Sandbox for gui apps, temporary files for
|
|
diff --git selinux-sandbox-2.9-rc2/sandboxX.sh selinux-sandbox-2.9-rc2/sandboxX.sh
|
|
index eaa500d..c211ebc 100644
|
|
--- selinux-sandbox-2.9-rc2/sandboxX.sh
|
|
+++ selinux-sandbox-2.9-rc2/sandboxX.sh
|
|
@@ -6,21 +6,7 @@ export TITLE="Sandbox $context -- `grep ^#TITLE: ~/.sandboxrc | /usr/bin/cut -b8
|
|
[ -z $2 ] && export DPI="96" || export DPI="$2"
|
|
trap "exit 0" HUP
|
|
|
|
-mkdir -p ~/.config/openbox
|
|
-cat > ~/.config/openbox/rc.xml << EOF
|
|
-<openbox_config xmlns="http://openbox.org/3.4/rc"
|
|
- xmlns:xi="http://www.w3.org/2001/XInclude">
|
|
-<applications>
|
|
- <application class="*">
|
|
- <decor>no</decor>
|
|
- <desktop>all</desktop>
|
|
- <maximized>yes</maximized>
|
|
- </application>
|
|
-</applications>
|
|
-</openbox_config>
|
|
-EOF
|
|
-
|
|
-(/usr/bin/Xephyr -resizeable -title "$TITLE" -terminate -screen $SCREENSIZE -dpi $DPI -nolisten tcp -displayfd 5 5>&1 2>/dev/null) | while read D; do
|
|
+(/usr/bin/Xephyr -resizeable -title "$TITLE" -terminate -reset -screen $SCREENSIZE -dpi $DPI -nolisten tcp -displayfd 5 5>&1 2>/dev/null) | while read D; do
|
|
export DISPLAY=:$D
|
|
cat > ~/seremote << __EOF
|
|
#!/bin/sh
|