577b79db7e
- Rebase on upstream f56a72ac9e86 - sepolicy: fix sepolicy manpage -w - sandbox: add -R option to alternate XDG_RUNTIME_DIR - Remove dependency on the Python module distutils
82 lines
3.2 KiB
Diff
82 lines
3.2 KiB
Diff
From c08cf24f39989cfc610a481ae3dc380b61e9ca5f Mon Sep 17 00:00:00 2001
|
|
From: James Carter <jwcart2@gmail.com>
|
|
Date: Fri, 28 Oct 2022 16:16:22 -0400
|
|
Subject: [PATCH] python: Remove dependency on the Python module distutils
|
|
Content-type: text/plain
|
|
|
|
The distutils package is deprecated and scheduled to be removed in
|
|
Python 3.12. Use the setuptools and sysconfig modules instead.
|
|
|
|
Signed-off-by: James Carter <jwcart2@gmail.com>
|
|
Acked-by: Petr Lautrbach <plautrba@redhat.com>
|
|
---
|
|
python/semanage/Makefile | 2 +-
|
|
python/sepolgen/src/sepolgen/Makefile | 2 +-
|
|
python/sepolicy/sepolicy/gui.py | 4 ++--
|
|
python/sepolicy/setup.py | 2 +-
|
|
4 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/python/semanage/Makefile b/python/semanage/Makefile
|
|
index 024e9640fed0..b53ee33db6ac 100644
|
|
--- a/python/semanage/Makefile
|
|
+++ b/python/semanage/Makefile
|
|
@@ -5,7 +5,7 @@ LINGUAS ?= ru
|
|
PREFIX ?= /usr
|
|
SBINDIR ?= $(PREFIX)/sbin
|
|
MANDIR = $(PREFIX)/share/man
|
|
-PYTHONLIBDIR ?= $(shell $(PYTHON) -c "from distutils.sysconfig import *; print(get_python_lib(prefix='$(PREFIX)'))")
|
|
+PYTHONLIBDIR ?= $(shell $(PYTHON) -c "import sysconfig; print(sysconfig.get_path('purelib', vars={'platbase': '$(PREFIX)', 'base': '$(PREFIX)'}))")
|
|
PACKAGEDIR ?= $(PYTHONLIBDIR)
|
|
BASHCOMPLETIONDIR ?= $(PREFIX)/share/bash-completion/completions
|
|
|
|
diff --git a/python/sepolgen/src/sepolgen/Makefile b/python/sepolgen/src/sepolgen/Makefile
|
|
index cac8def7204e..a10392273181 100644
|
|
--- a/python/sepolgen/src/sepolgen/Makefile
|
|
+++ b/python/sepolgen/src/sepolgen/Makefile
|
|
@@ -1,6 +1,6 @@
|
|
PREFIX ?= /usr
|
|
PYTHON ?= python3
|
|
-PYTHONLIBDIR ?= $(shell $(PYTHON) -c "from distutils.sysconfig import *; print(get_python_lib(prefix='$(PREFIX)'))")
|
|
+PYTHONLIBDIR ?= $(shell $(PYTHON) -c "import sysconfig; print(sysconfig.get_path('purelib', vars={'platbase': '$(PREFIX)', 'base': '$(PREFIX)'}))")
|
|
PACKAGEDIR ?= /$(PYTHONLIBDIR)/sepolgen
|
|
|
|
all:
|
|
diff --git a/python/sepolicy/sepolicy/gui.py b/python/sepolicy/sepolicy/gui.py
|
|
index 5bdbfebade1d..335be582b668 100644
|
|
--- a/python/sepolicy/sepolicy/gui.py
|
|
+++ b/python/sepolicy/sepolicy/gui.py
|
|
@@ -77,7 +77,7 @@ def cmp(a, b):
|
|
return 1
|
|
return (a > b) - (a < b)
|
|
|
|
-import distutils.sysconfig
|
|
+import sysconfig
|
|
ADVANCED_LABEL = (_("Advanced >>"), _("Advanced <<"))
|
|
ADVANCED_SEARCH_LABEL = (_("Advanced Search >>"), _("Advanced Search <<"))
|
|
OUTBOUND_PAGE = 0
|
|
@@ -130,7 +130,7 @@ class SELinuxGui():
|
|
self.application = app
|
|
self.filter_txt = ""
|
|
builder = Gtk.Builder() # BUILDER OBJ
|
|
- self.code_path = distutils.sysconfig.get_python_lib(plat_specific=False) + "/sepolicy/"
|
|
+ self.code_path = sysconfig.get_python_lib(plat_specific=False) + "/sepolicy/"
|
|
glade_file = self.code_path + "sepolicy.glade"
|
|
builder.add_from_file(glade_file)
|
|
self.outer_notebook = builder.get_object("outer_notebook")
|
|
diff --git a/python/sepolicy/setup.py b/python/sepolicy/setup.py
|
|
index b0f9650df875..c82206647f9b 100644
|
|
--- a/python/sepolicy/setup.py
|
|
+++ b/python/sepolicy/setup.py
|
|
@@ -2,7 +2,7 @@
|
|
|
|
# Author: Thomas Liu <tliu@redhat.com>
|
|
# Author: Dan Walsh <dwalsh@redhat.com>
|
|
-from distutils.core import setup
|
|
+from setuptools import setup
|
|
|
|
setup(
|
|
name="sepolicy",
|
|
--
|
|
2.38.1
|
|
|