577b79db7e
- Rebase on upstream f56a72ac9e86 - sepolicy: fix sepolicy manpage -w - sandbox: add -R option to alternate XDG_RUNTIME_DIR - Remove dependency on the Python module distutils
57 lines
2.2 KiB
Diff
57 lines
2.2 KiB
Diff
From c2d58b378b3cf350d042a7b657e2b7f5861c5f26 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Christian=20G=C3=B6ttsche?= <cgzones@googlemail.com>
|
|
Date: Mon, 8 Aug 2022 19:36:55 +0200
|
|
Subject: [PATCH] Ignore egg-info directories and clean them
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
Content-type: text/plain
|
|
|
|
Test .gitignore and make clean distclean
|
|
error: missing .gitignore entry for libselinux/src/selinux.egg-info/
|
|
error: missing .gitignore entry for python/sepolicy/sepolicy.egg-info/
|
|
Error: Process completed with exit code 1.
|
|
|
|
error: "make clean distclean" did not remove libselinux/src/selinux.egg-info/PKG-INFO
|
|
error: "make clean distclean" did not remove libselinux/src/selinux.egg-info/SOURCES.txt
|
|
error: "make clean distclean" did not remove libselinux/src/selinux.egg-info/dependency_links.txt
|
|
error: "make clean distclean" did not remove libselinux/src/selinux.egg-info/top_level.txt
|
|
error: "make clean distclean" did not remove python/sepolicy/sepolicy.egg-info/PKG-INFO
|
|
error: "make clean distclean" did not remove python/sepolicy/sepolicy.egg-info/SOURCES.txt
|
|
error: "make clean distclean" did not remove python/sepolicy/sepolicy.egg-info/dependency_links.txt
|
|
error: "make clean distclean" did not remove python/sepolicy/sepolicy.egg-info/top_level.txt
|
|
Error: Process completed with exit code 1.
|
|
|
|
Signed-off-by: Christian Göttsche <cgzones@googlemail.com>
|
|
Acked-by: James Carter <jwcart2@gmail.com>
|
|
---
|
|
python/sepolicy/.gitignore | 1 +
|
|
python/sepolicy/Makefile | 2 +-
|
|
2 files changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/python/sepolicy/.gitignore b/python/sepolicy/.gitignore
|
|
index 3186c860ec0d..32fb47f92a9d 100644
|
|
--- a/python/sepolicy/.gitignore
|
|
+++ b/python/sepolicy/.gitignore
|
|
@@ -1,3 +1,4 @@
|
|
build
|
|
tmp
|
|
*.bak
|
|
+sepolicy.egg-info/
|
|
diff --git a/python/sepolicy/Makefile b/python/sepolicy/Makefile
|
|
index 3361be4ef0bc..d983e409e5e6 100644
|
|
--- a/python/sepolicy/Makefile
|
|
+++ b/python/sepolicy/Makefile
|
|
@@ -18,7 +18,7 @@ python-build:
|
|
|
|
clean:
|
|
$(PYTHON) setup.py clean
|
|
- -rm -rf build *~ \#* *pyc .#*
|
|
+ -rm -rf build *~ \#* *pyc .#* sepolicy.egg-info/
|
|
|
|
sepolgen:
|
|
ln -sf sepolicy sepolgen
|
|
--
|
|
2.38.1
|
|
|