4bf679be9e
- Update semodule man page
351 lines
14 KiB
Diff
351 lines
14 KiB
Diff
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.23/Makefile
|
|
--- nsapolicycoreutils/Makefile 2007-07-16 14:20:43.000000000 -0400
|
|
+++ policycoreutils-2.0.23/Makefile 2007-08-22 16:29:22.000000000 -0400
|
|
@@ -1,4 +1,4 @@
|
|
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
|
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
|
|
|
all install relabel clean indent:
|
|
@for subdir in $(SUBDIRS); do \
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.23/restorecond/restorecond.c
|
|
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
|
+++ policycoreutils-2.0.23/restorecond/restorecond.c 2007-08-22 16:29:22.000000000 -0400
|
|
@@ -210,9 +210,10 @@
|
|
}
|
|
|
|
if (fsetfilecon(fd, scontext) < 0) {
|
|
- syslog(LOG_ERR,
|
|
- "set context %s->%s failed:'%s'\n",
|
|
- filename, scontext, strerror(errno));
|
|
+ if (errno != EOPNOTSUPP)
|
|
+ syslog(LOG_ERR,
|
|
+ "set context %s->%s failed:'%s'\n",
|
|
+ filename, scontext, strerror(errno));
|
|
if (retcontext >= 0)
|
|
free(prev_context);
|
|
free(scontext);
|
|
@@ -225,8 +226,9 @@
|
|
if (retcontext >= 0)
|
|
free(prev_context);
|
|
} else {
|
|
- syslog(LOG_ERR, "get context on %s failed: '%s'\n",
|
|
- filename, strerror(errno));
|
|
+ if (errno != EOPNOTSUPP)
|
|
+ syslog(LOG_ERR, "get context on %s failed: '%s'\n",
|
|
+ filename, strerror(errno));
|
|
}
|
|
free(scontext);
|
|
close(fd);
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/run_init/Makefile policycoreutils-2.0.23/run_init/Makefile
|
|
--- nsapolicycoreutils/run_init/Makefile 2007-07-16 14:20:41.000000000 -0400
|
|
+++ policycoreutils-2.0.23/run_init/Makefile 2007-08-22 16:29:22.000000000 -0400
|
|
@@ -34,8 +34,8 @@
|
|
install: all
|
|
test -d $(SBINDIR) || install -m 755 -d $(SBINDIR)
|
|
test -d $(MANDIR)/man1 || install -m 755 -d $(MANDIR)/man1
|
|
- install -m 555 run_init $(SBINDIR)
|
|
- install -m 555 open_init_pty $(SBINDIR)
|
|
+ install -m 755 run_init $(SBINDIR)
|
|
+ install -m 755 open_init_pty $(SBINDIR)
|
|
install -m 644 run_init.8 $(MANDIR)/man8/
|
|
install -m 644 open_init_pty.8 $(MANDIR)/man8/
|
|
ifeq (${PAMH}, /usr/include/security/pam_appl.h)
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.23/scripts/chcat
|
|
--- nsapolicycoreutils/scripts/chcat 2007-07-16 14:20:41.000000000 -0400
|
|
+++ policycoreutils-2.0.23/scripts/chcat 2007-08-22 16:29:22.000000000 -0400
|
|
@@ -77,7 +77,7 @@
|
|
|
|
if len(cats) > 0:
|
|
new_serange = "%s-%s:%s" % (serange[0], top[0], ",".join(cats))
|
|
- else
|
|
+ else:
|
|
new_serange = "%s-%s" % (serange[0], top[0])
|
|
|
|
if add_ind:
|
|
@@ -155,7 +155,7 @@
|
|
|
|
if len(cats) > 0:
|
|
new_serange = "%s-%s:%s" % (serange[0], top[0], ",".join(cats))
|
|
- else
|
|
+ else:
|
|
new_serange = "%s-%s" % (serange[0], top[0])
|
|
|
|
if add_ind:
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-2.0.23/scripts/fixfiles
|
|
--- nsapolicycoreutils/scripts/fixfiles 2007-07-16 14:20:41.000000000 -0400
|
|
+++ policycoreutils-2.0.23/scripts/fixfiles 2007-08-22 16:29:22.000000000 -0400
|
|
@@ -88,7 +88,7 @@
|
|
esac; \
|
|
fi; \
|
|
done | \
|
|
- while read pattern ; do find $pattern \
|
|
+ while read pattern ; do sh -c "find $pattern" \
|
|
! \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o \
|
|
\( -wholename /home -o -wholename /root -o -wholename /tmp -wholename /dev \) -prune -o -print; \
|
|
done 2> /dev/null | \
|
|
@@ -108,6 +108,7 @@
|
|
|
|
rpmlist() {
|
|
rpm -q --qf '[%{FILESTATES} %{FILENAMES}\n]' "$1" | grep '^0 ' | cut -f2- -d ' '
|
|
+[ ${PIPESTATUS[0]} != 0 ] && echo "$1 not found" >/dev/stderr
|
|
}
|
|
|
|
#
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/genhomedircon policycoreutils-2.0.23/scripts/genhomedircon
|
|
--- nsapolicycoreutils/scripts/genhomedircon 2007-07-16 14:20:41.000000000 -0400
|
|
+++ policycoreutils-2.0.23/scripts/genhomedircon 2007-08-23 10:08:04.000000000 -0400
|
|
@@ -139,7 +139,22 @@
|
|
self.default_user = "user_u"
|
|
self.default_prefix = "user"
|
|
self.users = self.getUsers()
|
|
+ fd = open(self.getFileContextFile())
|
|
+ self.fclines=[]
|
|
+ for i in fd.readlines():
|
|
+ try:
|
|
+ regex = i.split()[0]
|
|
+ #match a trailing .+
|
|
+ regex = re.sub("\.+$", "", regex)
|
|
+ regex = re.sub("\.\*$", "", regex)
|
|
+ regex = re.sub("\(\/\.\*\)\?", "", regex)
|
|
+ regex = regex + "/*$"
|
|
+ self.fclines.append(re.compile(regex))
|
|
+ except:
|
|
+ continue
|
|
|
|
+ fd.close()
|
|
+
|
|
def getFileContextDir(self):
|
|
return self.selinuxdir+self.type+self.filecontextdir
|
|
|
|
@@ -272,7 +287,7 @@
|
|
ret = ""
|
|
fd = open(self.getHomeDirTemplate(), 'r')
|
|
for i in fd.readlines():
|
|
- if i.find("USER") == 1:
|
|
+ if i.find("USER") > 0:
|
|
i = i.replace("USER", user)
|
|
i = i.replace("ROLE", prefix)
|
|
i = i.replace("system_u", sel_user)
|
|
@@ -289,20 +304,9 @@
|
|
return ret+"\n"
|
|
|
|
def checkExists(self, home):
|
|
- fd = open(self.getFileContextFile())
|
|
- for i in fd.readlines():
|
|
- if len(i) == 0:
|
|
- continue
|
|
+ for i in self.fclines:
|
|
try:
|
|
- regex = i.split()[0]
|
|
- #match a trailing .+
|
|
- regex = re.sub("\.+$", "", regex)
|
|
- regex = re.sub("\.\*$", "", regex)
|
|
- #strip a (/.*)? which matches anything trailing to a /*$ which matches trailing /'s
|
|
-
|
|
- regex = re.sub("\(\/\.\*\)\?", "", regex)
|
|
- regex = regex + "/*$"
|
|
- if re.search(regex,home, 0):
|
|
+ if i.match(home):
|
|
return 1
|
|
except:
|
|
continue
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.23/semanage/semanage
|
|
--- nsapolicycoreutils/semanage/semanage 2007-07-16 14:20:41.000000000 -0400
|
|
+++ policycoreutils-2.0.23/semanage/semanage 2007-08-22 16:29:22.000000000 -0400
|
|
@@ -34,7 +34,10 @@
|
|
sys.stdout = codecs.getwriter(locale.getpreferredencoding())(sys.__stdout__, 'replace')
|
|
|
|
try:
|
|
- gettext.install(PROGNAME, localedir="/usr/share/locale", unicode=1)
|
|
+ gettext.install(PROGNAME,
|
|
+ localedir="/usr/share/locale",
|
|
+ unicode=False,
|
|
+ codeset = 'utf-8')
|
|
except IOError:
|
|
import __builtin__
|
|
__builtin__.__dict__['_'] = unicode
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.23/semanage/seobject.py
|
|
--- nsapolicycoreutils/semanage/seobject.py 2007-07-16 14:20:41.000000000 -0400
|
|
+++ policycoreutils-2.0.23/semanage/seobject.py 2007-08-22 16:29:22.000000000 -0400
|
|
@@ -210,6 +210,7 @@
|
|
os.write(fd, self.out())
|
|
os.close(fd)
|
|
os.rename(newfilename, self.filename)
|
|
+ os.system("/sbin/service mcstrans reload > /dev/null")
|
|
|
|
class semanageRecords:
|
|
def __init__(self):
|
|
@@ -1024,14 +1025,31 @@
|
|
def __init__(self):
|
|
semanageRecords.__init__(self)
|
|
|
|
- def add(self, target, type, ftype = "", serange = "", seuser = "system_u"):
|
|
+ def createcon(self, target, seuser = "system_u"):
|
|
+ (rc, con) = semanage_context_create(self.sh)
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not create context for %s") % target)
|
|
if seuser == "":
|
|
seuser = "system_u"
|
|
+
|
|
+ rc = semanage_context_set_user(self.sh, con, seuser)
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not set user in file context for %s") % target)
|
|
+
|
|
+ rc = semanage_context_set_role(self.sh, con, "object_r")
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not set role in file context for %s") % target)
|
|
+
|
|
if is_mls_enabled == 1:
|
|
- if serange == "":
|
|
- serange = "s0"
|
|
- else:
|
|
- serange = untranslate(serange)
|
|
+ rc = semanage_context_set_mls(self.sh, con, "s0")
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not set mls fields in file context for %s") % target)
|
|
+
|
|
+ return con
|
|
+
|
|
+ def add(self, target, type, ftype = "", serange = "", seuser = "system_u"):
|
|
+ if is_mls_enabled == 1:
|
|
+ serange = untranslate(serange)
|
|
|
|
if type == "":
|
|
raise ValueError(_("SELinux Type is required"))
|
|
@@ -1051,33 +1069,23 @@
|
|
raise ValueError(_("Could not create file context for %s") % target)
|
|
|
|
rc = semanage_fcontext_set_expr(self.sh, fcontext, target)
|
|
- (rc, con) = semanage_context_create(self.sh)
|
|
- if rc < 0:
|
|
- raise ValueError(_("Could not create context for %s") % target)
|
|
-
|
|
- rc = semanage_context_set_user(self.sh, con, seuser)
|
|
- if rc < 0:
|
|
- raise ValueError(_("Could not set user in file context for %s") % target)
|
|
-
|
|
- rc = semanage_context_set_role(self.sh, con, "object_r")
|
|
- if rc < 0:
|
|
- raise ValueError(_("Could not set role in file context for %s") % target)
|
|
-
|
|
- rc = semanage_context_set_type(self.sh, con, type)
|
|
- if rc < 0:
|
|
- raise ValueError(_("Could not set type in file context for %s") % target)
|
|
+ if type != "<<none>>":
|
|
+ con = self.createcon(target, seuser)
|
|
|
|
- if serange != "":
|
|
- rc = semanage_context_set_mls(self.sh, con, serange)
|
|
- if rc < 0:
|
|
- raise ValueError(_("Could not set mls fields in file context for %s") % target)
|
|
+ rc = semanage_context_set_type(self.sh, con, type)
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not set type in file context for %s") % target)
|
|
+
|
|
+ if serange != "":
|
|
+ rc = semanage_context_set_mls(self.sh, con, serange)
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not set mls fields in file context for %s") % target)
|
|
+ rc = semanage_fcontext_set_con(self.sh, fcontext, con)
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not set file context for %s") % target)
|
|
|
|
semanage_fcontext_set_type(fcontext, file_types[ftype])
|
|
|
|
- rc = semanage_fcontext_set_con(self.sh, fcontext, con)
|
|
- if rc < 0:
|
|
- raise ValueError(_("Could not set file context for %s") % target)
|
|
-
|
|
rc = semanage_begin_transaction(self.sh)
|
|
if rc < 0:
|
|
raise ValueError(_("Could not start semanage transaction"))
|
|
@@ -1090,7 +1098,8 @@
|
|
if rc < 0:
|
|
raise ValueError(_("Could not add file context for %s") % target)
|
|
|
|
- semanage_context_free(con)
|
|
+ if type != "<<none>>":
|
|
+ semanage_context_free(con)
|
|
semanage_fcontext_key_free(k)
|
|
semanage_fcontext_free(fcontext)
|
|
|
|
@@ -1112,16 +1121,29 @@
|
|
if rc < 0:
|
|
raise ValueError(_("Could not query file context for %s") % target)
|
|
|
|
- con = semanage_fcontext_get_con(fcontext)
|
|
+ if setype != "<<none>>":
|
|
+ con = semanage_fcontext_get_con(fcontext)
|
|
|
|
- if serange != "":
|
|
- semanage_context_set_mls(self.sh, con, untranslate(serange))
|
|
- if seuser != "":
|
|
- semanage_context_set_user(self.sh, con, seuser)
|
|
- if setype != "":
|
|
- semanage_context_set_type(self.sh, con, setype)
|
|
-
|
|
- rc = semanage_begin_transaction(self.sh)
|
|
+ if con == None:
|
|
+ con = self.createcon(target)
|
|
+
|
|
+ if serange != "":
|
|
+ semanage_context_set_mls(self.sh, con, untranslate(serange))
|
|
+ if seuser != "":
|
|
+ semanage_context_set_user(self.sh, con, seuser)
|
|
+
|
|
+ if setype != "":
|
|
+ semanage_context_set_type(self.sh, con, setype)
|
|
+
|
|
+ rc = semanage_fcontext_set_con(self.sh, fcontext, con)
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not set file context for %s") % target)
|
|
+ else:
|
|
+ rc = semanage_fcontext_set_con(self.sh, fcontext, None)
|
|
+ if rc < 0:
|
|
+ raise ValueError(_("Could not set file context for %s") % target)
|
|
+
|
|
+ rc = semanage_begin_transaction(self.sh)
|
|
if rc < 0:
|
|
raise ValueError(_("Could not start semanage transaction"))
|
|
|
|
@@ -1283,9 +1305,12 @@
|
|
raise ValueError(_("Could not list booleans"))
|
|
|
|
for boolean in self.blist:
|
|
- name = semanage_bool_get_name(boolean)
|
|
- value = semanage_bool_get_value(boolean)
|
|
- ddict[name] = value
|
|
+ value = []
|
|
+ name = semanage_bool_get_name(boolean)
|
|
+ value[0] = semanage_bool_get_value(boolean)
|
|
+ value[1] = selinux.security_get_boolean_pending(boolean)
|
|
+ value[2] = selinux.security_get_boolean_active(boolean)
|
|
+ ddict[name] = value
|
|
|
|
return ddict
|
|
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semodule/semodule.8 policycoreutils-2.0.23/semodule/semodule.8
|
|
--- nsapolicycoreutils/semodule/semodule.8 2007-07-16 14:20:42.000000000 -0400
|
|
+++ policycoreutils-2.0.23/semodule/semodule.8 2007-08-23 10:18:35.000000000 -0400
|
|
@@ -23,6 +23,9 @@
|
|
.B \-B, \-\-build
|
|
force a rebuild of policy (also reloads unless -n is used)
|
|
.TP
|
|
+.B \-D, \-\-disable_dontaudit
|
|
+Temporarily remove dontaudits from policy. Reverts whenever policy is rebuilt
|
|
+.TP
|
|
.B \-i,\-\-install=MODULE_PKG
|
|
install/replace a module package
|
|
.TP
|
|
@@ -58,6 +61,10 @@
|
|
$ semodule -i httpd.pp
|
|
# List non-base modules.
|
|
$ semodule -l
|
|
+# Turn on all AVC Messages for which SELinux currently is "dontaudit"ing.
|
|
+$ semodule -DB
|
|
+# Turn "dontaudit" rules back on.
|
|
+$ semodule -B
|
|
# Install or replace all non-base modules in the current directory.
|
|
$ semodule -i *.pp
|
|
# Install or replace all modules in the current directory.
|