142 lines
4.0 KiB
Diff
142 lines
4.0 KiB
Diff
diff --git selinux-sandbox-2.8/Makefile selinux-sandbox-2.8/Makefile
|
|
index 49c1d3f..9e45329 100644
|
|
--- selinux-sandbox-2.8/Makefile
|
|
+++ selinux-sandbox-2.8/Makefile
|
|
@@ -12,6 +12,7 @@ override LDLIBS += -lselinux -lcap-ng
|
|
SEUNSHARE_OBJS = seunshare.o
|
|
|
|
all: sandbox seunshare sandboxX.sh start
|
|
+ (cd po && $(MAKE) $@)
|
|
|
|
seunshare: $(SEUNSHARE_OBJS)
|
|
|
|
@@ -30,6 +31,7 @@ install: all
|
|
install -m 755 start $(DESTDIR)$(SHAREDIR)
|
|
-mkdir -p $(DESTDIR)$(SYSCONFDIR)
|
|
install -m 644 sandbox.conf $(DESTDIR)$(SYSCONFDIR)/sandbox
|
|
+ (cd po && $(MAKE) $@)
|
|
|
|
test:
|
|
@$(PYTHON) test_sandbox.py -v
|
|
diff --git selinux-sandbox-2.8/po/Makefile selinux-sandbox-2.8/po/Makefile
|
|
new file mode 100644
|
|
index 0000000..0556bbe
|
|
--- /dev/null
|
|
+++ selinux-sandbox-2.8/po/Makefile
|
|
@@ -0,0 +1,82 @@
|
|
+#
|
|
+# Makefile for the PO files (translation) catalog
|
|
+#
|
|
+
|
|
+PREFIX ?= /usr
|
|
+
|
|
+# What is this package?
|
|
+NLSPACKAGE = sandbox
|
|
+POTFILE = $(NLSPACKAGE).pot
|
|
+INSTALL = /usr/bin/install -c -p
|
|
+INSTALL_DATA = $(INSTALL) -m 644
|
|
+INSTALL_DIR = /usr/bin/install -d
|
|
+
|
|
+# destination directory
|
|
+INSTALL_NLS_DIR = $(PREFIX)/share/locale
|
|
+
|
|
+# PO catalog handling
|
|
+MSGMERGE = msgmerge
|
|
+MSGMERGE_FLAGS = -q
|
|
+XGETTEXT = xgettext -L Python --default-domain=$(NLSPACKAGE)
|
|
+MSGFMT = msgfmt
|
|
+
|
|
+# All possible linguas
|
|
+PO_LINGUAS := $(sort $(patsubst %.po,%,$(wildcard *.po)))
|
|
+
|
|
+# Only the files matching what the user has set in LINGUAS
|
|
+USER_LINGUAS := $(filter $(patsubst %,%%,$(LINGUAS)),$(PO_LINGUAS))
|
|
+
|
|
+# if no valid LINGUAS, build all languages
|
|
+USE_LINGUAS := $(if $(USER_LINGUAS),$(USER_LINGUAS),$(PO_LINGUAS))
|
|
+
|
|
+POFILES = $(patsubst %,%.po,$(USE_LINGUAS))
|
|
+MOFILES = $(patsubst %.po,%.mo,$(POFILES))
|
|
+POTFILES = $(shell cat POTFILES)
|
|
+
|
|
+#default:: clean
|
|
+
|
|
+all:: $(POTFILE) $(MOFILES)
|
|
+
|
|
+$(POTFILE): $(POTFILES)
|
|
+ $(XGETTEXT) --keyword=_ --keyword=N_ $(POTFILES)
|
|
+ @if cmp -s $(NLSPACKAGE).po $(POTFILE); then \
|
|
+ rm -f $(NLSPACKAGE).po; \
|
|
+ else \
|
|
+ mv -f $(NLSPACKAGE).po $(POTFILE); \
|
|
+ fi; \
|
|
+
|
|
+
|
|
+refresh-po: Makefile
|
|
+ for cat in $(POFILES); do \
|
|
+ lang=`basename $$cat .po`; \
|
|
+ if $(MSGMERGE) $(MSGMERGE_FLAGS) $$lang.po $(POTFILE) > $$lang.pot ; then \
|
|
+ mv -f $$lang.pot $$lang.po ; \
|
|
+ echo "$(MSGMERGE) of $$lang succeeded" ; \
|
|
+ else \
|
|
+ echo "$(MSGMERGE) of $$lang failed" ; \
|
|
+ rm -f $$lang.pot ; \
|
|
+ fi \
|
|
+ done
|
|
+
|
|
+clean:
|
|
+ @rm -fv *mo *~ .depend
|
|
+ @rm -rf tmp
|
|
+
|
|
+install: $(MOFILES)
|
|
+ @for n in $(MOFILES); do \
|
|
+ l=`basename $$n .mo`; \
|
|
+ $(INSTALL_DIR) $(DESTDIR)$(INSTALL_NLS_DIR)/$$l/LC_MESSAGES; \
|
|
+ $(INSTALL_DATA) --verbose $$n $(DESTDIR)$(INSTALL_NLS_DIR)/$$l/LC_MESSAGES/selinux-$(NLSPACKAGE).mo; \
|
|
+ done
|
|
+
|
|
+%.mo: %.po
|
|
+ $(MSGFMT) -o $@ $<
|
|
+report:
|
|
+ @for cat in $(wildcard *.po); do \
|
|
+ echo -n "$$cat: "; \
|
|
+ msgfmt -v --statistics -o /dev/null $$cat; \
|
|
+ done
|
|
+
|
|
+.PHONY: missing depend
|
|
+
|
|
+relabel:
|
|
diff --git selinux-sandbox-2.8/po/POTFILES selinux-sandbox-2.8/po/POTFILES
|
|
new file mode 100644
|
|
index 0000000..deff3f2
|
|
--- /dev/null
|
|
+++ selinux-sandbox-2.8/po/POTFILES
|
|
@@ -0,0 +1 @@
|
|
+../sandbox
|
|
diff --git selinux-sandbox-2.8/sandbox selinux-sandbox-2.8/sandbox
|
|
index c07a1d8..a051360 100644
|
|
--- selinux-sandbox-2.8/sandbox
|
|
+++ selinux-sandbox-2.8/sandbox
|
|
@@ -37,7 +37,7 @@ import sepolicy
|
|
|
|
SEUNSHARE = "/usr/sbin/seunshare"
|
|
SANDBOXSH = "/usr/share/sandbox/sandboxX.sh"
|
|
-PROGNAME = "policycoreutils"
|
|
+PROGNAME = "selinux-sandbox"
|
|
try:
|
|
import gettext
|
|
kwargs = {}
|
|
diff --git selinux-sandbox-2.8/sandboxX.sh selinux-sandbox-2.8/sandboxX.sh
|
|
index eaa500d..4774528 100644
|
|
--- selinux-sandbox-2.8/sandboxX.sh
|
|
+++ selinux-sandbox-2.8/sandboxX.sh
|
|
@@ -20,7 +20,7 @@ cat > ~/.config/openbox/rc.xml << EOF
|
|
</openbox_config>
|
|
EOF
|
|
|
|
-(/usr/bin/Xephyr -resizeable -title "$TITLE" -terminate -screen $SCREENSIZE -dpi $DPI -nolisten tcp -displayfd 5 5>&1 2>/dev/null) | while read D; do
|
|
+(/usr/bin/Xephyr -resizeable -title "$TITLE" -terminate -reset -screen $SCREENSIZE -dpi $DPI -nolisten tcp -displayfd 5 5>&1 2>/dev/null) | while read D; do
|
|
export DISPLAY=:$D
|
|
cat > ~/seremote << __EOF
|
|
#!/bin/sh
|