20b4a0e287
- Fix system-config-selinux booleanspage throwing and exception - Update po files
31 lines
1.7 KiB
Diff
31 lines
1.7 KiB
Diff
diff --exclude-from=exclude --exclude=sepolgen-1.0.13 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.57/Makefile
|
|
--- nsapolicycoreutils/Makefile 2008-08-28 09:34:24.000000000 -0400
|
|
+++ policycoreutils-2.0.57/Makefile 2008-10-10 16:04:46.000000000 -0400
|
|
@@ -1,4 +1,4 @@
|
|
-SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
|
+SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
|
|
|
INOTIFYH = $(shell ls /usr/include/sys/inotify.h 2>/dev/null)
|
|
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.13 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/newrole/newrole.c policycoreutils-2.0.57/newrole/newrole.c
|
|
--- nsapolicycoreutils/newrole/newrole.c 2008-08-28 09:34:24.000000000 -0400
|
|
+++ policycoreutils-2.0.57/newrole/newrole.c 2008-10-17 16:43:52.000000000 -0400
|
|
@@ -553,7 +553,7 @@
|
|
new_caps = cap_init();
|
|
tmp_caps = cap_init();
|
|
if (!new_caps || !tmp_caps) {
|
|
- fprintf(stderr, _("Error initing capabilities, aborting.\n"));
|
|
+ fprintf(stderr, _("Error initializing capabilities, aborting.\n"));
|
|
return -1;
|
|
}
|
|
rc |= cap_set_flag(new_caps, CAP_PERMITTED, 1, cap_list, CAP_SET);
|
|
@@ -631,7 +631,7 @@
|
|
/* Non-root caller, suid root path */
|
|
new_caps = cap_init();
|
|
if (!new_caps) {
|
|
- fprintf(stderr, _("Error initing capabilities, aborting.\n"));
|
|
+ fprintf(stderr, _("Error initializing capabilities, aborting.\n"));
|
|
return -1;
|
|
}
|
|
rc |= cap_set_flag(new_caps, CAP_PERMITTED, 6, cap_list, CAP_SET);
|