127ce1fef4
- Update to upstream * fcontext add checked local records twice, fix from Dan Walsh.
117 lines
4.1 KiB
Diff
117 lines
4.1 KiB
Diff
diff --exclude-from=exclude --exclude=sepolgen-1.0.13 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.58/Makefile
|
|
--- nsapolicycoreutils/Makefile 2008-08-28 09:34:24.000000000 -0400
|
|
+++ policycoreutils-2.0.58/Makefile 2008-11-10 08:57:34.000000000 -0500
|
|
@@ -1,4 +1,4 @@
|
|
-SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
|
+SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
|
|
|
INOTIFYH = $(shell ls /usr/include/sys/inotify.h 2>/dev/null)
|
|
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.13 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.58/scripts/chcat
|
|
--- nsapolicycoreutils/scripts/chcat 2008-08-28 09:34:24.000000000 -0400
|
|
+++ policycoreutils-2.0.58/scripts/chcat 2008-11-10 08:57:34.000000000 -0500
|
|
@@ -291,6 +291,8 @@
|
|
for i in c.split(","):
|
|
if i not in newcats:
|
|
newcats.append(i)
|
|
+ if len(newcats) > 25:
|
|
+ return cats
|
|
return newcats
|
|
|
|
def translate(cats):
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.13 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.58/semanage/seobject.py
|
|
--- nsapolicycoreutils/semanage/seobject.py 2008-11-11 16:13:18.000000000 -0500
|
|
+++ policycoreutils-2.0.58/semanage/seobject.py 2008-11-10 08:59:16.000000000 -0500
|
|
@@ -35,7 +35,7 @@
|
|
import __builtin__
|
|
__builtin__.__dict__['_'] = unicode
|
|
|
|
-is_mls_enabled = selinux.is_selinux_mls_enabled()
|
|
+is_mls_enabled = not selinux.is_selinux_enabled() or selinux.is_selinux_mls_enabled()
|
|
|
|
import syslog
|
|
|
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.13 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semodule/semodule.c policycoreutils-2.0.58/semodule/semodule.c
|
|
--- nsapolicycoreutils/semodule/semodule.c 2008-08-28 09:34:24.000000000 -0400
|
|
+++ policycoreutils-2.0.58/semodule/semodule.c 2008-11-10 08:57:34.000000000 -0500
|
|
@@ -60,24 +60,6 @@
|
|
free(commands);
|
|
}
|
|
|
|
-/* mmap() a file to '*data', returning the total number of bytes in
|
|
- * the file. Returns 0 if file could not be opened or mapped. */
|
|
-static size_t map_file(char *filename, char **data)
|
|
-{
|
|
- int fd;
|
|
- struct stat sb;
|
|
- if ((fd = open(filename, O_RDONLY)) == -1) {
|
|
- return 0;
|
|
- }
|
|
- if (fstat(fd, &sb) == -1 ||
|
|
- (*data = mmap(NULL, sb.st_size, PROT_READ, MAP_PRIVATE, fd, 0)) ==
|
|
- MAP_FAILED) {
|
|
- sb.st_size = 0;
|
|
- }
|
|
- close(fd);
|
|
- return sb.st_size;
|
|
-}
|
|
-
|
|
/* Signal handlers. */
|
|
static void handle_signal(int sig_num)
|
|
{
|
|
@@ -339,16 +321,6 @@
|
|
for (i = 0; i < num_commands; i++) {
|
|
enum client_modes mode = commands[i].mode;
|
|
char *mode_arg = commands[i].arg;
|
|
- char *data = NULL;
|
|
- size_t data_len = 0;
|
|
- if (mode == INSTALL_M || mode == UPGRADE_M || mode == BASE_M) {
|
|
- if ((data_len = map_file(mode_arg, &data)) == 0) {
|
|
- fprintf(stderr,
|
|
- "%s: Could not read file '%s': %s\n",
|
|
- argv[0], mode_arg, errno ? strerror(errno) : "");
|
|
- goto cleanup;
|
|
- }
|
|
- }
|
|
switch (mode) {
|
|
case INSTALL_M:{
|
|
if (verbose) {
|
|
@@ -357,7 +329,7 @@
|
|
mode_arg);
|
|
}
|
|
result =
|
|
- semanage_module_install(sh, data, data_len);
|
|
+ semanage_module_install_file(sh, mode_arg);
|
|
break;
|
|
}
|
|
case UPGRADE_M:{
|
|
@@ -367,7 +339,7 @@
|
|
mode_arg);
|
|
}
|
|
result =
|
|
- semanage_module_upgrade(sh, data, data_len);
|
|
+ semanage_module_upgrade_file(sh, mode_arg);
|
|
break;
|
|
}
|
|
case BASE_M:{
|
|
@@ -377,8 +349,7 @@
|
|
mode_arg);
|
|
}
|
|
result =
|
|
- semanage_module_install_base(sh, data,
|
|
- data_len);
|
|
+ semanage_module_install_base_file(sh, mode_arg);
|
|
break;
|
|
}
|
|
case REMOVE_M:{
|
|
@@ -429,9 +400,6 @@
|
|
}
|
|
}
|
|
commit += do_commit[mode];
|
|
- if (mode == INSTALL_M || mode == UPGRADE_M || mode == BASE_M) {
|
|
- munmap(data, data_len);
|
|
- }
|
|
if (result < 0) {
|
|
fprintf(stderr, "%s: Failed on %s!\n", argv[0],
|
|
mode_arg ? : "list");
|