* Tue Sep 8 2009 Dan Walsh <dwalsh@redhat.com> 2.0.73-2
- Fix init script to show status in usage message
This commit is contained in:
parent
b745fe1161
commit
fc20c42a12
@ -658,6 +658,20 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
+extern void watch_list_free(int fd);
|
||||
|
||||
#endif
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.init policycoreutils-2.0.73/restorecond/restorecond.init
|
||||
--- nsapolicycoreutils/restorecond/restorecond.init 2009-08-20 15:49:21.000000000 -0400
|
||||
+++ policycoreutils-2.0.73/restorecond/restorecond.init 2009-09-08 19:19:57.000000000 -0400
|
||||
@@ -82,9 +82,8 @@
|
||||
[ -e /var/lock/subsys/restorecond ] && restart || :
|
||||
;;
|
||||
*)
|
||||
- echo $"Usage: $0 {start|stop|restart|reload|condrestart}"
|
||||
+ echo $"Usage: $0 {start|stop|restart|reload|status|condrestart}"
|
||||
RETVAL=3
|
||||
esac
|
||||
|
||||
exit $RETVAL
|
||||
-
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond_user.conf policycoreutils-2.0.73/restorecond/restorecond_user.conf
|
||||
--- nsapolicycoreutils/restorecond/restorecond_user.conf 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-2.0.73/restorecond/restorecond_user.conf 2009-09-08 09:21:08.000000000 -0400
|
||||
@ -1962,7 +1976,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
}
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/setfiles/Makefile policycoreutils-2.0.73/setfiles/Makefile
|
||||
--- nsapolicycoreutils/setfiles/Makefile 2009-07-07 15:32:32.000000000 -0400
|
||||
+++ policycoreutils-2.0.73/setfiles/Makefile 2009-09-08 09:21:08.000000000 -0400
|
||||
+++ policycoreutils-2.0.73/setfiles/Makefile 2009-09-08 18:40:14.000000000 -0400
|
||||
@@ -5,7 +5,7 @@
|
||||
LIBDIR ?= $(PREFIX)/lib
|
||||
AUDITH = $(shell ls /usr/include/libaudit.h 2>/dev/null)
|
||||
@ -2558,7 +2572,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
+
|
||||
+#endif
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/setfiles/setfiles.c policycoreutils-2.0.73/setfiles/setfiles.c
|
||||
--- nsapolicycoreutils/setfiles/setfiles.c 2009-09-08 09:03:10.000000000 -0400
|
||||
--- nsapolicycoreutils/setfiles/setfiles.c 2009-09-08 19:09:27.000000000 -0400
|
||||
+++ policycoreutils-2.0.73/setfiles/setfiles.c 2009-09-08 09:49:37.000000000 -0400
|
||||
@@ -1,26 +1,12 @@
|
||||
-#ifndef _GNU_SOURCE
|
||||
@ -3086,7 +3100,17 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
}
|
||||
|
||||
int canoncon(char **contextp)
|
||||
@@ -585,77 +152,6 @@
|
||||
@@ -535,7 +102,8 @@
|
||||
exit(1);
|
||||
}
|
||||
} else if (security_canonicalize_context_raw(context, &tmpcon) == 0) {
|
||||
- free(context); *contextp = tmpcon;
|
||||
+ free(context);
|
||||
+ *contextp = tmpcon;
|
||||
} else if (errno != ENOENT) {
|
||||
rc = -1;
|
||||
inc_err();
|
||||
@@ -584,77 +152,6 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
@ -3164,7 +3188,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
static int process_one_realpath(char *name)
|
||||
{
|
||||
int rc = 0;
|
||||
@@ -668,7 +164,7 @@
|
||||
@@ -667,7 +164,7 @@
|
||||
rc = lstat(name, &sb);
|
||||
if (rc < 0) {
|
||||
fprintf(stderr, "%s: lstat(%s) failed: %s\n",
|
||||
@ -3173,7 +3197,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
return -1;
|
||||
}
|
||||
|
||||
@@ -802,20 +298,30 @@
|
||||
@@ -801,20 +298,30 @@
|
||||
char *buf = NULL;
|
||||
size_t buf_len;
|
||||
char *base;
|
||||
@ -3212,7 +3236,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
|
||||
if (!strcmp(base, SETFILES)) {
|
||||
/*
|
||||
@@ -830,28 +336,28 @@
|
||||
@@ -829,28 +336,28 @@
|
||||
iamrestorecon = 0;
|
||||
recurse = 1;
|
||||
expand_realpath = 0;
|
||||
@ -3249,7 +3273,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
ctx_validate = 0;
|
||||
|
||||
/* restorecon only: silent exit if no SELinux.
|
||||
@@ -913,37 +419,37 @@
|
||||
@@ -912,37 +419,37 @@
|
||||
input_filename = optarg;
|
||||
break;
|
||||
case 'd':
|
||||
@ -3296,7 +3320,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
break;
|
||||
case 'R':
|
||||
case 'r':
|
||||
@@ -956,7 +462,7 @@
|
||||
@@ -955,7 +462,7 @@
|
||||
argv[0]);
|
||||
exit(1);
|
||||
}
|
||||
@ -3305,7 +3329,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
fprintf(stderr,
|
||||
"%s: only one -r can be specified\n",
|
||||
argv[0]);
|
||||
@@ -967,23 +473,23 @@
|
||||
@@ -966,23 +473,23 @@
|
||||
case 's':
|
||||
use_input_file = 1;
|
||||
input_filename = "-";
|
||||
@ -3334,7 +3358,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
break;
|
||||
case 'W':
|
||||
warn_no_match = 1;
|
||||
@@ -1031,18 +537,13 @@
|
||||
@@ -1030,18 +537,13 @@
|
||||
}
|
||||
|
||||
/* Load the file contexts configuration and check it. */
|
||||
@ -3356,7 +3380,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
if (use_input_file) {
|
||||
FILE *f = stdin;
|
||||
ssize_t len;
|
||||
@@ -1059,6 +560,9 @@
|
||||
@@ -1058,6 +560,9 @@
|
||||
delim = (null_terminated != 0) ? '\0' : '\n';
|
||||
while ((len = getdelim(&buf, &buf_len, delim, f)) > 0) {
|
||||
buf[len - 1] = 0;
|
||||
@ -3366,7 +3390,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
|
||||
errors |= process_one_realpath(buf);
|
||||
}
|
||||
if (strcmp(input_filename, "-") != 0)
|
||||
@@ -1068,22 +572,21 @@
|
||||
@@ -1067,22 +572,21 @@
|
||||
errors |= process_one_realpath(argv[i]);
|
||||
}
|
||||
}
|
||||
|
@ -6,7 +6,7 @@
|
||||
Summary: SELinux policy core utilities
|
||||
Name: policycoreutils
|
||||
Version: 2.0.73
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -295,6 +295,9 @@ fi
|
||||
exit 0
|
||||
|
||||
%changelog
|
||||
* Tue Sep 8 2009 Dan Walsh <dwalsh@redhat.com> 2.0.73-2
|
||||
- Fix init script to show status in usage message
|
||||
|
||||
* Tue Sep 8 2009 Dan Walsh <dwalsh@redhat.com> 2.0.73-1
|
||||
- Update to upstream
|
||||
* Add semanage dontaudit to turn off dontaudits from Dan Walsh.
|
||||
|
Loading…
Reference in New Issue
Block a user