* Fri Mar 17 2006 Dan Walsh <dwalsh@redhat.com> 1.30-1
- Update to upstream
This commit is contained in:
parent
ec67d7567a
commit
f459d26ec3
@ -951,28 +951,42 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/restorecond/utmpwatcher.
|
||||
+#endif
|
||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-1.30/scripts/fixfiles
|
||||
--- nsapolicycoreutils/scripts/fixfiles 2006-01-04 13:07:46.000000000 -0500
|
||||
+++ policycoreutils-1.30/scripts/fixfiles 2006-03-17 15:37:21.000000000 -0500
|
||||
@@ -124,7 +124,10 @@
|
||||
+++ policycoreutils-1.30/scripts/fixfiles 2006-03-17 16:26:25.000000000 -0500
|
||||
@@ -124,7 +124,15 @@
|
||||
exit $?
|
||||
fi
|
||||
if [ ! -z "$DIRS" ]; then
|
||||
- ${RESTORECON} ${OUTFILES} ${FORCEFLAG} -R $1 -v $DIRS 2>&1 >> $LOGFILE
|
||||
+ for d in ${DIRS} ; do find $d \
|
||||
+ ! \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o -print; \
|
||||
+ ${RESTORECON} ${OUTFILES} ${FORCEFLAG} $1 -v -f - 2>&1 >> $LOGFILE
|
||||
+ done
|
||||
+ if [ -x /usr/bin/find ]; then
|
||||
+ for d in ${DIRS} ; do find $d \
|
||||
+ ! \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o -print; \
|
||||
+ ${RESTORECON} ${OUTFILES} ${FORCEFLAG} $1 -v -f - 2>&1 >> $LOGFILE
|
||||
+ done
|
||||
+ else
|
||||
+ ${RESTORECON} ${OUTFILES} ${FORCEFLAG} -R $1 -v $DIRS 2>&1 >> $LOGFILE
|
||||
+ fi
|
||||
+
|
||||
exit $?
|
||||
fi
|
||||
LogReadOnly
|
||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/Makefile policycoreutils-1.30/scripts/Makefile
|
||||
--- nsapolicycoreutils/scripts/Makefile 2005-12-08 12:59:25.000000000 -0500
|
||||
+++ policycoreutils-1.30/scripts/Makefile 2006-03-17 15:37:21.000000000 -0500
|
||||
+++ policycoreutils-1.30/scripts/Makefile 2006-03-17 16:27:22.000000000 -0500
|
||||
@@ -1,7 +1,7 @@
|
||||
# Installation directories.
|
||||
PREFIX ?= ${DESTDIR}/usr
|
||||
BINDIR ?= $(PREFIX)/bin
|
||||
-SBINDIR ?= $(PREFIX)/sbin
|
||||
+SBINDIR ?= $(DESTDIR)/sbin
|
||||
MANDIR ?= $(PREFIX)/share/man
|
||||
LOCALEDIR ?= /usr/share/locale
|
||||
|
||||
@@ -13,7 +13,7 @@
|
||||
-mkdir -p $(BINDIR)
|
||||
install -m 755 $(TARGETS) $(SBINDIR)
|
||||
install -m 755 chcat $(BINDIR)
|
||||
- install -m 755 fixfiles $(DESTDIR)/sbin
|
||||
+ install -m 755 fixfiles $(PREFIX)/sbin
|
||||
+ install -m 755 fixfiles $(SBINDIR)
|
||||
-mkdir -p $(MANDIR)/man8
|
||||
install -m 644 fixfiles.8 $(MANDIR)/man8/
|
||||
install -m 644 genhomedircon.8 $(MANDIR)/man8/
|
||||
|
@ -59,8 +59,8 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
/sbin/restorecon
|
||||
/sbin/fixfiles
|
||||
%{_sbindir}/restorecond
|
||||
%{_sbindir}/fixfiles
|
||||
%{_sbindir}/setfiles
|
||||
%{_sbindir}/setsebool
|
||||
%{_sbindir}/semodule
|
||||
|
Loading…
Reference in New Issue
Block a user