* Fri Jun 22 2007 Dan Walsh <dwalsh@redhat.com> 2.0.22-2
- Fix else path in chcat
This commit is contained in:
parent
a57e4b7bc5
commit
df5eceb2a1
@ -1,6 +1,6 @@
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-2.0.19/audit2allow/Makefile
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-2.0.22/audit2allow/Makefile
|
||||
--- nsapolicycoreutils/audit2allow/Makefile 2007-02-07 12:11:49.000000000 -0500
|
||||
+++ policycoreutils-2.0.19/audit2allow/Makefile 2007-06-11 14:41:13.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/audit2allow/Makefile 2007-06-22 09:31:53.000000000 -0400
|
||||
@@ -1,6 +1,7 @@
|
||||
# Installation directories.
|
||||
PREFIX ?= ${DESTDIR}/usr
|
||||
@ -18,18 +18,18 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
-mkdir -p $(MANDIR)/man1
|
||||
install -m 644 audit2allow.1 $(MANDIR)/man1/
|
||||
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.19/Makefile
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.22/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2007-05-18 09:58:33.000000000 -0400
|
||||
+++ policycoreutils-2.0.19/Makefile 2007-06-11 14:41:13.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/Makefile 2007-06-22 09:31:53.000000000 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||
|
||||
all install relabel clean indent:
|
||||
@for subdir in $(SUBDIRS); do \
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.19/restorecond/restorecond.c
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.22/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-02-22 08:53:22.000000000 -0500
|
||||
+++ policycoreutils-2.0.19/restorecond/restorecond.c 2007-06-11 14:41:13.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/restorecond/restorecond.c 2007-06-22 09:31:53.000000000 -0400
|
||||
@@ -210,9 +210,10 @@
|
||||
}
|
||||
|
||||
@ -56,9 +56,30 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
}
|
||||
free(scontext);
|
||||
close(fd);
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.19/semanage/semanage
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.22/scripts/chcat
|
||||
--- nsapolicycoreutils/scripts/chcat 2007-04-24 10:36:17.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/scripts/chcat 2007-06-22 09:32:13.000000000 -0400
|
||||
@@ -77,7 +77,7 @@
|
||||
|
||||
if len(cats) > 0:
|
||||
new_serange = "%s-%s:%s" % (serange[0], top[0], ",".join(cats))
|
||||
- else
|
||||
+ else:
|
||||
new_serange = "%s-%s" % (serange[0], top[0])
|
||||
|
||||
if add_ind:
|
||||
@@ -155,7 +155,7 @@
|
||||
|
||||
if len(cats) > 0:
|
||||
new_serange = "%s-%s:%s" % (serange[0], top[0], ",".join(cats))
|
||||
- else
|
||||
+ else:
|
||||
new_serange = "%s-%s" % (serange[0], top[0])
|
||||
|
||||
if add_ind:
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.22/semanage/semanage
|
||||
--- nsapolicycoreutils/semanage/semanage 2007-05-04 09:14:39.000000000 -0400
|
||||
+++ policycoreutils-2.0.19/semanage/semanage 2007-06-11 14:41:13.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/semanage/semanage 2007-06-22 09:31:53.000000000 -0400
|
||||
@@ -34,7 +34,10 @@
|
||||
sys.stdout = codecs.getwriter(locale.getpreferredencoding())(sys.__stdout__, 'replace')
|
||||
|
||||
@ -71,9 +92,9 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
|
||||
except IOError:
|
||||
import __builtin__
|
||||
__builtin__.__dict__['_'] = unicode
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.19/semanage/seobject.py
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.22/semanage/seobject.py
|
||||
--- nsapolicycoreutils/semanage/seobject.py 2007-04-12 12:43:06.000000000 -0400
|
||||
+++ policycoreutils-2.0.19/semanage/seobject.py 2007-06-11 14:41:13.000000000 -0400
|
||||
+++ policycoreutils-2.0.22/semanage/seobject.py 2007-06-22 09:31:53.000000000 -0400
|
||||
@@ -210,6 +210,7 @@
|
||||
os.write(fd, self.out())
|
||||
os.close(fd)
|
||||
|
@ -6,7 +6,7 @@
|
||||
Summary: SELinux policy core utilities.
|
||||
Name: policycoreutils
|
||||
Version: 2.0.22
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -192,6 +192,9 @@ if [ "$1" -ge "1" ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Fri Jun 22 2007 Dan Walsh <dwalsh@redhat.com> 2.0.22-2
|
||||
- Fix else path in chcat
|
||||
|
||||
* Thu Jun 21 2007 Dan Walsh <dwalsh@redhat.com> 2.0.22-1
|
||||
- Update to match NSA
|
||||
* Rebase setfiles to use new labeling interface.
|
||||
|
Loading…
Reference in New Issue
Block a user