* Tue Jan 8 2008 Dan Walsh <dwalsh@redhat.com> 2.0.34-7
- Fix fixfiles to handle no args
This commit is contained in:
parent
856619e48c
commit
d7cddef625
@ -69,6 +69,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
|
|
||||||
if __name__ == "__main__":
|
if __name__ == "__main__":
|
||||||
sys.exit(main())
|
sys.exit(main())
|
||||||
|
Binary files nsapolicycoreutils/audit2why/audit2why and policycoreutils-2.0.34/audit2why/audit2why differ
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2why.c policycoreutils-2.0.34/audit2why/audit2why.c
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2why.c policycoreutils-2.0.34/audit2why/audit2why.c
|
||||||
--- nsapolicycoreutils/audit2why/audit2why.c 2007-07-16 14:20:41.000000000 -0400
|
--- nsapolicycoreutils/audit2why/audit2why.c 2007-07-16 14:20:41.000000000 -0400
|
||||||
+++ policycoreutils-2.0.34/audit2why/audit2why.c 2008-01-05 08:19:56.000000000 -0500
|
+++ policycoreutils-2.0.34/audit2why/audit2why.c 2008-01-05 08:19:56.000000000 -0500
|
||||||
@ -781,6 +782,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
+extern void policy_finish(void);
|
+extern void policy_finish(void);
|
||||||
+extern int policy_init(const char *init_path);
|
+extern int policy_init(const char *init_path);
|
||||||
+extern int audit2why(const security_context_t scon, const security_context_t tcon, char *tclassstr, char *permstr, struct boolean_t **bools);
|
+extern int audit2why(const security_context_t scon, const security_context_t tcon, char *tclassstr, char *permstr, struct boolean_t **bools);
|
||||||
|
Binary files nsapolicycoreutils/audit2why/audit2why.o and policycoreutils-2.0.34/audit2why/audit2why.o differ
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2why.py policycoreutils-2.0.34/audit2why/audit2why.py
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2why.py policycoreutils-2.0.34/audit2why/audit2why.py
|
||||||
--- nsapolicycoreutils/audit2why/audit2why.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/audit2why/audit2why.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-2.0.34/audit2why/audit2why.py 2008-01-05 08:15:10.000000000 -0500
|
+++ policycoreutils-2.0.34/audit2why/audit2why.py 2008-01-05 08:15:10.000000000 -0500
|
||||||
@ -872,6 +874,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
+audit2why = _audit2why.audit2why
|
+audit2why = _audit2why.audit2why
|
||||||
+
|
+
|
||||||
+
|
+
|
||||||
|
Binary files nsapolicycoreutils/audit2why/_audit2why.so and policycoreutils-2.0.34/audit2why/_audit2why.so differ
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2whyswig.i policycoreutils-2.0.34/audit2why/audit2whyswig.i
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2whyswig.i policycoreutils-2.0.34/audit2why/audit2whyswig.i
|
||||||
--- nsapolicycoreutils/audit2why/audit2whyswig.i 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/audit2why/audit2whyswig.i 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-2.0.34/audit2why/audit2whyswig.i 2008-01-08 05:24:42.000000000 -0500
|
+++ policycoreutils-2.0.34/audit2why/audit2whyswig.i 2008-01-08 05:24:42.000000000 -0500
|
||||||
@ -4549,6 +4552,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
+ SWIG_Python_SetConstant(d, "RBAC",SWIG_From_int((int)(4)));
|
+ SWIG_Python_SetConstant(d, "RBAC",SWIG_From_int((int)(4)));
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
|
Binary files nsapolicycoreutils/audit2why/audit2whyswig_wrap.lo and policycoreutils-2.0.34/audit2why/audit2whyswig_wrap.lo differ
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/Makefile policycoreutils-2.0.34/audit2why/Makefile
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/Makefile policycoreutils-2.0.34/audit2why/Makefile
|
||||||
--- nsapolicycoreutils/audit2why/Makefile 2007-07-16 14:20:41.000000000 -0400
|
--- nsapolicycoreutils/audit2why/Makefile 2007-07-16 14:20:41.000000000 -0400
|
||||||
+++ policycoreutils-2.0.34/audit2why/Makefile 2008-01-05 07:59:15.000000000 -0500
|
+++ policycoreutils-2.0.34/audit2why/Makefile 2008-01-05 07:59:15.000000000 -0500
|
||||||
@ -4664,22 +4668,22 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
gettext.install('policycoreutils')
|
gettext.install('policycoreutils')
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-2.0.34/scripts/fixfiles
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-2.0.34/scripts/fixfiles
|
||||||
--- nsapolicycoreutils/scripts/fixfiles 2007-12-10 21:42:28.000000000 -0500
|
--- nsapolicycoreutils/scripts/fixfiles 2007-12-10 21:42:28.000000000 -0500
|
||||||
+++ policycoreutils-2.0.34/scripts/fixfiles 2008-01-08 08:50:11.000000000 -0500
|
+++ policycoreutils-2.0.34/scripts/fixfiles 2008-01-08 09:56:34.000000000 -0500
|
||||||
@@ -126,17 +126,15 @@
|
@@ -126,17 +126,15 @@
|
||||||
done
|
done
|
||||||
exit $?
|
exit $?
|
||||||
fi
|
fi
|
||||||
-if [ ! -z "$DIRS" ]; then
|
-if [ ! -z "$DIRS" ]; then
|
||||||
+if [ ! -z "$PATH" ]; then
|
+if [ ! -z "$FILEPATH" ]; then
|
||||||
if [ -x /usr/bin/find ]; then
|
if [ -x /usr/bin/find ]; then
|
||||||
- for d in ${DIRS} ; do find $d \
|
- for d in ${DIRS} ; do find $d \
|
||||||
+ /usr/bin/find "$PATH" \
|
+ /usr/bin/find "$FILEPATH" \
|
||||||
! \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o -print | \
|
! \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -prune -o -print | \
|
||||||
${RESTORECON} ${OUTFILES} ${FORCEFLAG} $* -f - 2>&1 >> $LOGFILE
|
${RESTORECON} ${OUTFILES} ${FORCEFLAG} $* -f - 2>&1 >> $LOGFILE
|
||||||
- done
|
- done
|
||||||
else
|
else
|
||||||
- ${RESTORECON} ${OUTFILES} ${FORCEFLAG} -R $* $DIRS 2>&1 >> $LOGFILE
|
- ${RESTORECON} ${OUTFILES} ${FORCEFLAG} -R $* $DIRS 2>&1 >> $LOGFILE
|
||||||
+ ${RESTORECON} ${OUTFILES} ${FORCEFLAG} -R $* $PATH 2>&1 >> $LOGFILE
|
+ ${RESTORECON} ${OUTFILES} ${FORCEFLAG} -R $* $FILEPATH 2>&1 >> $LOGFILE
|
||||||
fi
|
fi
|
||||||
-
|
-
|
||||||
- exit $?
|
- exit $?
|
||||||
@ -4722,7 +4726,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
+ process $command
|
+ process $command
|
||||||
+ else
|
+ else
|
||||||
+ while [ -n "$1" ]; do
|
+ while [ -n "$1" ]; do
|
||||||
+ PATH=$1
|
+ FILEPATH=$1
|
||||||
+ process $command
|
+ process $command
|
||||||
+ shift
|
+ shift
|
||||||
+ done
|
+ done
|
||||||
|
@ -6,7 +6,7 @@
|
|||||||
Summary: SELinux policy core utilities
|
Summary: SELinux policy core utilities
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 2.0.34
|
Version: 2.0.34
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||||
@ -193,7 +193,7 @@ if [ "$1" -ge "1" ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Jan 8 2008 Dan Walsh <dwalsh@redhat.com> 2.0.34-6
|
* Tue Jan 8 2008 Dan Walsh <dwalsh@redhat.com> 2.0.34-7
|
||||||
- Fix fixfiles to handle no args
|
- Fix fixfiles to handle no args
|
||||||
|
|
||||||
* Mon Dec 31 2007 Dan Walsh <dwalsh@redhat.com> 2.0.34-5
|
* Mon Dec 31 2007 Dan Walsh <dwalsh@redhat.com> 2.0.34-5
|
||||||
|
Loading…
Reference in New Issue
Block a user