Remove lockdown wizard
This commit is contained in:
parent
01c8a3601e
commit
c938748d91
@ -45,10 +45,10 @@ index ef4bec3..9b313ec 100644
|
|||||||
return None
|
return None
|
||||||
diff --git a/policycoreutils/gui/Makefile b/policycoreutils/gui/Makefile
|
diff --git a/policycoreutils/gui/Makefile b/policycoreutils/gui/Makefile
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..0d63b78
|
index 0000000..53efa84
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/policycoreutils/gui/Makefile
|
+++ b/policycoreutils/gui/Makefile
|
||||||
@@ -0,0 +1,40 @@
|
@@ -0,0 +1,38 @@
|
||||||
+# Installation directories.
|
+# Installation directories.
|
||||||
+PREFIX ?= ${DESTDIR}/usr
|
+PREFIX ?= ${DESTDIR}/usr
|
||||||
+BINDIR ?= $(PREFIX)/bin
|
+BINDIR ?= $(PREFIX)/bin
|
||||||
@ -64,14 +64,13 @@ index 0000000..0d63b78
|
|||||||
+modulesPage.py \
|
+modulesPage.py \
|
||||||
+polgen.glade \
|
+polgen.glade \
|
||||||
+portsPage.py \
|
+portsPage.py \
|
||||||
+lockdown.glade \
|
|
||||||
+semanagePage.py \
|
+semanagePage.py \
|
||||||
+statusPage.py \
|
+statusPage.py \
|
||||||
+system-config-selinux.glade \
|
+system-config-selinux.glade \
|
||||||
+usersPage.py \
|
+usersPage.py \
|
||||||
+selinux.tbl
|
+selinux.tbl
|
||||||
+
|
+
|
||||||
+all: $(TARGETS) system-config-selinux.py polgengui.py templates lockdown.py polgen.py
|
+all: $(TARGETS) system-config-selinux.py polgengui.py templates polgen.py
|
||||||
+
|
+
|
||||||
+install: all
|
+install: all
|
||||||
+ -mkdir -p $(SHAREDIR)/templates
|
+ -mkdir -p $(SHAREDIR)/templates
|
||||||
@ -80,7 +79,6 @@ index 0000000..0d63b78
|
|||||||
+ install -m 755 polgengui.py $(SHAREDIR)
|
+ install -m 755 polgengui.py $(SHAREDIR)
|
||||||
+ install -m 755 polgen.py $(SHAREDIR)
|
+ install -m 755 polgen.py $(SHAREDIR)
|
||||||
+ (cd $(BINDIR); ln -fs ../share/system-config-selinux/polgen.py sepolgen)
|
+ (cd $(BINDIR); ln -fs ../share/system-config-selinux/polgen.py sepolgen)
|
||||||
+ install -m 755 lockdown.py $(SHAREDIR)
|
|
||||||
+ install -m 644 $(TARGETS) $(SHAREDIR)
|
+ install -m 644 $(TARGETS) $(SHAREDIR)
|
||||||
+ install -m 644 templates/*.py $(SHAREDIR)/templates/
|
+ install -m 644 templates/*.py $(SHAREDIR)/templates/
|
||||||
+
|
+
|
||||||
@ -8955,10 +8953,10 @@ index 0000000..fd6ef4f
|
|||||||
+
|
+
|
||||||
diff --git a/policycoreutils/gui/system-config-selinux.glade b/policycoreutils/gui/system-config-selinux.glade
|
diff --git a/policycoreutils/gui/system-config-selinux.glade b/policycoreutils/gui/system-config-selinux.glade
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..4dc5d0b
|
index 0000000..05a697e
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/policycoreutils/gui/system-config-selinux.glade
|
+++ b/policycoreutils/gui/system-config-selinux.glade
|
||||||
@@ -0,0 +1,3024 @@
|
@@ -0,0 +1,3005 @@
|
||||||
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
|
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
|
||||||
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
|
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
|
||||||
+
|
+
|
||||||
@ -10190,7 +10188,6 @@ index 0000000..4dc5d0b
|
|||||||
+ <widget class="GtkHPaned" id="hpaned1">
|
+ <widget class="GtkHPaned" id="hpaned1">
|
||||||
+ <property name="visible">True</property>
|
+ <property name="visible">True</property>
|
||||||
+ <property name="can_focus">True</property>
|
+ <property name="can_focus">True</property>
|
||||||
+ <property name="position">0</property>
|
|
||||||
+
|
+
|
||||||
+ <child>
|
+ <child>
|
||||||
+ <widget class="GtkFrame" id="frame1">
|
+ <widget class="GtkFrame" id="frame1">
|
||||||
@ -10587,24 +10584,6 @@ index 0000000..4dc5d0b
|
|||||||
+ <property name="homogeneous">True</property>
|
+ <property name="homogeneous">True</property>
|
||||||
+ </packing>
|
+ </packing>
|
||||||
+ </child>
|
+ </child>
|
||||||
+
|
|
||||||
+ <child>
|
|
||||||
+ <widget class="GtkToolButton" id="toolbutton36">
|
|
||||||
+ <property name="visible">True</property>
|
|
||||||
+ <property name="tooltip" translatable="yes">Run booleans lockdown wizard</property>
|
|
||||||
+ <property name="label" translatable="yes">Lockdown...</property>
|
|
||||||
+ <property name="use_underline">True</property>
|
|
||||||
+ <property name="stock_id">gtk-print-error</property>
|
|
||||||
+ <property name="visible_horizontal">True</property>
|
|
||||||
+ <property name="visible_vertical">True</property>
|
|
||||||
+ <property name="is_important">False</property>
|
|
||||||
+ <signal name="clicked" handler="on_lockdown_clicked" last_modification_time="Thu, 03 Jul 2008 16:51:17 GMT"/>
|
|
||||||
+ </widget>
|
|
||||||
+ <packing>
|
|
||||||
+ <property name="expand">False</property>
|
|
||||||
+ <property name="homogeneous">True</property>
|
|
||||||
+ </packing>
|
|
||||||
+ </child>
|
|
||||||
+ </widget>
|
+ </widget>
|
||||||
+ <packing>
|
+ <packing>
|
||||||
+ <property name="padding">0</property>
|
+ <property name="padding">0</property>
|
||||||
|
@ -7,7 +7,7 @@
|
|||||||
Summary: SELinux policy core utilities
|
Summary: SELinux policy core utilities
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 2.1.11
|
Version: 2.1.11
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
# Based on git repository with tag 20101221
|
# Based on git repository with tag 20101221
|
||||||
@ -340,6 +340,9 @@ fi
|
|||||||
%{_bindir}/systemctl try-restart restorecond.service >/dev/null 2>&1 || :
|
%{_bindir}/systemctl try-restart restorecond.service >/dev/null 2>&1 || :
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 1 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.11-10
|
||||||
|
- Remove lockdown wizard
|
||||||
|
|
||||||
* Mon Apr 30 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.11-9
|
* Mon Apr 30 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.11-9
|
||||||
- Fix semanage fcontext -E to extract the equivalance customizations.
|
- Fix semanage fcontext -E to extract the equivalance customizations.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user