Add Miroslav Grepl patch to create etc_rw_t sock files policy

This commit is contained in:
Dan Walsh 2012-11-21 14:32:28 -05:00
parent 77c01a631e
commit c80e41cce5
2 changed files with 20 additions and 13 deletions

View File

@ -9794,18 +9794,9 @@ index 8055a9e..0000000
-FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_spool_t,s0) -FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_spool_t,s0)
-""" -"""
diff --git a/policycoreutils/load_policy/Makefile b/policycoreutils/load_policy/Makefile diff --git a/policycoreutils/load_policy/Makefile b/policycoreutils/load_policy/Makefile
index 5da2e0d..a5ec65f 100644 index 5da2e0d..7c5bab0 100644
--- a/policycoreutils/load_policy/Makefile --- a/policycoreutils/load_policy/Makefile
+++ b/policycoreutils/load_policy/Makefile +++ b/policycoreutils/load_policy/Makefile
@@ -7,7 +7,7 @@ LOCALEDIR ?= /usr/share/locale
CFLAGS ?= -Werror -Wall -W
override CFLAGS += $(LDFLAGS) -I$(PREFIX)/include -DUSE_NLS -DLOCALEDIR="\"$(LOCALEDIR)\"" -DPACKAGE="\"policycoreutils\""
-LDLIBS += -lsepol -lselinux -L$(PREFIX)/lib
+LDLIBS += -lselinux -lsepol -L$(PREFIX)/lib
TARGETS=$(patsubst %.c,%,$(wildcard *.c))
@@ -19,7 +19,7 @@ install: all @@ -19,7 +19,7 @@ install: all
test -d $(MANDIR)/man8 || install -m 755 -d $(MANDIR)/man8 test -d $(MANDIR)/man8 || install -m 755 -d $(MANDIR)/man8
install -m 644 load_policy.8 $(MANDIR)/man8/ install -m 644 load_policy.8 $(MANDIR)/man8/
@ -334971,6 +334962,15 @@ index 0b4cbaa..9ab7334 100644
.SH "ARGUMENTS" .SH "ARGUMENTS"
One of: One of:
.TP .TP
diff --git a/policycoreutils/scripts/genhomedircon b/policycoreutils/scripts/genhomedircon
new file mode 100644
index 0000000..58b19cd
--- /dev/null
+++ b/policycoreutils/scripts/genhomedircon
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/sbin/semodule -Bn
diff --git a/policycoreutils/semanage/default_encoding/Makefile b/policycoreutils/semanage/default_encoding/Makefile diff --git a/policycoreutils/semanage/default_encoding/Makefile b/policycoreutils/semanage/default_encoding/Makefile
new file mode 100644 new file mode 100644
index 0000000..e15a877 index 0000000..e15a877
@ -342201,10 +342201,10 @@ index 0000000..679d0a5
+""" +"""
diff --git a/policycoreutils/sepolicy/sepolicy/templates/rw.py b/policycoreutils/sepolicy/sepolicy/templates/rw.py diff --git a/policycoreutils/sepolicy/sepolicy/templates/rw.py b/policycoreutils/sepolicy/sepolicy/templates/rw.py
new file mode 100644 new file mode 100644
index 0000000..143f56a index 0000000..46dd367
--- /dev/null --- /dev/null
+++ b/policycoreutils/sepolicy/sepolicy/templates/rw.py +++ b/policycoreutils/sepolicy/sepolicy/templates/rw.py
@@ -0,0 +1,154 @@ @@ -0,0 +1,158 @@
+# Copyright (C) 2007-2012 Red Hat +# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information +# see file 'COPYING' for use and warranty information
+# +#
@ -342356,6 +342356,10 @@ index 0000000..143f56a
+FILENAME -- gen_context(system_u:object_r:TEMPLATETYPE_rw_t,s0) +FILENAME -- gen_context(system_u:object_r:TEMPLATETYPE_rw_t,s0)
+""" +"""
+ +
+fc_sock_file="""\
+FILENAME -s gen_context(system_u:object_r:TEMPLATETYPE_etc_rw_t,s0)
+"""
+
+fc_dir=""" +fc_dir="""
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_rw_t,s0) +FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_rw_t,s0)
+""" +"""

View File

@ -7,7 +7,7 @@
Summary: SELinux policy core utilities Summary: SELinux policy core utilities
Name: policycoreutils Name: policycoreutils
Version: 2.1.13 Version: 2.1.13
Release: 34%{?dist} Release: 35%{?dist}
License: GPLv2 License: GPLv2
Group: System Environment/Base Group: System Environment/Base
# Based on git repository with tag 20101221 # Based on git repository with tag 20101221
@ -338,6 +338,9 @@ The policycoreutils-restorecond package contains the restorecond service.
%{_bindir}/systemctl try-restart restorecond.service >/dev/null 2>&1 || : %{_bindir}/systemctl try-restart restorecond.service >/dev/null 2>&1 || :
%changelog %changelog
* Wed Nov 21 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.12-35
- Add Miroslav Grepl patch to create etc_rw_t sock files policy
* Fri Nov 16 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.12-34 * Fri Nov 16 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.12-34
- Fix semanage to work without policycoreutils-devel installed - Fix semanage to work without policycoreutils-devel installed
- Update translations - Update translations