* Tue Nov 28 2006 Dan Walsh <dwalsh@redhat.com> 1.33.5-2
- Fix -q qualifier on load_policy Resolves: #214827
This commit is contained in:
parent
252a932c4d
commit
c5e5d1fec3
@ -1,6 +1,6 @@
|
|||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-1.33.4/audit2allow/audit2allow
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-1.33.5/audit2allow/audit2allow
|
||||||
--- nsapolicycoreutils/audit2allow/audit2allow 2006-11-16 17:14:29.000000000 -0500
|
--- nsapolicycoreutils/audit2allow/audit2allow 2006-11-16 17:14:29.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/audit2allow/audit2allow 2006-11-22 16:16:37.000000000 -0500
|
+++ policycoreutils-1.33.5/audit2allow/audit2allow 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -29,6 +29,7 @@
|
@@ -29,6 +29,7 @@
|
||||||
if __name__ == '__main__':
|
if __name__ == '__main__':
|
||||||
import commands, sys, os, getopt, selinux
|
import commands, sys, os, getopt, selinux
|
||||||
@ -75,9 +75,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
else:
|
else:
|
||||||
errorExit(rc[1])
|
errorExit(rc[1])
|
||||||
|
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-1.33.4/gui/booleansPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-1.33.5/gui/booleansPage.py
|
||||||
--- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/booleansPage.py 2006-11-24 08:54:51.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/booleansPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,199 @@
|
@@ -0,0 +1,199 @@
|
||||||
+#
|
+#
|
||||||
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel
|
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel
|
||||||
@ -278,9 +278,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+
|
+
|
||||||
+ setsebool="/usr/sbin/setsebool -P %s=%d" % (key, not val)
|
+ setsebool="/usr/sbin/setsebool -P %s=%d" % (key, not val)
|
||||||
+ commands.getstatusoutput(setsebool)
|
+ commands.getstatusoutput(setsebool)
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-1.33.4/gui/fcontextPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-1.33.5/gui/fcontextPage.py
|
||||||
--- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/fcontextPage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/fcontextPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,158 @@
|
@@ -0,0 +1,158 @@
|
||||||
+## fcontextPage.py - show selinux mappings
|
+## fcontextPage.py - show selinux mappings
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -440,9 +440,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ self.store.set_value(iter, 0, fspec)
|
+ self.store.set_value(iter, 0, fspec)
|
||||||
+ self.store.set_value(iter, 2, ftype)
|
+ self.store.set_value(iter, 2, ftype)
|
||||||
+ self.store.set_value(iter, 1, "system_u:object_r:%s:%s" % (type, mls))
|
+ self.store.set_value(iter, 1, "system_u:object_r:%s:%s" % (type, mls))
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-1.33.4/gui/loginsPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-1.33.5/gui/loginsPage.py
|
||||||
--- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/loginsPage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/loginsPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,161 @@
|
@@ -0,0 +1,161 @@
|
||||||
+## loginsPage.py - show selinux mappings
|
+## loginsPage.py - show selinux mappings
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -605,9 +605,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ self.store.set_value(iter, 1, seuser)
|
+ self.store.set_value(iter, 1, seuser)
|
||||||
+ self.store.set_value(iter, 2, seobject.translate(serange))
|
+ self.store.set_value(iter, 2, seobject.translate(serange))
|
||||||
+
|
+
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-1.33.4/gui/Makefile
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-1.33.5/gui/Makefile
|
||||||
--- nsapolicycoreutils/gui/Makefile 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/Makefile 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/Makefile 2006-11-24 08:54:13.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/Makefile 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,30 @@
|
@@ -0,0 +1,30 @@
|
||||||
+# Installation directories.
|
+# Installation directories.
|
||||||
+PREFIX ?= ${DESTDIR}/usr
|
+PREFIX ?= ${DESTDIR}/usr
|
||||||
@ -639,9 +639,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+indent:
|
+indent:
|
||||||
+
|
+
|
||||||
+relabel:
|
+relabel:
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-1.33.4/gui/mappingsPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-1.33.5/gui/mappingsPage.py
|
||||||
--- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/mappingsPage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/mappingsPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,54 @@
|
@@ -0,0 +1,54 @@
|
||||||
+## mappingsPage.py - show selinux mappings
|
+## mappingsPage.py - show selinux mappings
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -697,9 +697,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ for k in keys:
|
+ for k in keys:
|
||||||
+ print "%-25s %-25s %-25s" % (k, dict[k][0], translate(dict[k][1]))
|
+ print "%-25s %-25s %-25s" % (k, dict[k][0], translate(dict[k][1]))
|
||||||
+
|
+
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-1.33.4/gui/modulesPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-1.33.5/gui/modulesPage.py
|
||||||
--- nsapolicycoreutils/gui/modulesPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/modulesPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/modulesPage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/modulesPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,161 @@
|
@@ -0,0 +1,161 @@
|
||||||
+## modulesPage.py - show selinux mappings
|
+## modulesPage.py - show selinux mappings
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -862,9 +862,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+
|
+
|
||||||
+
|
+
|
||||||
+
|
+
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-1.33.4/gui/portsPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-1.33.5/gui/portsPage.py
|
||||||
--- nsapolicycoreutils/gui/portsPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/portsPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/portsPage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/portsPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,214 @@
|
@@ -0,0 +1,214 @@
|
||||||
+## portsPage.py - show selinux mappings
|
+## portsPage.py - show selinux mappings
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -1080,9 +1080,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ self.store.set_value(iter, MLS_COL, mls)
|
+ self.store.set_value(iter, MLS_COL, mls)
|
||||||
+
|
+
|
||||||
+
|
+
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-1.33.4/gui/selinux.tbl
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-1.33.5/gui/selinux.tbl
|
||||||
--- nsapolicycoreutils/gui/selinux.tbl 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/selinux.tbl 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/selinux.tbl 2006-11-24 08:46:20.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/selinux.tbl 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,265 @@
|
@@ -0,0 +1,265 @@
|
||||||
+acct_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for acct daemon")
|
+acct_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for acct daemon")
|
||||||
+allow_cvs_read_shadow _("CVS") _("Allow cvs daemon to read shadow")
|
+allow_cvs_read_shadow _("CVS") _("Allow cvs daemon to read shadow")
|
||||||
@ -1349,9 +1349,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ypserv_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for ypserv daemon")
|
+ypserv_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for ypserv daemon")
|
||||||
+ypxfr_disable_trans _("NIS") _("Disable SELinux protection for NIS Transfer Daemon")
|
+ypxfr_disable_trans _("NIS") _("Disable SELinux protection for NIS Transfer Daemon")
|
||||||
+zebra_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for zebra daemon")
|
+zebra_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for zebra daemon")
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-1.33.4/gui/semanagePage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-1.33.5/gui/semanagePage.py
|
||||||
--- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/semanagePage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/semanagePage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,109 @@
|
@@ -0,0 +1,109 @@
|
||||||
+## semanagePage.py - show selinux mappings
|
+## semanagePage.py - show selinux mappings
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -1462,9 +1462,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ self.dialog.hide()
|
+ self.dialog.hide()
|
||||||
+
|
+
|
||||||
+
|
+
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-1.33.4/gui/statusPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-1.33.5/gui/statusPage.py
|
||||||
--- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/statusPage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/statusPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,213 @@
|
@@ -0,0 +1,213 @@
|
||||||
+## statusPage.py - show selinux status
|
+## statusPage.py - show selinux status
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -1679,9 +1679,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ return self.types[self.selinuxTypeOptionMenu.get_active()]
|
+ return self.types[self.selinuxTypeOptionMenu.get_active()]
|
||||||
+
|
+
|
||||||
+
|
+
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-1.33.4/gui/system-config-selinux.glade
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-1.33.5/gui/system-config-selinux.glade
|
||||||
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/system-config-selinux.glade 2006-11-24 17:16:19.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/system-config-selinux.glade 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,2803 @@
|
@@ -0,0 +1,2803 @@
|
||||||
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
|
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
|
||||||
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
|
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
|
||||||
@ -4486,9 +4486,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+</widget>
|
+</widget>
|
||||||
+
|
+
|
||||||
+</glade-interface>
|
+</glade-interface>
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-1.33.4/gui/system-config-selinux.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-1.33.5/gui/system-config-selinux.py
|
||||||
--- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/system-config-selinux.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/system-config-selinux.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,156 @@
|
@@ -0,0 +1,156 @@
|
||||||
+#!/usr/bin/python
|
+#!/usr/bin/python
|
||||||
+#
|
+#
|
||||||
@ -4646,9 +4646,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+
|
+
|
||||||
+ app = childWindow()
|
+ app = childWindow()
|
||||||
+ app.stand_alone()
|
+ app.stand_alone()
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-1.33.4/gui/translationsPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-1.33.5/gui/translationsPage.py
|
||||||
--- nsapolicycoreutils/gui/translationsPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/translationsPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/translationsPage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/translationsPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,109 @@
|
@@ -0,0 +1,109 @@
|
||||||
+## translationsPage.py - show selinux translations
|
+## translationsPage.py - show selinux translations
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -4759,9 +4759,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ store, iter = self.view.get_selection().get_selected()
|
+ store, iter = self.view.get_selection().get_selected()
|
||||||
+ self.store.set_value(iter, 0, level)
|
+ self.store.set_value(iter, 0, level)
|
||||||
+ self.store.set_value(iter, 1, translation)
|
+ self.store.set_value(iter, 1, translation)
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-1.33.4/gui/usersPage.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-1.33.5/gui/usersPage.py
|
||||||
--- nsapolicycoreutils/gui/usersPage.py 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/gui/usersPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/gui/usersPage.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/gui/usersPage.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -0,0 +1,155 @@
|
@@ -0,0 +1,155 @@
|
||||||
+## usersPage.py - show selinux mappings
|
+## usersPage.py - show selinux mappings
|
||||||
+## Copyright (C) 2006 Red Hat, Inc.
|
+## Copyright (C) 2006 Red Hat, Inc.
|
||||||
@ -4918,18 +4918,39 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
+ except ValueError, e:
|
+ except ValueError, e:
|
||||||
+ self.error(e.args[0])
|
+ self.error(e.args[0])
|
||||||
+
|
+
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.33.4/Makefile
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/load_policy/load_policy.c policycoreutils-1.33.5/load_policy/load_policy.c
|
||||||
|
--- nsapolicycoreutils/load_policy/load_policy.c 2006-11-16 17:14:31.000000000 -0500
|
||||||
|
+++ policycoreutils-1.33.5/load_policy/load_policy.c 2006-11-28 10:44:25.000000000 -0500
|
||||||
|
@@ -50,12 +50,12 @@
|
||||||
|
nargs = argc - optind;
|
||||||
|
if (nargs > 2)
|
||||||
|
usage(argv[0]);
|
||||||
|
- if (nargs >= 1) {
|
||||||
|
- fprintf(stderr,
|
||||||
|
- "%s: Warning! Policy file argument (%s) is no longer supported, installed policy is always loaded. Continuing...\n",
|
||||||
|
- argv[0], argv[optind++]);
|
||||||
|
+ if (nargs >= 1 && !quiet) {
|
||||||
|
+ fprintf(stderr,
|
||||||
|
+ "%s: Warning! Policy file argument (%s) is no longer supported, installed policy is always loaded. Continuing...\n",
|
||||||
|
+ argv[0], argv[optind++]);
|
||||||
|
}
|
||||||
|
- if (nargs == 2) {
|
||||||
|
+ if (nargs == 2 && ! quiet) {
|
||||||
|
fprintf(stderr,
|
||||||
|
"%s: Warning! Boolean file argument (%s) is no longer supported, installed booleans file is always used. Continuing...\n",
|
||||||
|
argv[0], argv[optind++]);
|
||||||
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.33.5/Makefile
|
||||||
--- nsapolicycoreutils/Makefile 2006-11-16 17:15:00.000000000 -0500
|
--- nsapolicycoreutils/Makefile 2006-11-16 17:15:00.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/Makefile 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/Makefile 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||||
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||||
|
|
||||||
all install relabel clean indent:
|
all install relabel clean indent:
|
||||||
@for subdir in $(SUBDIRS); do \
|
@for subdir in $(SUBDIRS); do \
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/newrole/newrole.c policycoreutils-1.33.4/newrole/newrole.c
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/newrole/newrole.c policycoreutils-1.33.5/newrole/newrole.c
|
||||||
--- nsapolicycoreutils/newrole/newrole.c 2006-11-20 12:19:55.000000000 -0500
|
--- nsapolicycoreutils/newrole/newrole.c 2006-11-20 12:19:55.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/newrole/newrole.c 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/newrole/newrole.c 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -1068,11 +1068,16 @@
|
@@ -1068,11 +1068,16 @@
|
||||||
*/
|
*/
|
||||||
int rc;
|
int rc;
|
||||||
@ -4948,9 +4969,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
if (restore_tty_label(fd, ttyn, tty_context, new_tty_context)) {
|
if (restore_tty_label(fd, ttyn, tty_context, new_tty_context)) {
|
||||||
fprintf(stderr, _("Unable to restore tty label...\n"));
|
fprintf(stderr, _("Unable to restore tty label...\n"));
|
||||||
exit_code = -1;
|
exit_code = -1;
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/run_init/run_init.c policycoreutils-1.33.4/run_init/run_init.c
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/run_init/run_init.c policycoreutils-1.33.5/run_init/run_init.c
|
||||||
--- nsapolicycoreutils/run_init/run_init.c 2006-11-16 17:14:27.000000000 -0500
|
--- nsapolicycoreutils/run_init/run_init.c 2006-11-16 17:14:27.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/run_init/run_init.c 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/run_init/run_init.c 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -132,6 +132,14 @@
|
@@ -132,6 +132,14 @@
|
||||||
result = 1; /* user authenticated OK! */
|
result = 1; /* user authenticated OK! */
|
||||||
}
|
}
|
||||||
@ -4966,9 +4987,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
/* We're done with PAM. Free `pam_handle'. */
|
/* We're done with PAM. Free `pam_handle'. */
|
||||||
pam_end(pam_handle, PAM_SUCCESS);
|
pam_end(pam_handle, PAM_SUCCESS);
|
||||||
|
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/semanage.8 policycoreutils-1.33.4/semanage/semanage.8
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/semanage.8 policycoreutils-1.33.5/semanage/semanage.8
|
||||||
--- nsapolicycoreutils/semanage/semanage.8 2006-11-20 12:19:55.000000000 -0500
|
--- nsapolicycoreutils/semanage/semanage.8 2006-11-20 12:19:55.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/semanage/semanage.8 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/semanage/semanage.8 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -82,9 +82,6 @@
|
@@ -82,9 +82,6 @@
|
||||||
.TP
|
.TP
|
||||||
.I \-T, \-\-trans
|
.I \-T, \-\-trans
|
||||||
@ -4979,9 +5000,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
|
|||||||
|
|
||||||
.SH EXAMPLE
|
.SH EXAMPLE
|
||||||
.nf
|
.nf
|
||||||
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.33.4/semanage/seobject.py
|
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.33.5/semanage/seobject.py
|
||||||
--- nsapolicycoreutils/semanage/seobject.py 2006-11-16 17:14:26.000000000 -0500
|
--- nsapolicycoreutils/semanage/seobject.py 2006-11-16 17:14:26.000000000 -0500
|
||||||
+++ policycoreutils-1.33.4/semanage/seobject.py 2006-11-22 14:11:25.000000000 -0500
|
+++ policycoreutils-1.33.5/semanage/seobject.py 2006-11-28 10:44:03.000000000 -0500
|
||||||
@@ -94,23 +94,25 @@
|
@@ -94,23 +94,25 @@
|
||||||
return re.search("^" + reg +"$",raw)
|
return re.search("^" + reg +"$",raw)
|
||||||
|
|
||||||
|
@ -5,7 +5,7 @@
|
|||||||
Summary: SELinux policy core utilities.
|
Summary: SELinux policy core utilities.
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 1.33.5
|
Version: 1.33.5
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||||
@ -168,6 +168,10 @@ fi
|
|||||||
[ -x /sbin/service ] && /sbin/service restorecond condrestart
|
[ -x /sbin/service ] && /sbin/service restorecond condrestart
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 28 2006 Dan Walsh <dwalsh@redhat.com> 1.33.5-2
|
||||||
|
- Fix -q qualifier on load_policy
|
||||||
|
Resolves: #214827
|
||||||
|
|
||||||
* Tue Nov 28 2006 Dan Walsh <dwalsh@redhat.com> 1.33.5-1
|
* Tue Nov 28 2006 Dan Walsh <dwalsh@redhat.com> 1.33.5-1
|
||||||
- Merge to upstream
|
- Merge to upstream
|
||||||
- Fix makefile line
|
- Fix makefile line
|
||||||
@ -196,7 +200,7 @@ Resolves: #208838
|
|||||||
- Fix display of gui
|
- Fix display of gui
|
||||||
|
|
||||||
* Thu Nov 16 2006 Dan Walsh <dwalsh@redhat.com> 1.33.1-7
|
* Thu Nov 16 2006 Dan Walsh <dwalsh@redhat.com> 1.33.1-7
|
||||||
- Add patch by Joe Plans to make run_init use pam_acct_mgmt
|
- Add patch by Jose Plans to make run_init use pam_acct_mgmt
|
||||||
|
|
||||||
* Wed Nov 15 2006 Dan Walsh <dwalsh@redhat.com> 1.33.1-6
|
* Wed Nov 15 2006 Dan Walsh <dwalsh@redhat.com> 1.33.1-6
|
||||||
- More fixes to gui
|
- More fixes to gui
|
||||||
|
Loading…
Reference in New Issue
Block a user