* Fri Mar 23 2007 Dan Walsh <dwalsh@redhat.com> 2.0.7-5
- Change location of audit2allow and sepol-ifgen to sbin - Updated version of sepolgen
This commit is contained in:
parent
9eedb8e684
commit
bb82af009d
@ -140,3 +140,4 @@ sepolgen-1.0.2.tgz
|
||||
sepolgen-1.0.3.tgz
|
||||
policycoreutils-2.0.7.tgz
|
||||
sepolgen-1.0.4.tgz
|
||||
sepolgen-1.0.6.tgz
|
||||
|
@ -1,3 +1,14 @@
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.4 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-2.0.7/audit2allow/Makefile
|
||||
--- nsapolicycoreutils/audit2allow/Makefile 2007-02-07 12:11:49.000000000 -0500
|
||||
+++ policycoreutils-2.0.7/audit2allow/Makefile 2007-03-22 16:55:49.000000000 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
# Installation directories.
|
||||
PREFIX ?= ${DESTDIR}/usr
|
||||
-BINDIR ?= $(PREFIX)/bin
|
||||
+BINDIR ?= $(PREFIX)/sbin
|
||||
LIBDIR ?= $(PREFIX)/lib
|
||||
MANDIR ?= $(PREFIX)/share/man
|
||||
LOCALEDIR ?= /usr/share/locale
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.4 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.7/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2006-11-16 17:15:00.000000000 -0500
|
||||
+++ policycoreutils-2.0.7/Makefile 2007-03-01 17:37:41.000000000 -0500
|
||||
@ -7,6 +18,22 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.4 --exclude=gui --exclude=po
|
||||
|
||||
all install relabel clean indent:
|
||||
@for subdir in $(SUBDIRS); do \
|
||||
Binary files nsapolicycoreutils/restorecon/restorecon and policycoreutils-2.0.7/restorecon/restorecon differ
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.4 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecon/restorecon.c policycoreutils-2.0.7/restorecon/restorecon.c
|
||||
--- nsapolicycoreutils/restorecon/restorecon.c 2006-11-16 17:14:26.000000000 -0500
|
||||
+++ policycoreutils-2.0.7/restorecon/restorecon.c 2007-03-22 17:33:57.000000000 -0400
|
||||
@@ -336,8 +336,8 @@
|
||||
if (!file_exist && errno == ENOENT)
|
||||
return;
|
||||
fprintf(stderr,
|
||||
- "%s: error while labeling files under %s\n",
|
||||
- progname, buf);
|
||||
+ "%s: %s: %s\n",
|
||||
+ progname, buf, strerror(errno));
|
||||
errors++;
|
||||
}
|
||||
}
|
||||
Binary files nsapolicycoreutils/restorecon/restorecon.o and policycoreutils-2.0.7/restorecon/restorecon.o differ
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.4 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.7/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-02-22 08:53:22.000000000 -0500
|
||||
+++ policycoreutils-2.0.7/restorecond/restorecond.c 2007-03-01 17:37:41.000000000 -0500
|
||||
|
@ -2,11 +2,11 @@
|
||||
%define libsepolver 2.0.1-1
|
||||
%define libsemanagever 1.10.0-1
|
||||
%define libselinuxver 2.0.0-1
|
||||
%define sepolgenver 1.0.4
|
||||
%define sepolgenver 1.0.6
|
||||
Summary: SELinux policy core utilities.
|
||||
Name: policycoreutils
|
||||
Version: 2.0.7
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -125,19 +125,19 @@ rm -rf %{buildroot}
|
||||
%{_sbindir}/semodule
|
||||
%{_sbindir}/semanage
|
||||
%{_sbindir}/load_policy
|
||||
%{_sbindir}/audit2allow
|
||||
%{_sbindir}/audit2why
|
||||
%{_sbindir}/genhomedircon
|
||||
%{_sbindir}/sepolgen-ifgen
|
||||
%{_sbindir}/sestatus
|
||||
%{_sbindir}/run_init
|
||||
%{_sbindir}/open_init_pty
|
||||
%{_bindir}/audit2allow
|
||||
%{_bindir}/chcat
|
||||
%{_bindir}/secon
|
||||
%{_bindir}/semodule_deps
|
||||
%{_bindir}/semodule_expand
|
||||
%{_bindir}/semodule_link
|
||||
%{_bindir}/semodule_package
|
||||
%{_bindir}/sepolgen-ifgen
|
||||
%{_mandir}/man8/chcat.8.gz
|
||||
%{_mandir}/man8/restorecond.8.gz
|
||||
%{_mandir}/man8/restorecon.8.gz
|
||||
@ -177,7 +177,7 @@ fi
|
||||
|
||||
%post
|
||||
/sbin/chkconfig --add restorecond
|
||||
[ -f /usr/share/selinux/devel/include/build.conf ] && /usr/bin/sepolgen-ifgen > /dev/null
|
||||
[ -f /usr/share/selinux/devel/include/build.conf ] && /usr/sbin/sepolgen-ifgen > /dev/null
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
@ -186,6 +186,10 @@ if [ "$1" -ge "1" ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Fri Mar 23 2007 Dan Walsh <dwalsh@redhat.com> 2.0.7-5
|
||||
- Change location of audit2allow and sepol-ifgen to sbin
|
||||
- Updated version of sepolgen
|
||||
|
||||
* Mon Mar 19 2007 Dan Walsh <dwalsh@redhat.com> 2.0.7-4
|
||||
- Add polgen gui
|
||||
- Many fixes to system-config-selinux
|
||||
|
Loading…
Reference in New Issue
Block a user