* Tue Dec 19 2007 Dan Walsh <dwalsh@redhat.com> 2.0.34-1
- Update to upstream * Tue Dec 19 2007 Dan Walsh <dwalsh@redhat.com> 2.0.33-4 - Fix sepolgen to be able to parse Fedora 9 policy Handle ifelse statements Handle refpolicywarn inside of define Add init.if and inetd.if into parse Add parse_file to syntax error message
This commit is contained in:
parent
e61ad2382c
commit
bac931cd73
@ -165,3 +165,4 @@ policycoreutils-2.0.29.tgz
|
|||||||
policycoreutils-2.0.31.tgz
|
policycoreutils-2.0.31.tgz
|
||||||
policycoreutils-2.0.32.tgz
|
policycoreutils-2.0.32.tgz
|
||||||
policycoreutils-2.0.33.tgz
|
policycoreutils-2.0.33.tgz
|
||||||
|
policycoreutils-2.0.34.tgz
|
||||||
|
@ -1,6 +1,36 @@
|
|||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2why.c policycoreutils-2.0.32/audit2why/audit2why.c
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-2.0.34/audit2allow/audit2allow
|
||||||
|
--- nsapolicycoreutils/audit2allow/audit2allow 2007-07-16 14:20:41.000000000 -0400
|
||||||
|
+++ policycoreutils-2.0.34/audit2allow/audit2allow 2007-12-19 06:05:50.000000000 -0500
|
||||||
|
@@ -60,7 +60,9 @@
|
||||||
|
parser.add_option("-o", "--output", dest="output",
|
||||||
|
help="append output to <filename>, conflicts with -M")
|
||||||
|
parser.add_option("-R", "--reference", action="store_true", dest="refpolicy",
|
||||||
|
- default=False, help="generate refpolicy style output")
|
||||||
|
+ default=True, help="generate refpolicy style output")
|
||||||
|
+ parser.add_option("-N", "--noreference", action="store_false", dest="refpolicy",
|
||||||
|
+ default=False, help="do not generate refpolicy style output")
|
||||||
|
parser.add_option("-v", "--verbose", action="store_true", dest="verbose",
|
||||||
|
default=False, help="explain generated output")
|
||||||
|
parser.add_option("-e", "--explain", action="store_true", dest="explain_long",
|
||||||
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/audit2allow.1 policycoreutils-2.0.34/audit2allow/audit2allow.1
|
||||||
|
--- nsapolicycoreutils/audit2allow/audit2allow.1 2007-07-16 14:20:41.000000000 -0400
|
||||||
|
+++ policycoreutils-2.0.34/audit2allow/audit2allow.1 2007-12-19 06:05:50.000000000 -0500
|
||||||
|
@@ -65,8 +65,11 @@
|
||||||
|
.B "\-r" | "\-\-requires"
|
||||||
|
Generate require output syntax for loadable modules.
|
||||||
|
.TP
|
||||||
|
+.B "\-N" | "\-\-noreference"
|
||||||
|
+Do not generate reference policy, traditional style allow rules.
|
||||||
|
+.TP
|
||||||
|
.B "\-R" | "\-\-reference"
|
||||||
|
-Generate reference policy using installed macros. Requires the selinux-policy-devel package.
|
||||||
|
+Generate reference policy using installed macros.Default
|
||||||
|
.TP
|
||||||
|
.B "\-t " | "\-\-tefile"
|
||||||
|
Indicates input file is a te (type enforcement) file. This can be used to translate old te format to new policy format.
|
||||||
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2why/audit2why.c policycoreutils-2.0.34/audit2why/audit2why.c
|
||||||
--- nsapolicycoreutils/audit2why/audit2why.c 2007-07-16 14:20:41.000000000 -0400
|
--- nsapolicycoreutils/audit2why/audit2why.c 2007-07-16 14:20:41.000000000 -0400
|
||||||
+++ policycoreutils-2.0.32/audit2why/audit2why.c 2007-12-02 20:29:15.000000000 -0500
|
+++ policycoreutils-2.0.34/audit2why/audit2why.c 2007-12-19 06:05:50.000000000 -0500
|
||||||
@@ -137,6 +137,8 @@
|
@@ -137,6 +137,8 @@
|
||||||
/* Process the audit messages. */
|
/* Process the audit messages. */
|
||||||
while (getline(&buffer, &len, stdin) > 0) {
|
while (getline(&buffer, &len, stdin) > 0) {
|
||||||
@ -97,18 +127,18 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
if (!tclass) {
|
if (!tclass) {
|
||||||
fprintf(stderr,
|
fprintf(stderr,
|
||||||
"Invalid %s%s on line %u, skipping...\n",
|
"Invalid %s%s on line %u, skipping...\n",
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.32/Makefile
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.34/Makefile
|
||||||
--- nsapolicycoreutils/Makefile 2007-07-16 14:20:43.000000000 -0400
|
--- nsapolicycoreutils/Makefile 2007-12-19 06:02:52.000000000 -0500
|
||||||
+++ policycoreutils-2.0.32/Makefile 2007-12-02 20:29:15.000000000 -0500
|
+++ policycoreutils-2.0.34/Makefile 2007-12-19 06:06:04.000000000 -0500
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
-SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||||
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
+SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||||
|
|
||||||
all install relabel clean indent:
|
INOTIFYH = $(shell ls /usr/include/sys/inotify.h 2>/dev/null)
|
||||||
@for subdir in $(SUBDIRS); do \
|
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.32/restorecond/restorecond.c
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.34/restorecond/restorecond.c
|
||||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
||||||
+++ policycoreutils-2.0.32/restorecond/restorecond.c 2007-12-02 20:29:15.000000000 -0500
|
+++ policycoreutils-2.0.34/restorecond/restorecond.c 2007-12-19 06:05:50.000000000 -0500
|
||||||
@@ -210,9 +210,10 @@
|
@@ -210,9 +210,10 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -135,9 +165,9 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
}
|
}
|
||||||
free(scontext);
|
free(scontext);
|
||||||
close(fd);
|
close(fd);
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.32/scripts/chcat
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.34/scripts/chcat
|
||||||
--- nsapolicycoreutils/scripts/chcat 2007-08-23 16:52:26.000000000 -0400
|
--- nsapolicycoreutils/scripts/chcat 2007-08-23 16:52:26.000000000 -0400
|
||||||
+++ policycoreutils-2.0.32/scripts/chcat 2007-12-02 20:29:15.000000000 -0500
|
+++ policycoreutils-2.0.34/scripts/chcat 2007-12-19 06:05:50.000000000 -0500
|
||||||
@@ -25,10 +25,6 @@
|
@@ -25,10 +25,6 @@
|
||||||
import commands, sys, os, pwd, string, getopt, selinux
|
import commands, sys, os, pwd, string, getopt, selinux
|
||||||
import seobject
|
import seobject
|
||||||
@ -149,9 +179,9 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po
|
|||||||
|
|
||||||
try:
|
try:
|
||||||
gettext.install('policycoreutils')
|
gettext.install('policycoreutils')
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.32/semanage/semanage
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.34/semanage/semanage
|
||||||
--- nsapolicycoreutils/semanage/semanage 2007-10-05 13:09:53.000000000 -0400
|
--- nsapolicycoreutils/semanage/semanage 2007-10-05 13:09:53.000000000 -0400
|
||||||
+++ policycoreutils-2.0.32/semanage/semanage 2007-12-02 20:29:15.000000000 -0500
|
+++ policycoreutils-2.0.34/semanage/semanage 2007-12-19 06:05:50.000000000 -0500
|
||||||
@@ -1,5 +1,5 @@
|
@@ -1,5 +1,5 @@
|
||||||
#! /usr/bin/python -E
|
#! /usr/bin/python -E
|
||||||
-# Copyright (C) 2005 Red Hat
|
-# Copyright (C) 2005 Red Hat
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff --exclude-from=exclude -N -u -r nsasepolgen/src/sepolgen/refparser.py policycoreutils-2.0.32/sepolgen-1.0.10/src/sepolgen/refparser.py
|
diff --exclude-from=exclude -N -u -r nsasepolgen/src/sepolgen/refparser.py policycoreutils-2.0.34/sepolgen-1.0.10/src/sepolgen/refparser.py
|
||||||
--- nsasepolgen/src/sepolgen/refparser.py 2007-09-13 08:21:11.000000000 -0400
|
--- nsasepolgen/src/sepolgen/refparser.py 2007-09-13 08:21:11.000000000 -0400
|
||||||
+++ policycoreutils-2.0.32/sepolgen-1.0.10/src/sepolgen/refparser.py 2007-12-19 05:21:44.000000000 -0500
|
+++ policycoreutils-2.0.34/sepolgen-1.0.10/src/sepolgen/refparser.py 2007-12-19 06:05:51.000000000 -0500
|
||||||
@@ -118,6 +118,7 @@
|
@@ -118,6 +118,7 @@
|
||||||
'TEMPLATE',
|
'TEMPLATE',
|
||||||
'GEN_CONTEXT',
|
'GEN_CONTEXT',
|
||||||
|
@ -5,8 +5,8 @@
|
|||||||
%define sepolgenver 1.0.10
|
%define sepolgenver 1.0.10
|
||||||
Summary: SELinux policy core utilities
|
Summary: SELinux policy core utilities
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 2.0.33
|
Version: 2.0.34
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||||
@ -193,6 +193,8 @@ if [ "$1" -ge "1" ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 19 2007 Dan Walsh <dwalsh@redhat.com> 2.0.34-1
|
||||||
|
- Update to upstream
|
||||||
* Tue Dec 19 2007 Dan Walsh <dwalsh@redhat.com> 2.0.33-4
|
* Tue Dec 19 2007 Dan Walsh <dwalsh@redhat.com> 2.0.33-4
|
||||||
- Fix sepolgen to be able to parse Fedora 9 policy
|
- Fix sepolgen to be able to parse Fedora 9 policy
|
||||||
Handle ifelse statements
|
Handle ifelse statements
|
||||||
|
Loading…
Reference in New Issue
Block a user