Don't require /usr/share/selinux/devel/Makefile to build permissive domains

This commit is contained in:
Dan Walsh 2014-01-08 11:20:05 -05:00
parent b9afd68089
commit b371ba3420
2 changed files with 8 additions and 11 deletions

View File

@ -658735,10 +658735,10 @@ index f8d2243..0000000
- print "%-30s (%-5s,%5s) %s" % (k, on_off[selinux.security_get_boolean_active(k)], on_off[ddict[k][2]], self.get_desc(k))
diff --git a/policycoreutils/semanage/seobject/__init__.py b/policycoreutils/semanage/seobject/__init__.py
new file mode 100644
index 0000000..a71225b
index 0000000..08bf736
--- /dev/null
+++ b/policycoreutils/semanage/seobject/__init__.py
@@ -0,0 +1,2243 @@
@@ -0,0 +1,2237 @@
+#! /usr/bin/python -Es
+# Copyright (C) 2005-2013 Red Hat
+# see file 'COPYING' for use and warranty information
@ -659181,8 +659181,8 @@ index 0000000..a71225b
+ fd.write(modtxt)
+ fd.close()
+ mc = module.ModuleCompiler()
+ mc.create_module_package(filename, 1)
+ fd = open("permissive_%s.pp" % setype)
+ mc.create_module_package(filename, False)
+ fd = open("%s.pp" % name)
+ data = fd.read()
+ fd.close()
+
@ -659190,12 +659190,6 @@ index 0000000..a71225b
+ if rc >= 0:
+ self.commit()
+
+ for root, dirs, files in os.walk("tmp", topdown = False):
+ for name in files:
+ os.remove(os.path.join(root, name))
+ for name in dirs:
+ os.rmdir(os.path.join(root, name))
+ os.removedirs("tmp")
+ for i in glob.glob("permissive_%s.*" % setype):
+ os.remove(i)
+ if rc < 0:

View File

@ -7,7 +7,7 @@
Summary: SELinux policy core utilities
Name: policycoreutils
Version: 2.2.5
Release: 1%{?dist}
Release: 2%{?dist}
License: GPLv2
Group: System Environment/Base
# Based on git repository with tag 20101221
@ -383,6 +383,9 @@ The policycoreutils-restorecond package contains the restorecond service.
%systemd_postun_with_restart restorecond.service
%changelog
* Wed Jan 8 2014 Dan Walsh <dwalsh@redhat.com> - 2.2.5-2
- Don't require /usr/share/selinux/devel/Makefile to build permissive domains
* Mon Jan 6 2014 Dan Walsh <dwalsh@redhat.com> - 2.2.5-1
- Update to upstream
* Ignore selevel/serange if MLS is disabled from Sven Vermeulen.