Add Miroslav patch to
- Fix previously_modified_initialize() to show modified changes properly for all selections
This commit is contained in:
parent
16f2333d36
commit
a3dfb2e273
@ -663961,7 +663961,7 @@ index 6b53035..32ea970 100644
|
||||
out += "%s # %s\n" % (self.write_te(out_dir), _("Type Enforcement file"))
|
||||
out += "%s # %s\n" % (self.write_if(out_dir), _("Interface file"))
|
||||
diff --git a/policycoreutils/sepolicy/sepolicy/gui.py b/policycoreutils/sepolicy/sepolicy/gui.py
|
||||
index 94ddb72..e663e20 100644
|
||||
index 94ddb72..ac2fe31 100644
|
||||
--- a/policycoreutils/sepolicy/sepolicy/gui.py
|
||||
+++ b/policycoreutils/sepolicy/sepolicy/gui.py
|
||||
@@ -47,12 +47,15 @@ gettext.bindtextdomain(PROGNAME, "/usr/share/locale")
|
||||
@ -664393,11 +664393,13 @@ index 94ddb72..e663e20 100644
|
||||
cur = selinux.getfilecon(path)[1].split(":")[2]
|
||||
con = selinux.matchpathcon(path,0)[1].split(":")[2]
|
||||
if self.verify(_("Run restorecon on %(PATH)s to change its type from %(CUR_CONTEXT)s to the default %(DEF_CONTEXT)s?") % {"PATH":path, "CUR_CONTEXT": cur, "DEF_CONTEXT": con}, title="restorecon dialog") == Gtk.ResponseType.YES:
|
||||
+ try:
|
||||
self.dbus.restorecon(path)
|
||||
self.application_selected()
|
||||
+ except dbus.exceptions.DBusException as e:
|
||||
+ self.error(e)
|
||||
- self.dbus.restorecon(path)
|
||||
- self.application_selected()
|
||||
+ try:
|
||||
+ self.dbus.restorecon(path)
|
||||
+ self.application_selected()
|
||||
+ except dbus.exceptions.DBusException as e:
|
||||
+ self.error(e)
|
||||
|
||||
def new_updates(self, *args):
|
||||
self.update_button.set_sensitive(self.modified())
|
||||
|
@ -385,7 +385,7 @@ The policycoreutils-restorecond package contains the restorecond service.
|
||||
%changelog
|
||||
* Thu Jan 16 2014 Dan Walsh <dwalsh@redhat.com> - 2.2.5-3
|
||||
- Add Miroslav patch to
|
||||
- Fix previously_modified_initialize() to show modified changes properly for all selections
|
||||
- Fix previously_modified_initialize() to show modified changes properly for all selections
|
||||
|
||||
* Wed Jan 8 2014 Dan Walsh <dwalsh@redhat.com> - 2.2.5-2
|
||||
- Do not require /usr/share/selinux/devel/Makefile to build permissive domains
|
||||
|
Loading…
Reference in New Issue
Block a user