auto-import changelog data from policycoreutils-1.14.1-2.src.rpm
* Tue Jul 06 2004 Dan Walsh <dwalsh@redhat.com> 1.14.1-2 - Fix fixfiles.cron to not run on non SELinux boxes
This commit is contained in:
parent
a2b2c59f77
commit
a1449eece0
@ -1,5 +1,5 @@
|
|||||||
--- policycoreutils-1.14.1/scripts/Makefile.rhat 2004-06-30 12:03:27.000000000 -0400
|
--- policycoreutils-1.14.1/scripts/Makefile.rhat 2004-06-30 12:03:27.000000000 -0400
|
||||||
+++ policycoreutils-1.14.1/scripts/Makefile 2004-06-30 13:14:42.776075168 -0400
|
+++ policycoreutils-1.14.1/scripts/Makefile 2004-06-30 13:14:42.000000000 -0400
|
||||||
@@ -12,6 +12,7 @@
|
@@ -12,6 +12,7 @@
|
||||||
-mkdir -p $(BINDIR)
|
-mkdir -p $(BINDIR)
|
||||||
install -m 755 $(TARGETS) $(BINDIR)
|
install -m 755 $(TARGETS) $(BINDIR)
|
||||||
@ -8,26 +8,33 @@
|
|||||||
-mkdir -p $(MANDIR)/man8
|
-mkdir -p $(MANDIR)/man8
|
||||||
install -m 644 fixfiles.8.gz $(MANDIR)/man8/
|
install -m 644 fixfiles.8.gz $(MANDIR)/man8/
|
||||||
|
|
||||||
--- policycoreutils-1.14.1/scripts/fixfiles.cron.rhat 2004-06-30 13:12:42.062426432 -0400
|
--- policycoreutils-1.14.1/scripts/fixfiles.cron.rhat 2004-06-30 13:12:42.000000000 -0400
|
||||||
+++ policycoreutils-1.14.1/scripts/fixfiles.cron 2004-06-30 13:28:28.507544904 -0400
|
+++ policycoreutils-1.14.1/scripts/fixfiles.cron 2004-07-06 11:35:18.896372632 -0400
|
||||||
@@ -0,0 +1,15 @@
|
@@ -0,0 +1,22 @@
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
+
|
+
|
||||||
+CRONTYPE="check"
|
+CRONTYPE="check"
|
||||||
+INVALIDFILE=/var/tmp/badcontext
|
+INVALIDFILE=/var/tmp/badcontext
|
||||||
+CRONMAILTO="root"
|
+CRONMAILTO="root"
|
||||||
+
|
+
|
||||||
|
+if [ ! -e /etc/selinux/config ]; then
|
||||||
|
+ exit 1
|
||||||
|
+fi
|
||||||
|
+
|
||||||
+. /etc/selinux/config
|
+. /etc/selinux/config
|
||||||
+
|
+
|
||||||
+renice +19 -p $$ >/dev/null 2>&1
|
+/usr/bin/selinuxenabled
|
||||||
+OUTFILE=`mktemp ${INVALIDFILE}.XXXXXXXXXX` || exit 1
|
+if [ $? -eq 0 ]; then
|
||||||
+/sbin/fixfiles -o $OUTFILE $CRONTYPE
|
+ renice +19 -p $$ >/dev/null 2>&1
|
||||||
+mv -f $OUTFILE $INVALIDFILE
|
+ OUTFILE=`mktemp ${INVALIDFILE}.XXXXXXXXXX` || exit 1
|
||||||
+if [ -s $INVALIDFILE ]; then
|
+ /sbin/fixfiles -o $OUTFILE $CRONTYPE
|
||||||
+ mail ${MAILTO} -s "Invalid File Contexts" < $INVALIDFILE
|
+ mv -f $OUTFILE $INVALIDFILE
|
||||||
|
+ if [ -s $INVALIDFILE ]; then
|
||||||
|
+ mail ${MAILTO} -s "Invalid File Contexts" < $INVALIDFILE
|
||||||
|
+ fi
|
||||||
+fi
|
+fi
|
||||||
--- policycoreutils-1.14.1/scripts/fixfiles.rhat 2004-06-30 13:10:21.630775288 -0400
|
--- policycoreutils-1.14.1/scripts/fixfiles.rhat 2004-06-30 13:10:21.000000000 -0400
|
||||||
+++ policycoreutils-1.14.1/scripts/fixfiles 2004-06-30 13:11:46.932807408 -0400
|
+++ policycoreutils-1.14.1/scripts/fixfiles 2004-06-30 13:11:46.000000000 -0400
|
||||||
@@ -19,25 +19,37 @@
|
@@ -19,25 +19,37 @@
|
||||||
# You should have received a copy of the GNU General Public License
|
# You should have received a copy of the GNU General Public License
|
||||||
# along with this program; if not, write to the Free Software
|
# along with this program; if not, write to the Free Software
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: SELinux policy core utilities.
|
Summary: SELinux policy core utilities.
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 1.14.1
|
Version: 1.14.1
|
||||||
Release: 1
|
Release: 2
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||||
@ -75,6 +75,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 6 2004 Dan Walsh <dwalsh@redhat.com> 1.14.1-2
|
||||||
|
- Fix fixfiles.cron to not run on non SELinux boxes
|
||||||
|
|
||||||
* Wed Jun 30 2004 Dan Walsh <dwalsh@redhat.com> 1.14.1-1
|
* Wed Jun 30 2004 Dan Walsh <dwalsh@redhat.com> 1.14.1-1
|
||||||
- Update from NSA
|
- Update from NSA
|
||||||
- Add cron capability to fixfiles
|
- Add cron capability to fixfiles
|
||||||
|
Loading…
Reference in New Issue
Block a user