Add unit_file.py for sepolgen

This commit is contained in:
Dan Walsh 2012-02-01 08:44:52 -05:00
parent d4088bfa91
commit a0ea1de748
3 changed files with 169 additions and 77 deletions

View File

@ -1,6 +1,6 @@
diff -up policycoreutils-2.1.10/gui/booleansPage.py.gui policycoreutils-2.1.10/gui/booleansPage.py
--- policycoreutils-2.1.10/gui/booleansPage.py.gui 2012-01-15 16:48:40.225095742 -0500
+++ policycoreutils-2.1.10/gui/booleansPage.py 2012-01-15 16:48:40.225095742 -0500
--- policycoreutils-2.1.10/gui/booleansPage.py.gui 2012-02-01 08:39:50.132218033 -0500
+++ policycoreutils-2.1.10/gui/booleansPage.py 2012-02-01 08:39:50.132218033 -0500
@@ -0,0 +1,247 @@
+#
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel
@ -250,8 +250,8 @@ diff -up policycoreutils-2.1.10/gui/booleansPage.py.gui policycoreutils-2.1.10/g
+ return True
+
diff -up policycoreutils-2.1.10/gui/domainsPage.py.gui policycoreutils-2.1.10/gui/domainsPage.py
--- policycoreutils-2.1.10/gui/domainsPage.py.gui 2012-01-15 16:48:40.225095742 -0500
+++ policycoreutils-2.1.10/gui/domainsPage.py 2012-01-15 16:48:40.225095742 -0500
--- policycoreutils-2.1.10/gui/domainsPage.py.gui 2012-02-01 08:39:50.132218033 -0500
+++ policycoreutils-2.1.10/gui/domainsPage.py 2012-02-01 08:39:50.132218033 -0500
@@ -0,0 +1,154 @@
+## domainsPage.py - show selinux domains
+## Copyright (C) 2009 Red Hat, Inc.
@ -408,8 +408,8 @@ diff -up policycoreutils-2.1.10/gui/domainsPage.py.gui policycoreutils-2.1.10/gu
+ except ValueError, e:
+ self.error(e.args[0])
diff -up policycoreutils-2.1.10/gui/fcontextPage.py.gui policycoreutils-2.1.10/gui/fcontextPage.py
--- policycoreutils-2.1.10/gui/fcontextPage.py.gui 2012-01-15 16:48:40.226095742 -0500
+++ policycoreutils-2.1.10/gui/fcontextPage.py 2012-01-15 16:48:40.226095742 -0500
--- policycoreutils-2.1.10/gui/fcontextPage.py.gui 2012-02-01 08:39:50.133218034 -0500
+++ policycoreutils-2.1.10/gui/fcontextPage.py 2012-02-01 08:39:50.133218034 -0500
@@ -0,0 +1,223 @@
+## fcontextPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -635,8 +635,8 @@ diff -up policycoreutils-2.1.10/gui/fcontextPage.py.gui policycoreutils-2.1.10/g
+ self.store.set_value(iter, FTYPE_COL, ftype)
+ self.store.set_value(iter, TYPE_COL, "%s:%s" % (type, mls))
diff -up policycoreutils-2.1.10/gui/html_util.py.gui policycoreutils-2.1.10/gui/html_util.py
--- policycoreutils-2.1.10/gui/html_util.py.gui 2012-01-15 16:48:40.226095742 -0500
+++ policycoreutils-2.1.10/gui/html_util.py 2012-01-15 16:48:40.226095742 -0500
--- policycoreutils-2.1.10/gui/html_util.py.gui 2012-02-01 08:39:50.134218035 -0500
+++ policycoreutils-2.1.10/gui/html_util.py 2012-02-01 08:39:50.134218035 -0500
@@ -0,0 +1,164 @@
+# Authors: John Dennis <jdennis@redhat.com>
+#
@ -803,8 +803,8 @@ diff -up policycoreutils-2.1.10/gui/html_util.py.gui policycoreutils-2.1.10/gui/
+ return doc
+
diff -up policycoreutils-2.1.10/gui/lockdown.glade.gui policycoreutils-2.1.10/gui/lockdown.glade
--- policycoreutils-2.1.10/gui/lockdown.glade.gui 2012-01-15 16:48:40.226095742 -0500
+++ policycoreutils-2.1.10/gui/lockdown.glade 2012-01-15 16:48:40.226095742 -0500
--- policycoreutils-2.1.10/gui/lockdown.glade.gui 2012-02-01 08:39:50.135218036 -0500
+++ policycoreutils-2.1.10/gui/lockdown.glade 2012-02-01 08:39:50.135218036 -0500
@@ -0,0 +1,771 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
@ -1578,8 +1578,8 @@ diff -up policycoreutils-2.1.10/gui/lockdown.glade.gui policycoreutils-2.1.10/gu
+
+</glade-interface>
diff -up policycoreutils-2.1.10/gui/lockdown.gladep.gui policycoreutils-2.1.10/gui/lockdown.gladep
--- policycoreutils-2.1.10/gui/lockdown.gladep.gui 2012-01-15 16:48:40.226095742 -0500
+++ policycoreutils-2.1.10/gui/lockdown.gladep 2012-01-15 16:48:40.226095742 -0500
--- policycoreutils-2.1.10/gui/lockdown.gladep.gui 2012-02-01 08:39:50.135218036 -0500
+++ policycoreutils-2.1.10/gui/lockdown.gladep 2012-02-01 08:39:50.135218036 -0500
@@ -0,0 +1,7 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-project SYSTEM "http://glade.gnome.org/glade-project-2.0.dtd">
@ -1589,8 +1589,8 @@ diff -up policycoreutils-2.1.10/gui/lockdown.gladep.gui policycoreutils-2.1.10/g
+ <program_name></program_name>
+</glade-project>
diff -up policycoreutils-2.1.10/gui/lockdown.py.gui policycoreutils-2.1.10/gui/lockdown.py
--- policycoreutils-2.1.10/gui/lockdown.py.gui 2012-01-15 16:48:40.227095742 -0500
+++ policycoreutils-2.1.10/gui/lockdown.py 2012-01-15 16:48:40.227095742 -0500
--- policycoreutils-2.1.10/gui/lockdown.py.gui 2012-02-01 08:39:50.136218037 -0500
+++ policycoreutils-2.1.10/gui/lockdown.py 2012-02-01 08:39:50.136218037 -0500
@@ -0,0 +1,375 @@
+#!/usr/bin/python
+#
@ -1968,8 +1968,8 @@ diff -up policycoreutils-2.1.10/gui/lockdown.py.gui policycoreutils-2.1.10/gui/l
+ app = booleanWindow()
+ app.stand_alone()
diff -up policycoreutils-2.1.10/gui/loginsPage.py.gui policycoreutils-2.1.10/gui/loginsPage.py
--- policycoreutils-2.1.10/gui/loginsPage.py.gui 2012-01-15 16:48:40.227095742 -0500
+++ policycoreutils-2.1.10/gui/loginsPage.py 2012-01-15 16:48:40.227095742 -0500
--- policycoreutils-2.1.10/gui/loginsPage.py.gui 2012-02-01 08:39:50.137218037 -0500
+++ policycoreutils-2.1.10/gui/loginsPage.py 2012-02-01 08:39:50.137218037 -0500
@@ -0,0 +1,185 @@
+## loginsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -2157,8 +2157,8 @@ diff -up policycoreutils-2.1.10/gui/loginsPage.py.gui policycoreutils-2.1.10/gui
+ self.store.set_value(iter, 2, seobject.translate(serange))
+
diff -up policycoreutils-2.1.10/gui/Makefile.gui policycoreutils-2.1.10/gui/Makefile
--- policycoreutils-2.1.10/gui/Makefile.gui 2012-01-15 16:48:40.227095742 -0500
+++ policycoreutils-2.1.10/gui/Makefile 2012-01-15 16:48:40.227095742 -0500
--- policycoreutils-2.1.10/gui/Makefile.gui 2012-02-01 08:39:50.137218037 -0500
+++ policycoreutils-2.1.10/gui/Makefile 2012-02-01 08:39:50.138218037 -0500
@@ -0,0 +1,40 @@
+# Installation directories.
+PREFIX ?= ${DESTDIR}/usr
@ -2201,8 +2201,8 @@ diff -up policycoreutils-2.1.10/gui/Makefile.gui policycoreutils-2.1.10/gui/Make
+
+relabel:
diff -up policycoreutils-2.1.10/gui/mappingsPage.py.gui policycoreutils-2.1.10/gui/mappingsPage.py
--- policycoreutils-2.1.10/gui/mappingsPage.py.gui 2012-01-15 16:48:40.227095742 -0500
+++ policycoreutils-2.1.10/gui/mappingsPage.py 2012-01-15 16:48:40.227095742 -0500
--- policycoreutils-2.1.10/gui/mappingsPage.py.gui 2012-02-01 08:39:50.138218037 -0500
+++ policycoreutils-2.1.10/gui/mappingsPage.py 2012-02-01 08:39:50.138218037 -0500
@@ -0,0 +1,56 @@
+## mappingsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -2261,8 +2261,8 @@ diff -up policycoreutils-2.1.10/gui/mappingsPage.py.gui policycoreutils-2.1.10/g
+ print "%-25s %-25s %-25s" % (k, dict[k][0], translate(dict[k][1]))
+
diff -up policycoreutils-2.1.10/gui/modulesPage.py.gui policycoreutils-2.1.10/gui/modulesPage.py
--- policycoreutils-2.1.10/gui/modulesPage.py.gui 2012-01-15 16:48:40.227095742 -0500
+++ policycoreutils-2.1.10/gui/modulesPage.py 2012-01-15 16:48:40.227095742 -0500
--- policycoreutils-2.1.10/gui/modulesPage.py.gui 2012-02-01 08:39:50.138218037 -0500
+++ policycoreutils-2.1.10/gui/modulesPage.py 2012-02-01 08:39:50.139218038 -0500
@@ -0,0 +1,190 @@
+## modulesPage.py - show selinux mappings
+## Copyright (C) 2006-2009 Red Hat, Inc.
@ -2455,8 +2455,8 @@ diff -up policycoreutils-2.1.10/gui/modulesPage.py.gui policycoreutils-2.1.10/gu
+ except ValueError, e:
+ self.error(e.args[0])
diff -up policycoreutils-2.1.10/gui/polgen.glade.gui policycoreutils-2.1.10/gui/polgen.glade
--- policycoreutils-2.1.10/gui/polgen.glade.gui 2012-01-15 16:48:40.229095742 -0500
+++ policycoreutils-2.1.10/gui/polgen.glade 2012-01-15 16:48:40.229095742 -0500
--- policycoreutils-2.1.10/gui/polgen.glade.gui 2012-02-01 08:39:50.141218040 -0500
+++ policycoreutils-2.1.10/gui/polgen.glade 2012-02-01 08:39:50.142218041 -0500
@@ -0,0 +1,3432 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
@ -5891,8 +5891,8 @@ diff -up policycoreutils-2.1.10/gui/polgen.glade.gui policycoreutils-2.1.10/gui/
+
+</glade-interface>
diff -up policycoreutils-2.1.10/gui/polgen.gladep.gui policycoreutils-2.1.10/gui/polgen.gladep
--- policycoreutils-2.1.10/gui/polgen.gladep.gui 2012-01-15 16:48:40.229095742 -0500
+++ policycoreutils-2.1.10/gui/polgen.gladep 2012-01-15 16:48:40.229095742 -0500
--- policycoreutils-2.1.10/gui/polgen.gladep.gui 2012-02-01 08:39:50.143218042 -0500
+++ policycoreutils-2.1.10/gui/polgen.gladep 2012-02-01 08:39:50.143218042 -0500
@@ -0,0 +1,7 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-project SYSTEM "http://glade.gnome.org/glade-project-2.0.dtd">
@ -5902,8 +5902,8 @@ diff -up policycoreutils-2.1.10/gui/polgen.gladep.gui policycoreutils-2.1.10/gui
+ <program_name></program_name>
+</glade-project>
diff -up policycoreutils-2.1.10/gui/polgengui.py.gui policycoreutils-2.1.10/gui/polgengui.py
--- policycoreutils-2.1.10/gui/polgengui.py.gui 2012-01-15 16:48:40.230095742 -0500
+++ policycoreutils-2.1.10/gui/polgengui.py 2012-01-15 16:48:40.230095742 -0500
--- policycoreutils-2.1.10/gui/polgengui.py.gui 2012-02-01 08:39:50.144218043 -0500
+++ policycoreutils-2.1.10/gui/polgengui.py 2012-02-01 08:39:50.144218043 -0500
@@ -0,0 +1,750 @@
+#!/usr/bin/python -Es
+#
@ -6656,8 +6656,8 @@ diff -up policycoreutils-2.1.10/gui/polgengui.py.gui policycoreutils-2.1.10/gui/
+ app = childWindow()
+ app.stand_alone()
diff -up policycoreutils-2.1.10/gui/polgen.py.gui policycoreutils-2.1.10/gui/polgen.py
--- policycoreutils-2.1.10/gui/polgen.py.gui 2012-01-15 16:48:40.230095742 -0500
+++ policycoreutils-2.1.10/gui/polgen.py 2012-01-15 16:49:37.290099123 -0500
--- policycoreutils-2.1.10/gui/polgen.py.gui 2012-02-01 08:39:50.145218044 -0500
+++ policycoreutils-2.1.10/gui/polgen.py 2012-02-01 08:39:50.146218045 -0500
@@ -0,0 +1,1353 @@
+#!/usr/bin/python -Es
+#
@ -8013,8 +8013,8 @@ diff -up policycoreutils-2.1.10/gui/polgen.py.gui policycoreutils-2.1.10/gui/pol
+ except ValueError, e:
+ usage(e)
diff -up policycoreutils-2.1.10/gui/portsPage.py.gui policycoreutils-2.1.10/gui/portsPage.py
--- policycoreutils-2.1.10/gui/portsPage.py.gui 2012-01-15 16:48:40.231095742 -0500
+++ policycoreutils-2.1.10/gui/portsPage.py 2012-01-15 16:48:40.231095742 -0500
--- policycoreutils-2.1.10/gui/portsPage.py.gui 2012-02-01 08:39:50.146218045 -0500
+++ policycoreutils-2.1.10/gui/portsPage.py 2012-02-01 08:39:50.146218045 -0500
@@ -0,0 +1,259 @@
+## portsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -8276,8 +8276,8 @@ diff -up policycoreutils-2.1.10/gui/portsPage.py.gui policycoreutils-2.1.10/gui/
+ return True
+
diff -up policycoreutils-2.1.10/gui/selinux.tbl.gui policycoreutils-2.1.10/gui/selinux.tbl
--- policycoreutils-2.1.10/gui/selinux.tbl.gui 2012-01-15 16:48:40.231095742 -0500
+++ policycoreutils-2.1.10/gui/selinux.tbl 2012-01-15 16:48:40.231095742 -0500
--- policycoreutils-2.1.10/gui/selinux.tbl.gui 2012-02-01 08:39:50.147218045 -0500
+++ policycoreutils-2.1.10/gui/selinux.tbl 2012-02-01 08:39:50.147218045 -0500
@@ -0,0 +1,234 @@
+acct_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for acct daemon")
+allow_daemons_dump_core _("Admin") _("Allow all daemons to write corefiles to /")
@ -8514,8 +8514,8 @@ diff -up policycoreutils-2.1.10/gui/selinux.tbl.gui policycoreutils-2.1.10/gui/s
+webadm_read_user_files _("HTTPD Service") _("Allow SELinux webadm user to read unprivileged users home directories")
+
diff -up policycoreutils-2.1.10/gui/semanagePage.py.gui policycoreutils-2.1.10/gui/semanagePage.py
--- policycoreutils-2.1.10/gui/semanagePage.py.gui 2012-01-15 16:48:40.231095742 -0500
+++ policycoreutils-2.1.10/gui/semanagePage.py 2012-01-15 16:48:40.231095742 -0500
--- policycoreutils-2.1.10/gui/semanagePage.py.gui 2012-02-01 08:39:50.148218045 -0500
+++ policycoreutils-2.1.10/gui/semanagePage.py 2012-02-01 08:39:50.148218045 -0500
@@ -0,0 +1,168 @@
+## semanagePage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -8686,8 +8686,8 @@ diff -up policycoreutils-2.1.10/gui/semanagePage.py.gui policycoreutils-2.1.10/g
+ return True
+
diff -up policycoreutils-2.1.10/gui/statusPage.py.gui policycoreutils-2.1.10/gui/statusPage.py
--- policycoreutils-2.1.10/gui/statusPage.py.gui 2012-01-15 16:48:40.231095742 -0500
+++ policycoreutils-2.1.10/gui/statusPage.py 2012-01-15 16:48:40.231095742 -0500
--- policycoreutils-2.1.10/gui/statusPage.py.gui 2012-02-01 08:39:50.148218045 -0500
+++ policycoreutils-2.1.10/gui/statusPage.py 2012-02-01 08:39:50.149218046 -0500
@@ -0,0 +1,190 @@
+# statusPage.py - show selinux status
+## Copyright (C) 2006-2009 Red Hat, Inc.
@ -8880,8 +8880,8 @@ diff -up policycoreutils-2.1.10/gui/statusPage.py.gui policycoreutils-2.1.10/gui
+
+
diff -up policycoreutils-2.1.10/gui/system-config-selinux.glade.gui policycoreutils-2.1.10/gui/system-config-selinux.glade
--- policycoreutils-2.1.10/gui/system-config-selinux.glade.gui 2012-01-15 16:48:40.233095742 -0500
+++ policycoreutils-2.1.10/gui/system-config-selinux.glade 2012-01-15 16:48:40.233095742 -0500
--- policycoreutils-2.1.10/gui/system-config-selinux.glade.gui 2012-02-01 08:39:50.151218048 -0500
+++ policycoreutils-2.1.10/gui/system-config-selinux.glade 2012-02-01 08:39:50.151218048 -0500
@@ -0,0 +1,3024 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
@ -11908,8 +11908,8 @@ diff -up policycoreutils-2.1.10/gui/system-config-selinux.glade.gui policycoreut
+
+</glade-interface>
diff -up policycoreutils-2.1.10/gui/system-config-selinux.gladep.gui policycoreutils-2.1.10/gui/system-config-selinux.gladep
--- policycoreutils-2.1.10/gui/system-config-selinux.gladep.gui 2012-01-15 16:48:40.233095742 -0500
+++ policycoreutils-2.1.10/gui/system-config-selinux.gladep 2012-01-15 16:48:40.233095742 -0500
--- policycoreutils-2.1.10/gui/system-config-selinux.gladep.gui 2012-02-01 08:39:50.152218049 -0500
+++ policycoreutils-2.1.10/gui/system-config-selinux.gladep 2012-02-01 08:39:50.152218049 -0500
@@ -0,0 +1,7 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-project SYSTEM "http://glade.gnome.org/glade-project-2.0.dtd">
@ -11919,8 +11919,8 @@ diff -up policycoreutils-2.1.10/gui/system-config-selinux.gladep.gui policycoreu
+ <program_name></program_name>
+</glade-project>
diff -up policycoreutils-2.1.10/gui/system-config-selinux.py.gui policycoreutils-2.1.10/gui/system-config-selinux.py
--- policycoreutils-2.1.10/gui/system-config-selinux.py.gui 2012-01-15 16:48:40.233095742 -0500
+++ policycoreutils-2.1.10/gui/system-config-selinux.py 2012-01-15 16:48:40.233095742 -0500
--- policycoreutils-2.1.10/gui/system-config-selinux.py.gui 2012-02-01 08:39:50.152218049 -0500
+++ policycoreutils-2.1.10/gui/system-config-selinux.py 2012-02-01 08:39:50.153218050 -0500
@@ -0,0 +1,187 @@
+#!/usr/bin/python -Es
+#
@ -12110,8 +12110,8 @@ diff -up policycoreutils-2.1.10/gui/system-config-selinux.py.gui policycoreutils
+ app = childWindow()
+ app.stand_alone()
diff -up policycoreutils-2.1.10/gui/templates/boolean.py.gui policycoreutils-2.1.10/gui/templates/boolean.py
--- policycoreutils-2.1.10/gui/templates/boolean.py.gui 2012-01-15 16:48:40.233095742 -0500
+++ policycoreutils-2.1.10/gui/templates/boolean.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/boolean.py.gui 2012-02-01 08:39:50.153218050 -0500
+++ policycoreutils-2.1.10/gui/templates/boolean.py 2012-02-01 08:39:50.153218050 -0500
@@ -0,0 +1,40 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -12154,8 +12154,8 @@ diff -up policycoreutils-2.1.10/gui/templates/boolean.py.gui policycoreutils-2.1
+"""
+
diff -up policycoreutils-2.1.10/gui/templates/etc_rw.py.gui policycoreutils-2.1.10/gui/templates/etc_rw.py
--- policycoreutils-2.1.10/gui/templates/etc_rw.py.gui 2012-01-15 16:48:40.233095742 -0500
+++ policycoreutils-2.1.10/gui/templates/etc_rw.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/etc_rw.py.gui 2012-02-01 08:39:50.154218051 -0500
+++ policycoreutils-2.1.10/gui/templates/etc_rw.py 2012-02-01 08:39:50.154218051 -0500
@@ -0,0 +1,112 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -12270,8 +12270,8 @@ diff -up policycoreutils-2.1.10/gui/templates/etc_rw.py.gui policycoreutils-2.1.
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_etc_rw_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/templates/executable.py.gui policycoreutils-2.1.10/gui/templates/executable.py
--- policycoreutils-2.1.10/gui/templates/executable.py.gui 2012-01-15 16:48:40.233095742 -0500
+++ policycoreutils-2.1.10/gui/templates/executable.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/executable.py.gui 2012-02-01 08:39:50.155218052 -0500
+++ policycoreutils-2.1.10/gui/templates/executable.py 2012-02-01 08:39:50.155218052 -0500
@@ -0,0 +1,441 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -12715,8 +12715,8 @@ diff -up policycoreutils-2.1.10/gui/templates/executable.py.gui policycoreutils-
+EXECUTABLE -- gen_context(system_u:object_r:TEMPLATETYPE_initrc_exec_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/templates/__init__.py.gui policycoreutils-2.1.10/gui/templates/__init__.py
--- policycoreutils-2.1.10/gui/templates/__init__.py.gui 2012-01-15 16:48:40.233095742 -0500
+++ policycoreutils-2.1.10/gui/templates/__init__.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/__init__.py.gui 2012-02-01 08:39:50.155218052 -0500
+++ policycoreutils-2.1.10/gui/templates/__init__.py 2012-02-01 08:39:50.155218052 -0500
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007-2012 Red Hat
@ -12737,8 +12737,8 @@ diff -up policycoreutils-2.1.10/gui/templates/__init__.py.gui policycoreutils-2.
+#
+
diff -up policycoreutils-2.1.10/gui/templates/network.py.gui policycoreutils-2.1.10/gui/templates/network.py
--- policycoreutils-2.1.10/gui/templates/network.py.gui 2012-01-15 16:48:40.234095742 -0500
+++ policycoreutils-2.1.10/gui/templates/network.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/network.py.gui 2012-02-01 08:39:50.156218053 -0500
+++ policycoreutils-2.1.10/gui/templates/network.py 2012-02-01 08:39:50.156218053 -0500
@@ -0,0 +1,102 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -12843,8 +12843,8 @@ diff -up policycoreutils-2.1.10/gui/templates/network.py.gui policycoreutils-2.1
+"""
+
diff -up policycoreutils-2.1.10/gui/templates/rw.py.gui policycoreutils-2.1.10/gui/templates/rw.py
--- policycoreutils-2.1.10/gui/templates/rw.py.gui 2012-01-15 16:48:40.234095742 -0500
+++ policycoreutils-2.1.10/gui/templates/rw.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/rw.py.gui 2012-02-01 08:39:50.156218053 -0500
+++ policycoreutils-2.1.10/gui/templates/rw.py 2012-02-01 08:39:50.157218053 -0500
@@ -0,0 +1,129 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -12976,8 +12976,8 @@ diff -up policycoreutils-2.1.10/gui/templates/rw.py.gui policycoreutils-2.1.10/g
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_rw_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/templates/script.py.gui policycoreutils-2.1.10/gui/templates/script.py
--- policycoreutils-2.1.10/gui/templates/script.py.gui 2012-01-15 16:48:40.234095742 -0500
+++ policycoreutils-2.1.10/gui/templates/script.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/script.py.gui 2012-02-01 08:39:50.157218053 -0500
+++ policycoreutils-2.1.10/gui/templates/script.py 2012-02-01 08:39:50.157218053 -0500
@@ -0,0 +1,126 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -13106,8 +13106,8 @@ diff -up policycoreutils-2.1.10/gui/templates/script.py.gui policycoreutils-2.1.
+fi
+"""
diff -up policycoreutils-2.1.10/gui/templates/semodule.py.gui policycoreutils-2.1.10/gui/templates/semodule.py
--- policycoreutils-2.1.10/gui/templates/semodule.py.gui 2012-01-15 16:48:40.234095742 -0500
+++ policycoreutils-2.1.10/gui/templates/semodule.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/semodule.py.gui 2012-02-01 08:39:50.157218053 -0500
+++ policycoreutils-2.1.10/gui/templates/semodule.py 2012-02-01 08:39:50.158218053 -0500
@@ -0,0 +1,41 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -13151,8 +13151,8 @@ diff -up policycoreutils-2.1.10/gui/templates/semodule.py.gui policycoreutils-2.
+"""
+
diff -up policycoreutils-2.1.10/gui/templates/tmp.py.gui policycoreutils-2.1.10/gui/templates/tmp.py
--- policycoreutils-2.1.10/gui/templates/tmp.py.gui 2012-01-15 16:48:40.234095742 -0500
+++ policycoreutils-2.1.10/gui/templates/tmp.py 2012-01-15 16:48:48.559096233 -0500
--- policycoreutils-2.1.10/gui/templates/tmp.py.gui 2012-02-01 08:39:50.158218053 -0500
+++ policycoreutils-2.1.10/gui/templates/tmp.py 2012-02-01 08:39:50.158218053 -0500
@@ -0,0 +1,102 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -13256,9 +13256,82 @@ diff -up policycoreutils-2.1.10/gui/templates/tmp.py.gui policycoreutils-2.1.10/
+ files_search_tmp($1)
+ admin_pattern($1, TEMPLATETYPE_tmp_t)
+"""
diff -up policycoreutils-2.1.10/gui/templates/unit_file.py.gui policycoreutils-2.1.10/gui/templates/unit_file.py
--- policycoreutils-2.1.10/gui/templates/unit_file.py.gui 2012-02-01 08:40:34.733252831 -0500
+++ policycoreutils-2.1.10/gui/templates/unit_file.py 2012-02-01 08:40:28.444248042 -0500
@@ -0,0 +1,69 @@
+# Copyright (C) 2012 Red Hat
+# see file 'COPYING' for use and warranty information
+#
+# policygentool is a tool for the initial generation of SELinux policy
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA
+#
+#
+########################### unit Template File #############################
+
+########################### Type Enforcement File #############################
+te_types="""
+type TEMPLATETYPE_unit_file_t;
+files_type(TEMPLATETYPE_unit_file_t)
+"""
+
+te_rules=""
+
+########################### Interface File #############################
+if_rules="""\
+########################################
+## <summary>
+## Execute TEMPLATETYPE server in the TEMPLATETYPE domain.
+## </summary>
+## <param name="domain">
+## <summary>
+## Domain allowed to transition.
+## </summary>
+## </param>
+#
+interface(`TEMPLATETYPE_systemctl',`
+ gen_require(`
+ type TEMPLATETYPE_t;
+ type TEMPLATETYPE_unit_file_t;
+ ')
+
+ systemd_exec_systemctl($1)
+ allow $1 TEMPLATETYPE_unit_file_t:file read_file_perms;
+ allow $1 TEMPLATETYPE_unit_file_t:service all_service_perms;
+
+ ps_process_pattern($1, TEMPLATETYPE_t)
+')
+
+"""
+
+if_admin_types="""
+ type TEMPLATETYPE_unit_file_t;"""
+
+if_admin_rules="""
+ TEMPLATETYPE_systemctl($1)
+"""
+
+########################### File Context ##################################
+fc_file="""\
+FILENAME -- gen_context(system_u:object_r:TEMPLATETYPE_unit_file_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/templates/user.py.gui policycoreutils-2.1.10/gui/templates/user.py
--- policycoreutils-2.1.10/gui/templates/user.py.gui 2012-01-15 16:48:40.234095742 -0500
+++ policycoreutils-2.1.10/gui/templates/user.py 2012-01-15 16:48:48.560096233 -0500
--- policycoreutils-2.1.10/gui/templates/user.py.gui 2012-02-01 08:39:50.159218054 -0500
+++ policycoreutils-2.1.10/gui/templates/user.py 2012-02-01 08:39:50.159218054 -0500
@@ -0,0 +1,204 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -13465,8 +13538,8 @@ diff -up policycoreutils-2.1.10/gui/templates/user.py.gui policycoreutils-2.1.10
+seutil_run_newrole(TEMPLATETYPE_t, TEMPLATETYPE_r)
+"""
diff -up policycoreutils-2.1.10/gui/templates/var_cache.py.gui policycoreutils-2.1.10/gui/templates/var_cache.py
--- policycoreutils-2.1.10/gui/templates/var_cache.py.gui 2012-01-15 16:48:40.234095742 -0500
+++ policycoreutils-2.1.10/gui/templates/var_cache.py 2012-01-15 16:48:48.560096233 -0500
--- policycoreutils-2.1.10/gui/templates/var_cache.py.gui 2012-02-01 08:39:50.159218054 -0500
+++ policycoreutils-2.1.10/gui/templates/var_cache.py 2012-02-01 08:39:50.159218054 -0500
@@ -0,0 +1,132 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -13601,8 +13674,8 @@ diff -up policycoreutils-2.1.10/gui/templates/var_cache.py.gui policycoreutils-2
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_cache_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/templates/var_lib.py.gui policycoreutils-2.1.10/gui/templates/var_lib.py
--- policycoreutils-2.1.10/gui/templates/var_lib.py.gui 2012-01-15 16:48:40.234095742 -0500
+++ policycoreutils-2.1.10/gui/templates/var_lib.py 2012-01-15 16:48:48.560096233 -0500
--- policycoreutils-2.1.10/gui/templates/var_lib.py.gui 2012-02-01 08:39:50.160218055 -0500
+++ policycoreutils-2.1.10/gui/templates/var_lib.py 2012-02-01 08:39:50.160218055 -0500
@@ -0,0 +1,160 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -13765,8 +13838,8 @@ diff -up policycoreutils-2.1.10/gui/templates/var_lib.py.gui policycoreutils-2.1
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_var_lib_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/templates/var_log.py.gui policycoreutils-2.1.10/gui/templates/var_log.py
--- policycoreutils-2.1.10/gui/templates/var_log.py.gui 2012-01-15 16:48:40.235095742 -0500
+++ policycoreutils-2.1.10/gui/templates/var_log.py 2012-01-15 16:48:48.560096233 -0500
--- policycoreutils-2.1.10/gui/templates/var_log.py.gui 2012-02-01 08:39:50.160218055 -0500
+++ policycoreutils-2.1.10/gui/templates/var_log.py 2012-02-01 08:39:50.161218056 -0500
@@ -0,0 +1,114 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -13883,8 +13956,8 @@ diff -up policycoreutils-2.1.10/gui/templates/var_log.py.gui policycoreutils-2.1
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_log_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/templates/var_run.py.gui policycoreutils-2.1.10/gui/templates/var_run.py
--- policycoreutils-2.1.10/gui/templates/var_run.py.gui 2012-01-15 16:48:40.235095742 -0500
+++ policycoreutils-2.1.10/gui/templates/var_run.py 2012-01-15 16:48:48.560096233 -0500
--- policycoreutils-2.1.10/gui/templates/var_run.py.gui 2012-02-01 08:39:50.161218056 -0500
+++ policycoreutils-2.1.10/gui/templates/var_run.py 2012-02-01 08:39:50.161218056 -0500
@@ -0,0 +1,101 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -13988,8 +14061,8 @@ diff -up policycoreutils-2.1.10/gui/templates/var_run.py.gui policycoreutils-2.1
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_var_run_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/templates/var_spool.py.gui policycoreutils-2.1.10/gui/templates/var_spool.py
--- policycoreutils-2.1.10/gui/templates/var_spool.py.gui 2012-01-15 16:48:40.235095742 -0500
+++ policycoreutils-2.1.10/gui/templates/var_spool.py 2012-01-15 16:48:48.560096233 -0500
--- policycoreutils-2.1.10/gui/templates/var_spool.py.gui 2012-02-01 08:39:50.162218057 -0500
+++ policycoreutils-2.1.10/gui/templates/var_spool.py 2012-02-01 08:39:50.162218057 -0500
@@ -0,0 +1,131 @@
+# Copyright (C) 2007-2012 Red Hat
+# see file 'COPYING' for use and warranty information
@ -14123,8 +14196,8 @@ diff -up policycoreutils-2.1.10/gui/templates/var_spool.py.gui policycoreutils-2
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_spool_t,s0)
+"""
diff -up policycoreutils-2.1.10/gui/usersPage.py.gui policycoreutils-2.1.10/gui/usersPage.py
--- policycoreutils-2.1.10/gui/usersPage.py.gui 2012-01-15 16:48:40.235095742 -0500
+++ policycoreutils-2.1.10/gui/usersPage.py 2012-01-15 16:48:40.235095742 -0500
--- policycoreutils-2.1.10/gui/usersPage.py.gui 2012-02-01 08:39:50.162218057 -0500
+++ policycoreutils-2.1.10/gui/usersPage.py 2012-02-01 08:39:50.163218058 -0500
@@ -0,0 +1,150 @@
+## usersPage.py - show selinux mappings
+## Copyright (C) 2006,2007,2008 Red Hat, Inc.

View File

@ -79,3 +79,16 @@ index 1a9a3e5..d56dd92 100644
def __iter__(self):
return iter(self.children)
diff --git a/sepolgen/src/sepolgen/yacc.py b/sepolgen/src/sepolgen/yacc.py
index 2f3c09d..bc4536d 100644
--- a/sepolgen/src/sepolgen/yacc.py
+++ b/sepolgen/src/sepolgen/yacc.py
@@ -506,7 +506,7 @@ def initialize_vars():
Errorfunc = None # User defined error handler
- Signature = hashlib.md5() # Digital signature of the grammar rules, precedence
+ Signature = hashlib.sha256() # Digital signature of the grammar rules, precedence
# and other information. Used to determined when a
# parsing table needs to be regenerated.

View File

@ -7,7 +7,7 @@
Summary: SELinux policy core utilities
Name: policycoreutils
Version: 2.1.10
Release: 18%{?dist}
Release: 20%{?dist}
License: GPLv2
Group: System Environment/Base
# Based on git repository with tag 20101221
@ -356,6 +356,12 @@ fi
%{_bindir}/systemctl try-restart restorecond.service >/dev/null 2>&1 || :
%changelog
* Wed Feb 1 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.10-20
- Add unit_file.py for sepolgen
* Tue Jan 31 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.10-19
- Change sepolgen to use sha256 instead of md5
* Mon Jan 30 2012 Dan Walsh <dwalsh@redhat.com> - 2.1.10-18
- Stop syslogging on full restore
- Stop syslogging when restorecon is not changing values