auto-import changelog data from policycoreutils-1.15.1-1.src.rpm
* Thu Jul 08 2004 Dan Walsh <dwalsh@redhat.com> 1.15.1-1 - Latest from NSA - Fix fixfiles.cron to delete outfile
This commit is contained in:
parent
0ad2425731
commit
984cf332e1
@ -1 +1 @@
|
||||
policycoreutils-1.14.1.tgz
|
||||
policycoreutils-1.15.1.tgz
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- policycoreutils-1.14.1/setfiles/setfiles.c.rhat 2004-06-30 12:03:27.000000000 -0400
|
||||
+++ policycoreutils-1.14.1/setfiles/setfiles.c 2004-07-06 16:44:21.464473808 -0400
|
||||
--- policycoreutils-1.15.1/setfiles/setfiles.c.rhat 2004-07-08 09:27:46.000000000 -0400
|
||||
+++ policycoreutils-1.15.1/setfiles/setfiles.c 2004-07-08 09:29:31.946970574 -0400
|
||||
@@ -654,7 +654,8 @@
|
||||
|
||||
freecon(context);
|
||||
@ -10,8 +10,8 @@
|
||||
fprintf(outfile, "%s\n", my_file);
|
||||
|
||||
/*
|
||||
--- policycoreutils-1.14.1/scripts/Makefile.rhat 2004-06-30 12:03:27.000000000 -0400
|
||||
+++ policycoreutils-1.14.1/scripts/Makefile 2004-06-30 13:14:42.000000000 -0400
|
||||
--- policycoreutils-1.15.1/scripts/Makefile.rhat 2004-07-08 09:27:46.000000000 -0400
|
||||
+++ policycoreutils-1.15.1/scripts/Makefile 2004-07-08 09:29:31.947970458 -0400
|
||||
@@ -12,6 +12,7 @@
|
||||
-mkdir -p $(BINDIR)
|
||||
install -m 755 $(TARGETS) $(BINDIR)
|
||||
@ -20,8 +20,8 @@
|
||||
-mkdir -p $(MANDIR)/man8
|
||||
install -m 644 fixfiles.8.gz $(MANDIR)/man8/
|
||||
|
||||
--- policycoreutils-1.14.1/scripts/fixfiles.cron.rhat 2004-06-30 13:12:42.000000000 -0400
|
||||
+++ policycoreutils-1.14.1/scripts/fixfiles.cron 2004-07-06 16:12:48.000000000 -0400
|
||||
--- /dev/null 2004-06-21 15:29:38.000000000 -0400
|
||||
+++ policycoreutils-1.15.1/scripts/fixfiles.cron 2004-07-08 09:30:32.796920099 -0400
|
||||
@@ -0,0 +1,22 @@
|
||||
+#!/bin/sh
|
||||
+
|
||||
@ -40,13 +40,13 @@
|
||||
+ renice +19 -p $$ >/dev/null 2>&1
|
||||
+ OUTFILE=`mktemp ${INVALIDFILE}.XXXXXXXXXX` || exit 1
|
||||
+ /sbin/fixfiles -l /dev/null -o $OUTFILE $CRONTYPE
|
||||
+ mv -f $OUTFILE $INVALIDFILE
|
||||
+ if [ -s $INVALIDFILE ]; then
|
||||
+ mail ${MAILTO} -s "Invalid File Contexts" < $INVALIDFILE
|
||||
+ if [ -s $OUTFILE ]; then
|
||||
+ mail ${MAILTO} -s "Invalid File Contexts" < $OUTFILE
|
||||
+ fi
|
||||
+ rm -f $OUTFILE
|
||||
+fi
|
||||
--- policycoreutils-1.14.1/scripts/fixfiles.rhat 2004-06-30 13:10:21.000000000 -0400
|
||||
+++ policycoreutils-1.14.1/scripts/fixfiles 2004-07-06 16:29:00.000000000 -0400
|
||||
--- policycoreutils-1.15.1/scripts/fixfiles.rhat 2004-07-08 09:27:46.000000000 -0400
|
||||
+++ policycoreutils-1.15.1/scripts/fixfiles 2004-07-08 09:29:31.949970225 -0400
|
||||
@@ -19,25 +19,37 @@
|
||||
# You should have received a copy of the GNU General Public License
|
||||
# along with this program; if not, write to the Free Software
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: SELinux policy core utilities.
|
||||
Name: policycoreutils
|
||||
Version: 1.14.1
|
||||
Release: 3
|
||||
Version: 1.15.1
|
||||
Release: 1
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -75,6 +75,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 8 2004 Dan Walsh <dwalsh@redhat.com> 1.15.1-1
|
||||
- Latest from NSA
|
||||
- Fix fixfiles.cron to delete outfile
|
||||
|
||||
* Tue Jul 6 2004 Dan Walsh <dwalsh@redhat.com> 1.14.1-2
|
||||
- Fix fixfiles.cron to not run on non SELinux boxes
|
||||
- Fix several problems in fixfiles and fixfiles.cron
|
||||
|
Loading…
Reference in New Issue
Block a user