* Tue Mar 18 2008 Dan Walsh <dwalsh@redhat.com> 2.0.46-1
- Update to upstream * Update audit2allow to report dontaudit cases from Dan Walsh. * Fix semanage port to use --proto from Caleb Case.
This commit is contained in:
parent
ea11570a87
commit
7d1caca617
@ -176,3 +176,4 @@ policycoreutils-2.0.41.tgz
|
||||
policycoreutils-2.0.42.tgz
|
||||
policycoreutils-2.0.43.tgz
|
||||
policycoreutils-2.0.44.tgz
|
||||
policycoreutils-2.0.46.tgz
|
||||
|
@ -1,30 +1,15 @@
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-2.0.42/audit2allow/audit2allow
|
||||
--- nsapolicycoreutils/audit2allow/audit2allow 2008-01-28 16:52:25.000000000 -0500
|
||||
+++ policycoreutils-2.0.42/audit2allow/audit2allow 2008-02-08 10:43:47.000000000 -0500
|
||||
@@ -247,6 +247,11 @@
|
||||
print "\t\tPossible mismatch between this policy and the one under which the audit message was generated.\n"
|
||||
print "\t\tPossible mismatch between current in-memory boolean settings vs. permanent ones.\n"
|
||||
continue
|
||||
+ if rc == audit2why.DONTAUDIT:
|
||||
+ print "\t\tUnknown - should be dontaudit'd by active policy\n",
|
||||
+ print "\t\tPossible mismatch between this policy and the one under which the audit message was generated.\n"
|
||||
+ print "\t\tPossible mismatch between current in-memory boolean settings vs. permanent ones.\n"
|
||||
+ continue
|
||||
if rc == audit2why.BOOLEAN:
|
||||
if len(bools) > 1:
|
||||
print "\tOne of the following booleans was set incorrectly."
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.42/Makefile
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.44/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2007-12-19 06:02:52.000000000 -0500
|
||||
+++ policycoreutils-2.0.42/Makefile 2008-02-05 16:09:43.000000000 -0500
|
||||
+++ policycoreutils-2.0.44/Makefile 2008-03-18 11:22:52.000000000 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||
+SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||
|
||||
INOTIFYH = $(shell ls /usr/include/sys/inotify.h 2>/dev/null)
|
||||
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.42/restorecond/restorecond.c
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.44/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.42/restorecond/restorecond.c 2008-02-05 16:09:43.000000000 -0500
|
||||
+++ policycoreutils-2.0.44/restorecond/restorecond.c 2008-03-18 11:22:52.000000000 -0400
|
||||
@@ -210,9 +210,10 @@
|
||||
}
|
||||
|
||||
|
@ -5,7 +5,7 @@
|
||||
%define sepolgenver 1.0.11
|
||||
Summary: SELinux policy core utilities
|
||||
Name: policycoreutils
|
||||
Version: 2.0.44
|
||||
Version: 2.0.46
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -192,6 +192,11 @@ if [ "$1" -ge "1" ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Mar 18 2008 Dan Walsh <dwalsh@redhat.com> 2.0.46-1
|
||||
- Update to upstream
|
||||
* Update audit2allow to report dontaudit cases from Dan Walsh.
|
||||
* Fix semanage port to use --proto from Caleb Case.
|
||||
|
||||
* Fri Feb 22 2008 Dan Walsh <dwalsh@redhat.com> 2.0.44-1
|
||||
- Update to upstream
|
||||
* Fix for segfault when conf file parse error occurs.
|
||||
|
Loading…
Reference in New Issue
Block a user