diff --git a/policycoreutils-rhat.patch b/policycoreutils-rhat.patch
index 087da7d..41dbeb3 100644
--- a/policycoreutils-rhat.patch
+++ b/policycoreutils-rhat.patch
@@ -1,6 +1,6 @@
 diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/genhomedircon policycoreutils-1.27.26/scripts/genhomedircon
 --- nsapolicycoreutils/scripts/genhomedircon	2005-09-12 16:33:30.000000000 -0400
-+++ policycoreutils-1.27.26/scripts/genhomedircon	2005-11-09 14:11:49.000000000 -0500
++++ policycoreutils-1.27.26/scripts/genhomedircon	2005-11-09 16:08:15.000000000 -0500
 @@ -15,30 +15,16 @@
  # The file CONTEXTDIR/files/homedir_template exists.  This file is used to
  # set up the home directory context for each real user.
@@ -230,7 +230,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/genhomedircon po
  		if rc[0] == 0:
  			users+=rc[1]
  		udict = {}
-@@ -336,24 +153,24 @@
+@@ -336,24 +153,27 @@
  		if users != "":
  			ulist = users.split("\n")
  			for u in ulist:
@@ -240,7 +240,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/genhomedircon po
 +				user = u.split(":")
  				try:
 -					if len(user)==0 or user[1] == "user_u" or user[1] == "system_u":
-+					if len(user)==0 or user[1] == "user_u" or user[1] == "root":
++					if len(user)==0 or user[1] == "user_u":
  						continue
  					# !!! chooses first role in the list to use in the file context !!!
 -					role = user[3]
@@ -248,7 +248,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/genhomedircon po
 -						role = user[4]
 -					role = role.split("_r")[0]
 -					home = pwd.getpwnam(user[1])[5]
-+					role = user[1]
++					if user[0] == "root":
++						role="user_u"
++					else:
++						role = user[1]
 +					role = role.split("_u")[0]
 +					home = pwd.getpwnam(user[0])[5]
  					if home == "/":
@@ -264,7 +267,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/genhomedircon po
  		return udict
  
  	def getHomeDirContext(self, user, home, role):
-@@ -478,10 +295,6 @@
+@@ -478,10 +298,6 @@
  	if type==None:
  		type=getSELinuxType(directory)
  
diff --git a/policycoreutils.spec b/policycoreutils.spec
index ac1d179..38f10ea 100644
--- a/policycoreutils.spec
+++ b/policycoreutils.spec
@@ -3,7 +3,7 @@
 Summary: SELinux policy core utilities.
 Name: policycoreutils
 Version: 1.27.26
-Release: 2
+Release: 3
 License: GPL
 Group: System Environment/Base
 Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@@ -86,8 +86,8 @@ rm -rf ${RPM_BUILD_ROOT}
 %config(noreplace) %{_sysconfdir}/sestatus.conf
 
 %changelog
-* Wed Nov 9 2005 Dan Walsh <dwalsh@redhat.com> 1.27.26-2
-- Fix genhomedircon to use seusers file
+* Wed Nov 9 2005 Dan Walsh <dwalsh@redhat.com> 1.27.26-3
+- Fix genhomedircon to use seusers file, temporary fix until swigified semanage
 
 * Tue Nov 8 2005 Dan Walsh <dwalsh@redhat.com> 1.27.26-1
 	* Added -B (--build) option to semodule to force a rebuild.