* Wed Jan 24 2007 Dan Walsh <dwalsh@redhat.com> 1.34.1-2
- Change chcat to exec semodule so file context is maintained
This commit is contained in:
parent
a43d594198
commit
76e419bed5
@ -1,6 +1,6 @@
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-1.33.15/gui/booleansPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-1.34.1/gui/booleansPage.py
|
||||
--- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/booleansPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/booleansPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,199 @@
|
||||
+#
|
||||
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel
|
||||
@ -201,9 +201,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+
|
||||
+ setsebool="/usr/sbin/setsebool -P %s=%d" % (key, not val)
|
||||
+ commands.getstatusoutput(setsebool)
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-1.33.15/gui/fcontextPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-1.34.1/gui/fcontextPage.py
|
||||
--- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/fcontextPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/fcontextPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,158 @@
|
||||
+## fcontextPage.py - show selinux mappings
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -363,9 +363,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ self.store.set_value(iter, 0, fspec)
|
||||
+ self.store.set_value(iter, 2, ftype)
|
||||
+ self.store.set_value(iter, 1, "system_u:object_r:%s:%s" % (type, mls))
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-1.33.15/gui/loginsPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-1.34.1/gui/loginsPage.py
|
||||
--- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/loginsPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/loginsPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,161 @@
|
||||
+## loginsPage.py - show selinux mappings
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -528,9 +528,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ self.store.set_value(iter, 1, seuser)
|
||||
+ self.store.set_value(iter, 2, seobject.translate(serange))
|
||||
+
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-1.33.15/gui/Makefile
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-1.34.1/gui/Makefile
|
||||
--- nsapolicycoreutils/gui/Makefile 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/Makefile 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/Makefile 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,30 @@
|
||||
+# Installation directories.
|
||||
+PREFIX ?= ${DESTDIR}/usr
|
||||
@ -562,9 +562,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+indent:
|
||||
+
|
||||
+relabel:
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-1.33.15/gui/mappingsPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-1.34.1/gui/mappingsPage.py
|
||||
--- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/mappingsPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/mappingsPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,54 @@
|
||||
+## mappingsPage.py - show selinux mappings
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -620,9 +620,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ for k in keys:
|
||||
+ print "%-25s %-25s %-25s" % (k, dict[k][0], translate(dict[k][1]))
|
||||
+
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-1.33.15/gui/modulesPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-1.34.1/gui/modulesPage.py
|
||||
--- nsapolicycoreutils/gui/modulesPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/modulesPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/modulesPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,161 @@
|
||||
+## modulesPage.py - show selinux mappings
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -785,9 +785,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+
|
||||
+
|
||||
+
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-1.33.15/gui/portsPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-1.34.1/gui/portsPage.py
|
||||
--- nsapolicycoreutils/gui/portsPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/portsPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/portsPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,214 @@
|
||||
+## portsPage.py - show selinux mappings
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -1003,9 +1003,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ self.store.set_value(iter, MLS_COL, mls)
|
||||
+
|
||||
+
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-1.33.15/gui/selinux.tbl
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-1.34.1/gui/selinux.tbl
|
||||
--- nsapolicycoreutils/gui/selinux.tbl 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/selinux.tbl 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/selinux.tbl 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,265 @@
|
||||
+acct_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for acct daemon")
|
||||
+allow_cvs_read_shadow _("CVS") _("Allow cvs daemon to read shadow")
|
||||
@ -1272,9 +1272,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ypserv_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for ypserv daemon")
|
||||
+ypxfr_disable_trans _("NIS") _("Disable SELinux protection for NIS Transfer Daemon")
|
||||
+zebra_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for zebra daemon")
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-1.33.15/gui/semanagePage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-1.34.1/gui/semanagePage.py
|
||||
--- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/semanagePage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/semanagePage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,109 @@
|
||||
+## semanagePage.py - show selinux mappings
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -1385,9 +1385,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ self.dialog.hide()
|
||||
+
|
||||
+
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-1.33.15/gui/statusPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-1.34.1/gui/statusPage.py
|
||||
--- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/statusPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/statusPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,213 @@
|
||||
+## statusPage.py - show selinux status
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -1602,9 +1602,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ return self.types[self.selinuxTypeOptionMenu.get_active()]
|
||||
+
|
||||
+
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-1.33.15/gui/system-config-selinux.glade
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-1.34.1/gui/system-config-selinux.glade
|
||||
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/system-config-selinux.glade 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/system-config-selinux.glade 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,2803 @@
|
||||
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
|
||||
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
|
||||
@ -4409,9 +4409,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+</widget>
|
||||
+
|
||||
+</glade-interface>
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-1.33.15/gui/system-config-selinux.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-1.34.1/gui/system-config-selinux.py
|
||||
--- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/system-config-selinux.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/system-config-selinux.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,156 @@
|
||||
+#!/usr/bin/python
|
||||
+#
|
||||
@ -4569,9 +4569,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+
|
||||
+ app = childWindow()
|
||||
+ app.stand_alone()
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-1.33.15/gui/translationsPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-1.34.1/gui/translationsPage.py
|
||||
--- nsapolicycoreutils/gui/translationsPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/translationsPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/translationsPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,109 @@
|
||||
+## translationsPage.py - show selinux translations
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -4682,9 +4682,9 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ store, iter = self.view.get_selection().get_selected()
|
||||
+ self.store.set_value(iter, 0, level)
|
||||
+ self.store.set_value(iter, 1, translation)
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-1.33.15/gui/usersPage.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-1.34.1/gui/usersPage.py
|
||||
--- nsapolicycoreutils/gui/usersPage.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/gui/usersPage.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/gui/usersPage.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -0,0 +1,155 @@
|
||||
+## usersPage.py - show selinux mappings
|
||||
+## Copyright (C) 2006 Red Hat, Inc.
|
||||
@ -4841,18 +4841,30 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
+ except ValueError, e:
|
||||
+ self.error(e.args[0])
|
||||
+
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.33.15/Makefile
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.34.1/Makefile
|
||||
--- nsapolicycoreutils/Makefile 2006-11-16 17:15:00.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/Makefile 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/Makefile 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
|
||||
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
|
||||
|
||||
all install relabel clean indent:
|
||||
@for subdir in $(SUBDIRS); do \
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-1.33.15/restorecond/restorecond.c
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/po/Makefile policycoreutils-1.34.1/po/Makefile
|
||||
--- nsapolicycoreutils/po/Makefile 2007-01-19 08:50:12.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/po/Makefile 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -36,7 +36,7 @@
|
||||
|
||||
#default:: clean
|
||||
|
||||
-all:: $(MOFILES)
|
||||
+all:: update-po $(MOFILES)
|
||||
|
||||
$(POTFILE): $(POTFILES)
|
||||
$(XGETTEXT) --keyword=_ --keyword=N_ $(POTFILES)
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-1.34.1/restorecond/restorecond.c
|
||||
--- nsapolicycoreutils/restorecond/restorecond.c 2006-11-16 17:14:28.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/restorecond/restorecond.c 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/restorecond/restorecond.c 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -210,9 +210,10 @@
|
||||
}
|
||||
|
||||
@ -4879,18 +4891,86 @@ diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.
|
||||
}
|
||||
free(scontext);
|
||||
close(fd);
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/restorecond/restorecond.conf policycoreutils-1.33.15/restorecond/restorecond.conf
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/restorecond/restorecond.conf policycoreutils-1.34.1/restorecond/restorecond.conf
|
||||
--- nsapolicycoreutils/restorecond/restorecond.conf 2006-11-20 12:19:55.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/restorecond/restorecond.conf 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/restorecond/restorecond.conf 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -1,4 +1,5 @@
|
||||
/etc/resolv.conf
|
||||
+/etc/localtime
|
||||
/etc/samba/secrets.tdb
|
||||
/etc/mtab
|
||||
/var/run/utmp
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.33.15/semanage/seobject.py
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-1.34.1/scripts/chcat
|
||||
--- nsapolicycoreutils/scripts/chcat 2006-11-16 17:14:27.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/scripts/chcat 2007-01-24 14:33:58.000000000 -0500
|
||||
@@ -62,12 +62,20 @@
|
||||
for i in newcat[1:]:
|
||||
if i not in cats:
|
||||
cats.append(i)
|
||||
+
|
||||
new_serange = "%s-%s:%s" % (serange[0], top[0], string.join(cats, ","))
|
||||
-
|
||||
+ if new_serange[-1:] == ":":
|
||||
+ new_serange = new_serange[:-1]
|
||||
+
|
||||
if add_ind:
|
||||
- logins.add(u, user[0], new_serange)
|
||||
+ cmd = "semanage login -a -r %s -s %s %s" % (new_serange, user[0], u)
|
||||
else:
|
||||
- logins.modify(u, user[0], new_serange)
|
||||
+ cmd = "semanage login -m -r %s -s %s %s" % (new_serange, user[0], u)
|
||||
+ rc = commands.getstatusoutput(cmd)
|
||||
+ if rc[0] != 0:
|
||||
+ print rc[1]
|
||||
+ errors += 1
|
||||
+
|
||||
return errors
|
||||
|
||||
def chcat_add(orig, newcat, objects,login_ind):
|
||||
@@ -133,11 +141,17 @@
|
||||
cats.remove(i)
|
||||
|
||||
new_serange = "%s-%s:%s" % (serange[0], top[0], string.join(cats, ","))
|
||||
+ if new_serange[-1:] == ":":
|
||||
+ new_serange = new_serange[:-1]
|
||||
|
||||
if add_ind:
|
||||
- logins.add(u, user[0], new_serange)
|
||||
+ cmd = "semanage login -a -r %s -s %s %s" % (new_serange, user[0], u)
|
||||
else:
|
||||
- logins.modify(u, user[0], new_serange)
|
||||
+ cmd = "semanage login -m -r %s -s %s %s" % (new_serange, user[0], u)
|
||||
+ rc = commands.getstatusoutput(cmd)
|
||||
+ if rc[0] != 0:
|
||||
+ print rc[1]
|
||||
+ errors += 1
|
||||
return errors
|
||||
|
||||
def chcat_remove(orig, newcat, objects, login_ind):
|
||||
@@ -198,11 +212,17 @@
|
||||
user = seusers["__default__"]
|
||||
serange = user[1].split("-")
|
||||
new_serange = "%s-%s:%s" % (serange[0],newcat[0], string.join(newcat[1:], ","))
|
||||
-
|
||||
+ if new_serange[-1:] == ":":
|
||||
+ new_serange = new_serange[:-1]
|
||||
+
|
||||
if add_ind:
|
||||
- logins.add(u, user[0], new_serange)
|
||||
+ cmd = "semanage login -a -r %s -s %s %s" % (new_serange, user[0], u)
|
||||
else:
|
||||
- logins.modify(u, user[0], new_serange)
|
||||
+ cmd = "semanage login -m -r %s -s %s %s" % (new_serange, user[0], u)
|
||||
+ rc = commands.getstatusoutput(cmd)
|
||||
+ if rc[0] != 0:
|
||||
+ print rc[1]
|
||||
+ errors += 1
|
||||
return errors
|
||||
|
||||
def chcat_replace(newcat, objects, login_ind):
|
||||
diff --exclude-from=exclude --exclude POTFILES.in --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.34.1/semanage/seobject.py
|
||||
--- nsapolicycoreutils/semanage/seobject.py 2007-01-17 11:11:34.000000000 -0500
|
||||
+++ policycoreutils-1.33.15/semanage/seobject.py 2007-01-24 09:58:03.000000000 -0500
|
||||
+++ policycoreutils-1.34.1/semanage/seobject.py 2007-01-24 10:05:24.000000000 -0500
|
||||
@@ -209,7 +209,8 @@
|
||||
os.write(fd, self.out())
|
||||
os.close(fd)
|
||||
|
@ -5,7 +5,7 @@
|
||||
Summary: SELinux policy core utilities.
|
||||
Name: policycoreutils
|
||||
Version: 1.34.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -168,6 +168,9 @@ fi
|
||||
[ -x /sbin/service ] && /sbin/service restorecond condrestart > /dev/null
|
||||
|
||||
%changelog
|
||||
* Wed Jan 24 2007 Dan Walsh <dwalsh@redhat.com> 1.34.1-2
|
||||
- Change chcat to exec semodule so file context is maintained
|
||||
|
||||
* Wed Jan 24 2007 Dan Walsh <dwalsh@redhat.com> 1.34.1-1
|
||||
- Fix system-config-selinux ports view
|
||||
- Update to upstream
|
||||
|
Loading…
Reference in New Issue
Block a user