* Tue Jan 29 2008 Dan Walsh <dwalsh@redhat.com> 2.0.41-1
- Update to upstream * Merged audit2why fix and semanage boolean --on/--off/-1/-0 support from Dan Walsh. * Merged a second fixfiles -C fix from Marshall Miller.
This commit is contained in:
parent
dc637d77fd
commit
75c4c38f00
@ -172,3 +172,4 @@ policycoreutils-2.0.37.tgz
|
|||||||
sepolgen-1.0.11.tgz
|
sepolgen-1.0.11.tgz
|
||||||
policycoreutils-2.0.38.tgz
|
policycoreutils-2.0.38.tgz
|
||||||
policycoreutils-2.0.39.tgz
|
policycoreutils-2.0.39.tgz
|
||||||
|
policycoreutils-2.0.41.tgz
|
||||||
|
@ -1,15 +1,3 @@
|
|||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-2.0.38/audit2allow/audit2allow
|
|
||||||
--- nsapolicycoreutils/audit2allow/audit2allow 2008-01-24 14:41:25.000000000 -0500
|
|
||||||
+++ policycoreutils-2.0.38/audit2allow/audit2allow 2008-01-25 11:12:17.000000000 -0500
|
|
||||||
@@ -221,7 +221,7 @@
|
|
||||||
import selinux
|
|
||||||
import selinux.audit2why as audit2why
|
|
||||||
import seobject
|
|
||||||
- audit2why.init("%s.%s" % (selinux.selinux_binary_policy_path(), selinux.security_policyvers()))
|
|
||||||
+ audit2why.init()
|
|
||||||
for i in self.__parser.avc_msgs:
|
|
||||||
rc, bools = audit2why.analyze(i.scontext.to_string(), i.tcontext.to_string(), i.tclass, i.accesses)
|
|
||||||
if rc >= 0:
|
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.38/Makefile
|
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.38/Makefile
|
||||||
--- nsapolicycoreutils/Makefile 2007-12-19 06:02:52.000000000 -0500
|
--- nsapolicycoreutils/Makefile 2007-12-19 06:02:52.000000000 -0500
|
||||||
+++ policycoreutils-2.0.38/Makefile 2008-01-24 15:31:27.000000000 -0500
|
+++ policycoreutils-2.0.38/Makefile 2008-01-24 15:31:27.000000000 -0500
|
||||||
@ -48,54 +36,3 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po
|
|||||||
}
|
}
|
||||||
free(scontext);
|
free(scontext);
|
||||||
close(fd);
|
close(fd);
|
||||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.11 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.38/semanage/semanage
|
|
||||||
--- nsapolicycoreutils/semanage/semanage 2008-01-23 14:36:28.000000000 -0500
|
|
||||||
+++ policycoreutils-2.0.38/semanage/semanage 2008-01-24 15:31:27.000000000 -0500
|
|
||||||
@@ -111,7 +111,7 @@
|
|
||||||
valid_option["translation"] = []
|
|
||||||
valid_option["translation"] += valid_everyone + [ '-T', '--trans' ]
|
|
||||||
valid_option["boolean"] = []
|
|
||||||
- valid_option["boolean"] += valid_everyone
|
|
||||||
+ valid_option["boolean"] += valid_everyone + [ '--on', "--off", "-1", "-0" ]
|
|
||||||
return valid_option
|
|
||||||
|
|
||||||
#
|
|
||||||
@@ -131,7 +131,7 @@
|
|
||||||
seuser = ""
|
|
||||||
prefix = ""
|
|
||||||
heading=1
|
|
||||||
-
|
|
||||||
+ value=0
|
|
||||||
add = 0
|
|
||||||
modify = 0
|
|
||||||
delete = 0
|
|
||||||
@@ -150,7 +150,7 @@
|
|
||||||
args = sys.argv[2:]
|
|
||||||
|
|
||||||
gopts, cmds = getopt.getopt(args,
|
|
||||||
- 'adf:lhmnp:s:CDR:L:r:t:T:P:S:',
|
|
||||||
+ '01adf:lhmnp:s:CDR:L:r:t:T:P:S:',
|
|
||||||
['add',
|
|
||||||
'delete',
|
|
||||||
'deleteall',
|
|
||||||
@@ -160,6 +160,8 @@
|
|
||||||
'modify',
|
|
||||||
'noheading',
|
|
||||||
'localist',
|
|
||||||
+ 'off',
|
|
||||||
+ 'on',
|
|
||||||
'proto=',
|
|
||||||
'seuser=',
|
|
||||||
'store=',
|
|
||||||
@@ -238,6 +240,11 @@
|
|
||||||
if o == "-T" or o == "--trans":
|
|
||||||
setrans = a
|
|
||||||
|
|
||||||
+ if o == "--on" or o == "-1":
|
|
||||||
+ value = 1
|
|
||||||
+ if o == "-off" or o == "-0":
|
|
||||||
+ value = 0
|
|
||||||
+
|
|
||||||
if object == "login":
|
|
||||||
OBJECT = seobject.loginRecords(store)
|
|
||||||
|
|
||||||
|
@ -5,7 +5,7 @@
|
|||||||
%define sepolgenver 1.0.11
|
%define sepolgenver 1.0.11
|
||||||
Summary: SELinux policy core utilities
|
Summary: SELinux policy core utilities
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 2.0.39
|
Version: 2.0.41
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -193,6 +193,12 @@ if [ "$1" -ge "1" ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 29 2008 Dan Walsh <dwalsh@redhat.com> 2.0.41-1
|
||||||
|
- Update to upstream
|
||||||
|
* Merged audit2why fix and semanage boolean --on/--off/-1/-0 support from Dan Walsh.
|
||||||
|
* Merged a second fixfiles -C fix from Marshall Miller.
|
||||||
|
|
||||||
|
|
||||||
* Thu Jan 24 2008 Dan Walsh <dwalsh@redhat.com> 2.0.39-1
|
* Thu Jan 24 2008 Dan Walsh <dwalsh@redhat.com> 2.0.39-1
|
||||||
- Don't initialize audit2allow for audit2why call. Use default
|
- Don't initialize audit2allow for audit2why call. Use default
|
||||||
- Update to upstream
|
- Update to upstream
|
||||||
|
Loading…
Reference in New Issue
Block a user