* Wed Aug 2 2006 Dan Walsh <dwalsh@redhat.com> 1.30.22-2
- Stop restorecond init script when selinux is not enabled
This commit is contained in:
parent
7afda3cb6a
commit
5f19ebe323
@ -1033,3 +1033,26 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/fixfiles policyc
|
||||
check) restore -n -v ;;
|
||||
relabel) relabel;;
|
||||
*)
|
||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/genhomedircon policycoreutils-1.30.22/scripts/genhomedircon
|
||||
--- nsapolicycoreutils/scripts/genhomedircon 2006-08-01 09:47:23.000000000 -0400
|
||||
+++ policycoreutils-1.30.22/scripts/genhomedircon 2006-08-02 14:43:21.000000000 -0400
|
||||
@@ -346,7 +346,7 @@
|
||||
|
||||
if os.getuid() > 0 or os.geteuid() > 0:
|
||||
print _("You must be root to run %s.") % sys.argv[0]
|
||||
- sys.exit(0)
|
||||
+ sys.exit(1)
|
||||
|
||||
#
|
||||
# This script will generate home dir file context
|
||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/semodule_deps/Makefile policycoreutils-1.30.22/semodule_deps/Makefile
|
||||
--- nsapolicycoreutils/semodule_deps/Makefile 2006-08-01 09:47:23.000000000 -0400
|
||||
+++ policycoreutils-1.30.22/semodule_deps/Makefile 2006-08-02 14:33:29.000000000 -0400
|
||||
@@ -17,6 +17,7 @@
|
||||
-mkdir -p $(BINDIR)
|
||||
install -m 755 semodule_deps $(BINDIR)
|
||||
test -d $(MANDIR)/man8 || install -m 755 -d $(MANDIR)/man8
|
||||
+ install -m 644 semodule_deps.8 $(MANDIR)/man8/
|
||||
|
||||
relabel:
|
||||
|
||||
|
@ -76,6 +76,7 @@ rm -rf %{buildroot}
|
||||
%{_bindir}/audit2allow
|
||||
%{_bindir}/chcat
|
||||
%{_bindir}/secon
|
||||
%{_bindir}/semodule_deps
|
||||
%{_bindir}/semodule_expand
|
||||
%{_bindir}/semodule_link
|
||||
%{_bindir}/semodule_package
|
||||
@ -85,6 +86,7 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man8/sestatus.8.gz
|
||||
%{_mandir}/man8/semanage.8.gz
|
||||
%{_mandir}/man8/semodule.8.gz
|
||||
%{_mandir}/man8/semodule_deps.8.gz
|
||||
%{_mandir}/man8/semodule_link.8.gz
|
||||
%{_mandir}/man8/semodule_package.8.gz
|
||||
%{_mandir}/man8/semodule_expand.8.gz
|
||||
|
Loading…
Reference in New Issue
Block a user