* Mon May 16 2005 Dan Walsh <dwalsh@redhat.com> 1.23.9-1
- Update to match NSA * Updated audit2why for sepol_ prefixes on Flask types to avoid namespace collision with libselinux, and to include <selinux/selinux.h> now.
This commit is contained in:
parent
a618e17dc9
commit
49e5ce8ced
@ -35,3 +35,4 @@ policycoreutils-1.23.5.tgz
|
|||||||
policycoreutils-1.23.6.tgz
|
policycoreutils-1.23.6.tgz
|
||||||
policycoreutils-1.23.7.tgz
|
policycoreutils-1.23.7.tgz
|
||||||
policycoreutils-1.23.8.tgz
|
policycoreutils-1.23.8.tgz
|
||||||
|
policycoreutils-1.23.9.tgz
|
||||||
|
@ -1,17 +1,6 @@
|
|||||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-1.23.8/audit2allow/Makefile
|
|
||||||
--- nsapolicycoreutils/audit2allow/Makefile 2005-01-25 10:32:01.000000000 -0500
|
|
||||||
+++ policycoreutils-1.23.8/audit2allow/Makefile 2005-05-13 15:30:55.000000000 -0400
|
|
||||||
@@ -13,7 +13,6 @@
|
|
||||||
install -m 755 $(TARGETS) $(BINDIR)
|
|
||||||
-mkdir -p $(MANDIR)/man1
|
|
||||||
install -m 644 audit2allow.1 $(MANDIR)/man1/
|
|
||||||
-
|
|
||||||
clean:
|
|
||||||
|
|
||||||
relabel:
|
|
||||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2why/audit2why.1 policycoreutils-1.23.8/audit2why/audit2why.1
|
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2why/audit2why.1 policycoreutils-1.23.8/audit2why/audit2why.1
|
||||||
--- nsapolicycoreutils/audit2why/audit2why.1 1969-12-31 19:00:00.000000000 -0500
|
--- nsapolicycoreutils/audit2why/audit2why.1 1969-12-31 19:00:00.000000000 -0500
|
||||||
+++ policycoreutils-1.23.8/audit2why/audit2why.1 2005-05-13 15:28:05.000000000 -0400
|
+++ policycoreutils-1.23.8/audit2why/audit2why.1 2005-05-16 15:40:04.000000000 -0400
|
||||||
@@ -0,0 +1,62 @@
|
@@ -0,0 +1,62 @@
|
||||||
+.\" Hey, Emacs! This is an -*- nroff -*- source file.
|
+.\" Hey, Emacs! This is an -*- nroff -*- source file.
|
||||||
+.\" Copyright (c) 2005 Dan Walsh <dwalsh@redhat.com>
|
+.\" Copyright (c) 2005 Dan Walsh <dwalsh@redhat.com>
|
||||||
@ -75,21 +64,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2why/audit2why.1 po
|
|||||||
+.I Dan Walsh <dwalsh@redhat.com>,
|
+.I Dan Walsh <dwalsh@redhat.com>,
|
||||||
+.B audit2why
|
+.B audit2why
|
||||||
+utility was written by Stephen Smalley <sds@tycho.nsa.gov>.
|
+utility was written by Stephen Smalley <sds@tycho.nsa.gov>.
|
||||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2why/audit2why.c policycoreutils-1.23.8/audit2why/audit2why.c
|
|
||||||
--- nsapolicycoreutils/audit2why/audit2why.c 2005-05-13 10:56:05.000000000 -0400
|
|
||||||
+++ policycoreutils-1.23.8/audit2why/audit2why.c 2005-05-13 15:17:46.000000000 -0400
|
|
||||||
@@ -36,7 +36,7 @@
|
|
||||||
char *buffer = NULL, *bufcopy = NULL;
|
|
||||||
unsigned int lineno = 0;
|
|
||||||
size_t len = 0, bufcopy_len = 0;
|
|
||||||
- FILE *fp;
|
|
||||||
+ FILE *fp=NULL;
|
|
||||||
int opt, rc, set_path = 0;
|
|
||||||
char *p, *scon, *tcon, *tclassstr, *permstr;
|
|
||||||
security_id_t ssid, tsid;
|
|
||||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2why/Makefile policycoreutils-1.23.8/audit2why/Makefile
|
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2why/Makefile policycoreutils-1.23.8/audit2why/Makefile
|
||||||
--- nsapolicycoreutils/audit2why/Makefile 2005-05-13 10:56:05.000000000 -0400
|
--- nsapolicycoreutils/audit2why/Makefile 2005-05-16 15:40:11.000000000 -0400
|
||||||
+++ policycoreutils-1.23.8/audit2why/Makefile 2005-05-13 15:31:15.000000000 -0400
|
+++ policycoreutils-1.23.8/audit2why/Makefile 2005-05-16 15:40:04.000000000 -0400
|
||||||
@@ -1,6 +1,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
# Installation directories.
|
# Installation directories.
|
||||||
PREFIX ?= ${DESTDIR}/usr
|
PREFIX ?= ${DESTDIR}/usr
|
||||||
@ -98,12 +75,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2why/Makefile polic
|
|||||||
LIBDIR ?= ${PREFIX}/lib
|
LIBDIR ?= ${PREFIX}/lib
|
||||||
MANDIR ?= $(PREFIX)/share/man
|
MANDIR ?= $(PREFIX)/share/man
|
||||||
LOCALEDIR ?= /usr/share/locale
|
LOCALEDIR ?= /usr/share/locale
|
||||||
@@ -16,7 +16,9 @@
|
@@ -17,6 +17,8 @@
|
||||||
|
|
||||||
install: all
|
install: all
|
||||||
-mkdir -p $(BINDIR)
|
-mkdir -p $(BINDIR)
|
||||||
- install -m 755 $(TARGETS) $(SBINDIR)
|
install -m 755 $(TARGETS) $(BINDIR)
|
||||||
+ install -m 755 $(TARGETS) $(BINDIR)
|
|
||||||
+ -mkdir -p $(MANDIR)/man1
|
+ -mkdir -p $(MANDIR)/man1
|
||||||
+ install -m 644 audit2why.1 $(MANDIR)/man1/
|
+ install -m 644 audit2why.1 $(MANDIR)/man1/
|
||||||
|
|
||||||
@ -111,7 +86,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2why/Makefile polic
|
|||||||
rm -f $(TARGETS) *.o
|
rm -f $(TARGETS) *.o
|
||||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-1.23.8/scripts/fixfiles
|
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-1.23.8/scripts/fixfiles
|
||||||
--- nsapolicycoreutils/scripts/fixfiles 2005-04-29 14:11:23.000000000 -0400
|
--- nsapolicycoreutils/scripts/fixfiles 2005-04-29 14:11:23.000000000 -0400
|
||||||
+++ policycoreutils-1.23.8/scripts/fixfiles 2005-05-13 15:17:46.000000000 -0400
|
+++ policycoreutils-1.23.8/scripts/fixfiles 2005-05-16 15:40:04.000000000 -0400
|
||||||
@@ -164,7 +164,7 @@
|
@@ -164,7 +164,7 @@
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
%define libselinuxver 1.23.1-1
|
%define libselinuxver 1.23.1-1
|
||||||
%define libsepolver 1.5.7-1
|
%define libsepolver 1.5.8-1
|
||||||
Summary: SELinux policy core utilities.
|
Summary: SELinux policy core utilities.
|
||||||
Name: policycoreutils
|
Name: policycoreutils
|
||||||
Version: 1.23.8
|
Version: 1.23.9
|
||||||
Release: 1
|
Release: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -84,6 +84,12 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%config(noreplace) %{_sysconfdir}/sestatus.conf
|
%config(noreplace) %{_sysconfdir}/sestatus.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 16 2005 Dan Walsh <dwalsh@redhat.com> 1.23.9-1
|
||||||
|
- Update to match NSA
|
||||||
|
* Updated audit2why for sepol_ prefixes on Flask types to
|
||||||
|
avoid namespace collision with libselinux, and to
|
||||||
|
include <selinux/selinux.h> now.
|
||||||
|
|
||||||
* Fri May 13 2005 Dan Walsh <dwalsh@redhat.com> 1.23.8-1
|
* Fri May 13 2005 Dan Walsh <dwalsh@redhat.com> 1.23.8-1
|
||||||
- Fix fixfiles to accept -f
|
- Fix fixfiles to accept -f
|
||||||
- Update to match NSA
|
- Update to match NSA
|
||||||
|
Loading…
Reference in New Issue
Block a user