diff --git a/policycoreutils-gui.patch b/policycoreutils-gui.patch
index 6690de9..8531ec9 100644
--- a/policycoreutils-gui.patch
+++ b/policycoreutils-gui.patch
@@ -1,6 +1,6 @@
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-2.0.19/gui/booleansPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-2.0.21/gui/booleansPage.py
--- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/booleansPage.py 2007-06-11 12:38:04.000000000 -0400
++++ policycoreutils-2.0.21/gui/booleansPage.py 2007-06-13 16:57:10.000000000 -0400
@@ -0,0 +1,227 @@
+#
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel
@@ -229,9 +229,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py poli
+
+ setsebool="/usr/sbin/setsebool -P %s=%d" % (key, not val)
+ commands.getstatusoutput(setsebool)
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-2.0.19/gui/fcontextPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-2.0.21/gui/fcontextPage.py
--- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/fcontextPage.py 2007-06-11 12:38:08.000000000 -0400
++++ policycoreutils-2.0.21/gui/fcontextPage.py 2007-06-13 16:57:10.000000000 -0400
@@ -0,0 +1,210 @@
+## fcontextPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -443,10 +443,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py poli
+ self.store.set_value(iter, SPEC_COL, fspec)
+ self.store.set_value(iter, FTYPE_COL, ftype)
+ self.store.set_value(iter, TYPE_COL, "system_u:object_r:%s:%s" % (type, mls))
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-2.0.19/gui/loginsPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-2.0.21/gui/loginsPage.py
--- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/loginsPage.py 2007-06-11 12:38:13.000000000 -0400
-@@ -0,0 +1,176 @@
++++ policycoreutils-2.0.21/gui/loginsPage.py 2007-06-13 16:57:11.000000000 -0400
+@@ -0,0 +1,180 @@
+## loginsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@@ -514,17 +514,21 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policy
+ self.loginsSelinuxUserCombo = xml.get_widget("loginsSelinuxUserCombo")
+ self.loginsMLSEntry = xml.get_widget("loginsMLSEntry")
+
-+ def load(self):
++ def load(self, filter = ""):
++ self.filter=filter
+ self.login = seobject.loginRecords()
+ dict = self.login.get_all()
+ keys = dict.keys()
+ keys.sort()
+ self.store.clear()
+ for k in keys:
++ range = seobject.translate(dict[k][1])
++ if not (self.match(k, filter) or self.match(dict[k][0], filter) or self.match(range, filter)):
++ continue
+ iter = self.store.append()
+ self.store.set_value(iter, 0, k)
+ self.store.set_value(iter, 1, dict[k][0])
-+ self.store.set_value(iter, 2, seobject.translate(dict[k][1]))
++ self.store.set_value(iter, 2, range)
+ self.view.get_selection().select_path ((0,))
+
+ def __dialogSetup(self):
@@ -623,9 +627,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policy
+ self.store.set_value(iter, 1, seuser)
+ self.store.set_value(iter, 2, seobject.translate(serange))
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-2.0.19/gui/Makefile
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-2.0.21/gui/Makefile
--- nsapolicycoreutils/gui/Makefile 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/Makefile 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/Makefile 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,34 @@
+# Installation directories.
+PREFIX ?= ${DESTDIR}/usr
@@ -661,9 +665,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/Makefile policycoreu
+indent:
+
+relabel:
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-2.0.19/gui/mappingsPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-2.0.21/gui/mappingsPage.py
--- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/mappingsPage.py 2007-06-11 12:38:18.000000000 -0400
++++ policycoreutils-2.0.21/gui/mappingsPage.py 2007-06-13 16:57:11.000000000 -0400
@@ -0,0 +1,57 @@
+## mappingsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -722,9 +726,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py poli
+ for k in keys:
+ print "%-25s %-25s %-25s" % (k, dict[k][0], translate(dict[k][1]))
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-2.0.19/gui/modulesPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-2.0.21/gui/modulesPage.py
--- nsapolicycoreutils/gui/modulesPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/modulesPage.py 2007-06-11 12:44:16.000000000 -0400
++++ policycoreutils-2.0.21/gui/modulesPage.py 2007-06-13 16:57:12.000000000 -0400
@@ -0,0 +1,182 @@
+## modulesPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -775,7 +779,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py polic
+class modulesPage(semanagePage):
+ def __init__(self, xml):
+ semanagePage.__init__(self, xml, "modules", _("Policy Module"))
-+ self.module_filter = xml.get_widget("moduleFilterEntry")
++ self.module_filter = xml.get_widget("modulesFilterEntry")
+ self.module_filter.connect("focus_out_event", self.filter_changed)
+ self.module_filter.connect("activate", self.filter_changed)
+
@@ -908,9 +912,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py polic
+
+
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.glade policycoreutils-2.0.19/gui/polgen.glade
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.glade policycoreutils-2.0.21/gui/polgen.glade
--- nsapolicycoreutils/gui/polgen.glade 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/polgen.glade 2007-06-11 12:42:40.000000000 -0400
++++ policycoreutils-2.0.21/gui/polgen.glade 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,1168 @@
+
+
@@ -2080,9 +2084,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.glade policyc
+
+
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgengui.py policycoreutils-2.0.19/gui/polgengui.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgengui.py policycoreutils-2.0.21/gui/polgengui.py
--- nsapolicycoreutils/gui/polgengui.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/polgengui.py 2007-06-11 12:38:30.000000000 -0400
++++ policycoreutils-2.0.21/gui/polgengui.py 2007-06-13 16:57:12.000000000 -0400
@@ -0,0 +1,256 @@
+#!/usr/bin/python
+#
@@ -2340,9 +2344,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgengui.py policyc
+
+ app = childWindow()
+ app.stand_alone()
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycoreutils-2.0.19/gui/polgen.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycoreutils-2.0.21/gui/polgen.py
--- nsapolicycoreutils/gui/polgen.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/polgen.py 2007-06-11 12:38:46.000000000 -0400
++++ policycoreutils-2.0.21/gui/polgen.py 2007-06-13 16:57:13.000000000 -0400
@@ -0,0 +1,458 @@
+#! /usr/bin/python
+# Copyright (C) 2007 Red Hat
@@ -2802,9 +2806,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycore
+ sys.exit(0)
+
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-2.0.19/gui/portsPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-2.0.21/gui/portsPage.py
--- nsapolicycoreutils/gui/portsPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/portsPage.py 2007-06-11 12:44:49.000000000 -0400
++++ policycoreutils-2.0.21/gui/portsPage.py 2007-06-13 16:57:13.000000000 -0400
@@ -0,0 +1,248 @@
+## portsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@@ -3054,9 +3058,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/portsPage.py policyc
+ self.store.set_value(iter, MLS_COL, mls)
+
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-2.0.19/gui/selinux.tbl
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-2.0.21/gui/selinux.tbl
--- nsapolicycoreutils/gui/selinux.tbl 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/selinux.tbl 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/selinux.tbl 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,274 @@
+acct_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for acct daemon")
+allow_cvs_read_shadow _("CVS") _("Allow cvs daemon to read shadow")
@@ -3332,10 +3336,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+webadm_manage_users_files _("HTTPD Service") _("Allow httpd to access nfs file systems.")
+webadm_read_users_files _("HTTPD Service") _("Allow httpd to access nfs file systems.")
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-2.0.19/gui/semanagePage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-2.0.21/gui/semanagePage.py
--- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/semanagePage.py 2007-06-11 12:43:46.000000000 -0400
-@@ -0,0 +1,133 @@
++++ policycoreutils-2.0.21/gui/semanagePage.py 2007-06-13 16:57:14.000000000 -0400
+@@ -0,0 +1,137 @@
+## semanagePage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@@ -3384,6 +3388,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py poli
+ self.xml = xml
+ self.view = xml.get_widget("%sView" % name)
+ self.dialog = xml.get_widget("%sDialog" % name)
++ self.filter_entry = xml.get_widget("%sFilterEntry" % name )
++ self.filter_entry.connect("focus_out_event", self.filter_changed)
++ self.filter_entry.connect("activate", self.filter_changed)
++
+ self.view.connect("row_activated", self.rowActivated)
+ self.view.get_selection().connect("changed", self.itemSelected)
+ self.description = description;
@@ -3469,9 +3477,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py poli
+ self.dialog.hide()
+
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-2.0.19/gui/statusPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-2.0.21/gui/statusPage.py
--- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/statusPage.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/statusPage.py 2007-06-13 16:57:14.000000000 -0400
@@ -0,0 +1,220 @@
+## statusPage.py - show selinux status
+## Copyright (C) 2006 Red Hat, Inc.
@@ -3693,10 +3701,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policy
+ return self.types[self.selinuxTypeOptionMenu.get_active()]
+
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-2.0.19/gui/system-config-selinux.glade
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-2.0.21/gui/system-config-selinux.glade
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/system-config-selinux.glade 2007-06-11 12:42:41.000000000 -0400
-@@ -0,0 +1,3209 @@
++++ policycoreutils-2.0.21/gui/system-config-selinux.glade 2007-06-13 16:56:35.000000000 -0400
+@@ -0,0 +1,3326 @@
+
+
+
@@ -3705,6 +3713,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+
+
+
++ 5
+ False
+ system-config-selinux
+ Copyright (c)2006 Red Hat, Inc.
@@ -5966,6 +5975,64 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+
+
+
++
++ True
++ False
++ 0
++
++
++
++ True
++ Filter
++ False
++ False
++ GTK_JUSTIFY_LEFT
++ False
++ False
++ 0.5
++ 0.5
++ 0
++ 0
++ PANGO_ELLIPSIZE_NONE
++ -1
++ False
++ 0
++
++
++ 10
++ False
++ False
++
++
++
++
++
++ True
++ True
++ True
++ True
++ 0
++
++ True
++ •
++ False
++
++
++
++ 0
++ True
++ True
++
++
++
++
++ 5
++ False
++ True
++
++
++
++
+
+ True
+ True
@@ -6094,6 +6161,64 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+
+
+
++
++ True
++ False
++ 0
++
++
++
++ True
++ Filter
++ False
++ False
++ GTK_JUSTIFY_LEFT
++ False
++ False
++ 0.5
++ 0.5
++ 0
++ 0
++ PANGO_ELLIPSIZE_NONE
++ -1
++ False
++ 0
++
++
++ 10
++ False
++ False
++
++
++
++
++
++ True
++ True
++ True
++ True
++ 0
++
++ True
++ •
++ False
++
++
++
++ 0
++ True
++ True
++
++
++
++
++ 5
++ False
++ True
++
++
++
++
+
+ True
+ True
@@ -6791,7 +6916,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+
+
+
-+
++
+ True
+ True
+ True
@@ -6906,9 +7031,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+
+
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-2.0.19/gui/system-config-selinux.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-2.0.21/gui/system-config-selinux.py
--- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/system-config-selinux.py 2007-06-11 12:37:26.000000000 -0400
++++ policycoreutils-2.0.21/gui/system-config-selinux.py 2007-06-13 16:57:15.000000000 -0400
@@ -0,0 +1,172 @@
+#!/usr/bin/python
+#
@@ -7082,9 +7207,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+
+ app = childWindow()
+ app.stand_alone()
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/executable.py policycoreutils-2.0.19/gui/templates/executable.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/executable.py policycoreutils-2.0.21/gui/templates/executable.py
--- nsapolicycoreutils/gui/templates/executable.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/executable.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/executable.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,154 @@
+#! /usr/bin/env python
+# Copyright (C) 2007 Red Hat
@@ -7240,9 +7365,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/executable
+EXECUTABLE -- gen_context(system_u:object_r:TEMPLATETYPE_exec_t,s0)
+"""
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/__init__.py policycoreutils-2.0.19/gui/templates/__init__.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/__init__.py policycoreutils-2.0.21/gui/templates/__init__.py
--- nsapolicycoreutils/gui/templates/__init__.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/__init__.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/__init__.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007 Red Hat, Inc.
@@ -7262,9 +7387,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/__init__.p
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/network.py policycoreutils-2.0.19/gui/templates/network.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/network.py policycoreutils-2.0.21/gui/templates/network.py
--- nsapolicycoreutils/gui/templates/network.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/network.py 2007-06-11 12:45:41.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/network.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,44 @@
+te_port_types="""\
+type TEMPLATETYPE_port_t;
@@ -7310,9 +7435,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/network.py
+allow TEMPLATETYPE_t TEMPLATETYPE_port_t:udp_socket name_bind;
+"""
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/rw.py policycoreutils-2.0.19/gui/templates/rw.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/rw.py policycoreutils-2.0.21/gui/templates/rw.py
--- nsapolicycoreutils/gui/templates/rw.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/rw.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/rw.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,104 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@@ -7418,9 +7543,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/rw.py poli
+fc_dir="""
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_rw_t,s0)
+"""
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/script.py policycoreutils-2.0.19/gui/templates/script.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/script.py policycoreutils-2.0.21/gui/templates/script.py
--- nsapolicycoreutils/gui/templates/script.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/script.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/script.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,42 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@@ -7464,9 +7589,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/script.py
+/usr/sbin/semanage port -a -t TEMPLATETYPE_port_t -p udp PORTNUM
+"""
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/semodule.py policycoreutils-2.0.19/gui/templates/semodule.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/semodule.py policycoreutils-2.0.21/gui/templates/semodule.py
--- nsapolicycoreutils/gui/templates/semodule.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/semodule.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/semodule.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,41 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@@ -7509,9 +7634,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/semodule.p
+semanage ports -a -t TEMPLATETYPE_port_t -p udp PORTNUM
+"""
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/tmp.py policycoreutils-2.0.19/gui/templates/tmp.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/tmp.py policycoreutils-2.0.21/gui/templates/tmp.py
--- nsapolicycoreutils/gui/templates/tmp.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/tmp.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/tmp.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,72 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@@ -7585,9 +7710,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/tmp.py pol
+ dontaudit $1 TEMPLATETYPE_tmp_t:file r_file_perms;
+')
+"""
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_lib.py policycoreutils-2.0.19/gui/templates/var_lib.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_lib.py policycoreutils-2.0.21/gui/templates/var_lib.py
--- nsapolicycoreutils/gui/templates/var_lib.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/var_lib.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/var_lib.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,137 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@@ -7726,9 +7851,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_lib.py
+fc_dir="""\
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_var_lib_t,s0)
+"""
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_log.py policycoreutils-2.0.19/gui/templates/var_log.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_log.py policycoreutils-2.0.21/gui/templates/var_log.py
--- nsapolicycoreutils/gui/templates/var_log.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/var_log.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/var_log.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,89 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@@ -7819,9 +7944,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_log.py
+fc_dir="""\
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_log_t,s0)
+"""
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_run.py policycoreutils-2.0.19/gui/templates/var_run.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_run.py policycoreutils-2.0.21/gui/templates/var_run.py
--- nsapolicycoreutils/gui/templates/var_run.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/var_run.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/var_run.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,95 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@@ -7918,9 +8043,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_run.py
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_var_run_t,s0)
+"""
+
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_spool.py policycoreutils-2.0.19/gui/templates/var_spool.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_spool.py policycoreutils-2.0.21/gui/templates/var_spool.py
--- nsapolicycoreutils/gui/templates/var_spool.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/templates/var_spool.py 2007-06-01 10:29:17.000000000 -0400
++++ policycoreutils-2.0.21/gui/templates/var_spool.py 2007-06-13 09:13:18.000000000 -0400
@@ -0,0 +1,105 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@@ -8027,9 +8152,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_spool.
+fc_dir="""\
+FILENAME(/.*)? gen_context(system_u:object_r:TEMPLATETYPE_spool_t,s0)
+"""
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-2.0.19/gui/translationsPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-2.0.21/gui/translationsPage.py
--- nsapolicycoreutils/gui/translationsPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/translationsPage.py 2007-06-11 12:43:05.000000000 -0400
++++ policycoreutils-2.0.21/gui/translationsPage.py 2007-06-13 16:57:15.000000000 -0400
@@ -0,0 +1,119 @@
+## translationsPage.py - show selinux translations
+## Copyright (C) 2006 Red Hat, Inc.
@@ -8150,10 +8275,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/translationsPage.py
+ store, iter = self.view.get_selection().get_selected()
+ self.store.set_value(iter, 0, level)
+ self.store.set_value(iter, 1, translation)
-diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-2.0.19/gui/usersPage.py
+diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-2.0.21/gui/usersPage.py
--- nsapolicycoreutils/gui/usersPage.py 1969-12-31 19:00:00.000000000 -0500
-+++ policycoreutils-2.0.19/gui/usersPage.py 2007-06-01 10:29:17.000000000 -0400
-@@ -0,0 +1,166 @@
++++ policycoreutils-2.0.21/gui/usersPage.py 2007-06-13 16:57:16.000000000 -0400
+@@ -0,0 +1,173 @@
+## usersPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@@ -8199,6 +8324,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/usersPage.py policyc
+class usersPage(semanagePage):
+ def __init__(self, xml):
+ semanagePage.__init__(self, xml, "users", "SELinux User")
++
+ self.store = gtk.ListStore(gobject.TYPE_STRING, gobject.TYPE_STRING, gobject.TYPE_STRING, gobject.TYPE_STRING, gobject.TYPE_STRING)
+ self.view.set_model(self.store)
+ self.store.set_sort_column_id(0, gtk.SORT_ASCENDING)
@@ -8229,18 +8355,24 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/usersPage.py policyc
+ self.mlsRangeEntry = xml.get_widget("mlsRangeEntry")
+ self.selinuxRolesEntry = xml.get_widget("selinuxRolesEntry")
+
-+ def load(self):
++ def load(self, filter = ""):
++ self.filter=filter
+ self.user = seobject.seluserRecords()
+ dict = self.user.get_all()
+ keys = dict.keys()
+ keys.sort()
+ self.store.clear()
+ for k in keys:
++ level = seobject.translate(dict[k][1])
++ range = seobject.translate(dict[k][2])
++ if not (self.match(k, filter) or self.match(dict[k][0], filter) or self.match(level, filter) or self.match(range, filter) or self.match(dict[k][3], filter)):
++ continue
++
+ iter = self.store.append()
+ self.store.set_value(iter, 0, k)
+ self.store.set_value(iter, 1, dict[k][0])
-+ self.store.set_value(iter, 2, seobject.translate(dict[k][1]))
-+ self.store.set_value(iter, 3, seobject.translate(dict[k][2]))
++ self.store.set_value(iter, 2, level)
++ self.store.set_value(iter, 3, range)
+ self.store.set_value(iter, 4, dict[k][3])
+ self.view.get_selection().select_path ((0,))
+
diff --git a/policycoreutils.spec b/policycoreutils.spec
index 00b19e2..2b04c87 100644
--- a/policycoreutils.spec
+++ b/policycoreutils.spec
@@ -6,7 +6,7 @@
Summary: SELinux policy core utilities.
Name: policycoreutils
Version: 2.0.21
-Release: 1%{?dist}
+Release: 2%{?dist}
License: GPL
Group: System Environment/Base
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@@ -192,6 +192,9 @@ if [ "$1" -ge "1" ]; then
fi
%changelog
+* Wed Jun 13 2007 Dan Walsh 2.0.21-2
+- Add filter to all system-config-selinux lists
+
* Wed Jun 13 2007 Dan Walsh 2.0.21-1
- Update to match NSA
* Fixed setsebool (falling through to error path on success).